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HYPACK SHELL

• Added the Compress Project Folder option to the Compress Project program.
When Compress Project Folder is selected, the entirety of the currently open project 
folder is saved to a ZIP file while preserving the file and folder structure.

To use this option, from the HYPACK® Shell click File -> Compress Project. In the 
Compress Project window, check “Compress Project Folder”, then click [Compress]. The 
Save As window opens to the project folder by default, but you can select a different 
folder to save to. Give the ZIP file a name and click Save.

• Targets deleted in the HYPACK® Shell can now be restored from the Target Editor.
See the Target Editor section in this document for more information.

LINE EDITOR

• Entire lines in the HYPACK Shell can now be moved and rotated. Users can click and 
drag a line to move it in the HYPACK Shell, and they can click and drag an endpoint on a 
line to rotate the selected line.

To use either of these functions:
1. From the HYPACK Shell click Preparation -> Editors -> Line Editor to open the Line Editor 

window.
2. In the Line Editor, add new lines or open a planned line file.
3. From the list of lines on the left, click the line number or name that you want to edit to 

select it. Notice the line will be highlighted with blue arrows in the HYPACK Shell. In this 
example, Line #20 is selected.
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4. Right click on the line number in the list to choose between Move Selected Line or Rotate 
Selected Line from the menu.

5. To move the line, in the HYPACK Shell, click and drag the line to its new location.
The following images show before (left) and after (right) Line 20 was moved.

To rotate the line, in the HYPACK Shell, click and drag a point on the line and move it to 
its new location. While moving the point, the length of the line can also change.
4



The following images show before (left) and after (center, right) Line 20 was rotated.

Note that you can press the "M" and "R" keys to toggle between the move and rotate 
functions. You must first select Move Selected Line or Rotate Selected Line in the Line 
Editor to enable these keyboard shortcuts.

• New feature: Visual Geodesy with dynamic webmap. The Project Wizard now has an 
alternate and simpler way of setting up geodetic parameters when you are using UTM 
Grids and US State Plane NAD-83. This interface allows you to set up geodesy with just a 
click on a dynamic map!
To set up geodetic parameters using Visual Geodesy:

1. Open the Project Wizard, which is either when HYPACK® starts, or click File-> Project 
Wizard.

2. Select “Create New Project” and click [Next]. This will take you to the new project creation 
page.

3. Give a project name and click [Next]. Next is the geodesy page. 
4. On the Geodesy page, select Click on Map in the Selection Mode drop-down. This opens 

the World Map where you can click on the area to set up your geodetic parameters. You 
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can see the Lat-Long value on the bottom of the window along with grid area and zone 
information.

5. An interactive dynamic web map will appear. You can turn on and off the zone grid lines 
by clicking the “Show Zone Grid” button and vice versa if you are using UTM Grids. You 
can zoom in and out by using the mouse scroll wheel and scroll bar in the map window. 
You can also pan around the map area by dragging the map using the mouse. You can 
see Lat-Long in the bottom right of the map window, while UTM grid and zone info can be 
seen in the bottom left of the window.

6. If you are using the State Plane NAD-83 grid, you can click on the [State Plane] button 
and US state plan zones will appear. You can zoom in and out like explained in the 
previous step. Select the zone of your choice and your selection will appear at the bottom 
6



left of the map window. You will need a *.kml file for the state plane system in the datum 
folder under the HYPACK® installation directory. File name is “StatePlaneNAD83.kml”.

7. When the information is correct for your project, click [Set Geodesy]. This will take you 
back to the geodesy page in the Project Wizard, and you can see the updated geodesy 
settings.

8. When you are done with Geodesy settings, click [Next].
9. You have created the project and set up your geodesy with just click on a map.
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TPU EDITOR

Users can now add custom devices and custom standards to the TPU Editor:

> To add a custom device, click File -> Add Device to set up parameters and name a 
new device. Users can add positioning, MRU, multibeam, and heading systems.

> To add a custom standard, click on the drop down menu under Estimation Graph 
Parameters and click Add Standard. The New Standards window appears, and users 
can add depth and position uncertainties, target detection, and name the standard. 
Up to five custom standards can be added.

For more information, refer to Custom Devices and Standards in the TPU Editor by Jocelyn 
Kane.

PREPARATION

GEODESY

• HYPACK now supports the ITRF 2020 epoch. To use this new option, from HYPACK 
Shell click Preparation -> Geodetic Parameters. In the Geodetic Parameters window, 
click Tools -> Time-Variable Transformations, and in the Time-Variable Transformations 
window, you can select ITRF 2020 from the ITRF/WGS84 Epoch drop down.

• In the GEOID File Converter, the GRA Import window now appears if a *.GRA file is 
selected. Users need to specify the data string format in the *.GRA file by selecting 
between the following three options: Lon/Lat/Sep, Lat/Lon/Sep, and Separation values 
only. 
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To use this option, open the GEOID File Converter from the Shell by clicking Utilities -> 
Geodesy -> Geoid Generator, click [Select File] and open a *.gra file.

• Added the Enable Height Transformation check box to the Time-Variable 
Transformations window, which allows vertical transformation using the datum 
transformation parameters.

To use this new feature:

1. In the Geodetic Parameter windows, click Tools -> Time-Variable Transformations. This 
opens the Time-Variable Transformations window.

2. Check the “Enable Height Transformation” box, then click [OK]. 
Height calculations are now vertically transformed based on datum transformation 
parameters.

• The Datum Height Calculator feature was added in the 2023 Q3 HYPACK release to 
calculate the height correction using datum transformation parameters, however it 
was removed in the 2024 HYPACK in favor of real time height calculation.
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• The HSX and RAW file filters have been combined in Tools -> Import HSX/RAW 
data.

GRID CONVERSION

• In the Grid Conversion dialog, added the Datum Correction field which allows users to 
enter the vertical datum shift.

To use this new feature:

1. From the HYPACK Shell, click Utilities -> Geodesy -> Grid Conversion to open the Grid 
Conversion window.

2. Type in the vertical datum shift in the Datum Correction field. Fill out the remainder of the 
dialog as normal and click [Convert].
10



HARDWARE

• New Feature: We’ve added the new dialog Vessel Configuration Wizard, which 
allows users to quickly save and load vessel configurations from the C:\HYPACK 
Store\Vessels folder.
To use the Vessel Wizard, from the HYPACK Shell click Preparation -> Hardware Setup. 
In the HYPACK Combined Hardware, click File -> Vessel Wizard. The Vessel Wizard 
Dialog Box opens.

> Click [Save] to save the currently opened project's hardware configuration to the 
Vessels folder.

> To load one of the listed vessel configurations, click the name of the configuration and 
click [Open]. 

> To delete a vessel configuration, click the name of the configuration and click [Delete].

• In the HYPACK Combined Hardware, users can now save device offsets to a PDF. 
To do this, enter your device offsets in the HYPACK Combined Hardware window, then go 
to the All Offsets tab and click Export to PDF. Give the PDF file a name and select the 
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save location.

The following image shows an example PDF containing the entered offsets.
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SURVEY DEVICE DRIVER UPDATES

To add and update device driver settings, from the HYPACK® shell click Preparation --> 
Hardware Setup. Search the list of available drivers, and click the name of the driver and click 
[Add -->]. Under the Installed list, double click the name of the driver to bring up its setup 
window.

• GPS.dll: Users can now enter multiple status codes in the GPS Status Code boxes.
Use commas to separate multiple numbers.

• Updates to MVP.dll:
> MVP.dll now accepts date format in DD/MM/YYYY or DD:MM:YYYY.
> MVP.dll now records coordinates, date, and time to the SVP (*.vel) file.
> SVP (*.vel) files are now written to the SVP folder of the active HYPACK project 

by default. Users can use the Project Subdirectory field to change the save folder.
> Added the Overwrite Previous File with Same Name option. Select this option to 

overwrite the existing VEL file. If this option is unchecked, and if a file with the same 
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name exists, the new files are named with the format of svp_1.vel, svp_2.vel, and so 
forth.

> Fixed issue where there was a discrepancy between the position of the VEL files and 
actual position.

• Sbg.dll: Added the “Calculate tides when solution status is at least...” slider in the 
SBG Setup window, which allows users to set the minimum solution level to record 
tides. These choices are similar to the alarm threshold conditions.
14



To use this function, add sbg.dll in the HYPACK Combined Hardware, then open the SBG 
Setup window. Drag the slider to the condition you want, then click [OK].

• ScaledDGH.dll: Added options to interpolate pitch/roll readings to the origin point, 
to a mobile's current position, or to a user-defined offset.
To use these option, from the HYPACK Shell click Preparation -> Hardware Setup. In the 
HYPACK Combined Hardware window, add ScaledDGH.dll, then open the Setup window. 
Check the box next to “Interpolate Reading with Pitch/Roll”, then select the reference 
point.
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• Subbot.dll: Multiple updates for this driver.
> For Fugro 32-bit Analog devices, added the option to “Create one SEGY file per 

ping” to the Setup window.
By default, Fugro devices create one file per ping, however users can now choose to 
enable or disable this option.

> For subbot.dll, removed the base gain setting from the Subbot.dll window in 
Side Scan Survey, since its function is redundant and caused undesired side 
effects. Gain can still be applied in the Analog Monitor and display controls.
16



> For subbot.dll, users can now separately set the Trigger and Data terminal 
mode inputs from the I/O Channels window associated with the Analog Monitor 
in HYPACK Survey. These options work for National Instruments devices like Fugro.

The Trigger and Data terminal mode dropdowns are populated with options that are 
based on what the connected device(s) report back as their capabilities. Note that if 
you do not have a National Instruments device connected, all of the dropdowns will be 
empty.

For the terminal modes, potential options include Referenced single-ended, Non-
referenced single-ended, Differential, and Pseudodifferential mode.

The Coupling mode options are AC or DC.

To use this new feature:
From the HYPACK Shell, click Preparation -> Hardware Setup to open the HYPACK 
Combined Hardware window. Add subbot.dll, and select a National Instruments 
device (ie: Fugro).
Back in the HYPACK Shell, open HYPACK Survey. In the Analog Monitor window 
under the Settings section, click [I/O Channels] to open the I/O Channels window. 
Check the Sub-Bottom checkbox, then select the desired input from the Trigger 
terminal mode, Data terminal mode, and Coupling mode dropdowns. Click [OK].
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NEW SURVEY DEVICE DRIVERS

• New Driver: spectre.dll
Dynautics SPECTRE is now supported in HYPACK, which allows control of the 
SPECTRE autopilot in Survey. When you add the driver in HYPACK Combined 
Hardware, you can set up the connection type and recording rate in the Survey Devices 
tab.

The Dynautics Spectre device window appears in HYPACK SURVEY. Click [Connect] to 
connect to the device. Once connected, you can use the Change Mode, Thrust, and 
18



Heading functions to control the device. Planned line files can be uploaded as a track to 
follow by clicking [Upload Track].

• New Driver: Added the Entek Hopper System driver, EntekTSHD.dll. This driver 
supports the Entek PLC hopper system, which uses two hopper-level sensors and two 
draft sensors. The driver reads draft and ullage levels, displays them visually, and sends 

the information to the Load and Draft Monitor (LDM) program in DREDGEPACK®.

After adding the Entek Hopper System driver in the HYPACK Combined Hardware, 
double click the driver name to open the Device Settings window. For draft sensors, enter 
their location relative to the midship draft scale, and for the hopper level sensors enter 
their heights above the keel.
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Calibration is performed similar to the Entek Bubbler calibration. Click [Calibration] to 
open the Calibration window. For each sensor you want to calibrate, first measure the 
value, select the value from the Sensor drop down, then add the measured value in the 
Set Value box and click [Mark].

• New Driver: AirmarEcho.dll
Added support for Airmar single and dual frequency devices with the AirmarEcho.dll 
driver.
The driver reads Echo Envelope data, and plots the echogram within the Airmar Dual 
Frequency window in HYPACK Survey.
In HYPACK Hardware, the Airmar Setup window contains the following options:
> Data Com Port (fixed to 921600 baud): Select com port for primary channel.
> Second Channel Com Port: Enable to select com port for second channel.
20



HYSWEEP® DEVICE DRIVER UPDATES

• Valeport SWiFT SVP: Now supports the Valeport SWiFT CTD. Detection of whether 
you have a CTD or SVP occurs automatically and does not need further user input. 
For more information, see the Sound Velocity section.

• R2Sonic Devices: Added the option to log TruePix compressed water column data. 
To use this option, in the HYPACK Combined Hardware setup window, select HYSWEEP 
Devices and choose from the following R2Sonic devices: R2Sonic Dual Head 2020, Dual 
Head 2024, SONIC 2020, and SONIC 2024. Double click the device name to open the 
R2Sonic Setup window.

Check both “Log Water Column Data” and “TruePix Water Column”, and make sure the 
R2Sonic device control software is set to output TruePix angle and magnitude data. The 

compressed data will be logged and displayed in the HYSWEEP® Water Column Logger 

window while HYSWEEP® SURVEY is running.
For more information, see “Compressed Water Column in HYSWEEP” by Mike 
Kalmbach.

• Norbit WBMS Single and Norbit Dual Head Drivers: Users can now change the port 
values for primary and secondary heads. The default port values are:

> Single head: 7000.
> Dual head: 7000 for the primary head, 7001 for the secondary head.

To change the port values, from the HYPACK Shell click Preparation -> Hardware. In the 
HYPACK Combined Hardware window, go to the Mobile tab and select HYSWEEP 
Devices. From the list of devices, select NORBIT WBMS or NORBIT Dual Head.

To change the primary port value for both single and dual head drivers, click the Connect 
tab and enter the new port number under Network Connection.
January / 2024  21
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To change the secondary port value for the NORBIT Dual Head driver, double click on 
NORBIT Dual Head to open the WBMS Setup window, then enter the new port number 
under the Dual Head section.

• R2Sonic Devices: The HYPACK 2023 Q1 release introduced the option to log TruePix 
compressed water column data for R2Sonic HYSWEEP devices. However, it was found 
that a UDP pass through is necessary to correctly transfer data from HYSWEEP to the 
water column logger.

In this update, the Pass Through Port field has been added to the R2Sonic Setup 
window. When logging TruePix water column data, you need to specify the UDP 
port for HYSWEEP Survey to water column logger pass through.

Now, use the following steps when setting up HYPACK Combined Hardware and the 
R2Sonic Sonic Control software when logging TruePix water column data:

In the HYPACK Combined Hardware setup window, select HYSWEEP Devices and 
choose from the following R2Sonic devices: R2Sonic Dual Head 2020, Dual Head 2024, 
SONIC 2020, and SONIC 2024. Double click the device name to open the R2Sonic Setup 
22



window. Check both “Log Water Column Data” and “TruePix Water Column”. Enter the 
value of the pass through port. The default pass through port is 5656, which should work 
for the majority of situations. If data is not transferring, try 5657 instead.

In the R2Sonic Sonic Control, open the Operation Settings window and make sure 
TruePix Enable is checked in the Sonar tab, and Magnitude+Angle is selected as the 
TruePix data format in the Imagery tab.
The compressed data will be logged and displayed in the HYSWEEP® Water Column 
Logger window while HYSWEEP® SURVEY is running.

SIDE SCAN DEVICE DRIVER UPDATES

• Added support for the Falmouth Scientific HMS-624 side scan sonar. 
Add this device driver by opening HYPACK Hardware and selecting Sidescan Devices 
from the Mobile tab.
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Network settings for the HMS-624 side scan sonar are given in the screen shot.

DREDGEPACK® DEVICE DRIVER UPDATES

NEW FUNCTION: DQM DIRECT

The USACE has recently added the ability to send DQM data directly to their servers through 
the internet. HYPACK has incorporated this function into their hopper, cutter-suction, and 
crane DQM device drivers. The following section lists an overview of updates that were made 
to support DQM Direct. For more information, please refer to Dredge Quality Management 
(DQM) Direct for Hopper, Cutter-Suction, and Crane Dredges by John Marinuzzi.

• CutterDQMSender.dll Updates - Setup now includes DQM Direct options including 
Enable DQM Driect, Plant ID, and Connection String. Connection status is shown in the 
bottom right corner of the CutterDQMSender’s runtime window.

• New Driver: HopperDQMSender.dll
This driver is a rewrite of SI_SENDER.dll and handles DQM and DQM Direct for hopper 
suction dredges. The DQM Direct setup sends data packets over the Internet to a cloud-
24
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based endpoint, which eliminates the need for a separate DQM computer on vessels. 
This driver also eliminates outdated DQM requirements and is more efficient.

• New Driver: MechanicalDQMSender.dll - Setup and runtime windows are similar to 
CutterDQMSender.dll and HopperDQMSender.dll.
January / 2024  25



TARGET EDITOR

To improve usability in the Target Editor, we’ve made multiple updates to the Target Editor, 
Shell, and HYPACK SURVEY that give users the option to restore deleted targets before 

completely deleting them permanently. Open the Target Editor from the HYPACK® Shell by 
clicking Preparation -> Editors -> Target Editor.

• The Deleted Targets tab has been added to the Target Editor. This tab displays all 
targets that have been deleted from the Target Editor, Shell, and HYPACK SURVEY.

• Users can now restore targets deleted from the Shell, HYPACK SURVEY, and 
Target Editor from the Deleted Targets tab. To restore a target, open the Target Editor 
and navigate to the Deleted Targets tab. Click on the target you want to restore to select 
it, then right click on it -> Restore Targets. 
You can select multiple targets by clicking and dragging to highlight their names prior to 
restoring.

• The Purge Data icon and functionality have been added to the Target Editor toolbar, 
which completely deletes all targets within the Deleted Targets tab. After clicking 
Purge Data, the following prompt will appear. Click [Yes] to confirm permanent deletion of 
all targets within the Deleted Targets tab.

• The Target Editor now loads with the Spreadsheet tab displayed by default.
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TPU EDITOR

• RTF reports generated from the TPU Editor now include a Devices Info table, which 
lists the selected positioning, MRU, multibeam, and heading devices.
To generate an RTF report, after choosing each device, click File -> Save RTF Report.

• In the menu, a blue checkmark is now displayed next to the selected positioning, 
MRU, multibeam, and heading devices.
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DATA ACQUISITION

SURVEY
• Users can now use the keyboard shortcut CTRL+T to freeze and thaw windows in 

HYPACK Survey.

• Targets deleted in HYPACK® SURVEY can now be restored from the Target Editor. See 
the Target Editor section in this document for more information.

• Added autoscaling options for both fixed matrix and auto-matrix files. The 
autoscale function uses current minimum and maximum depths in the matrix to set up the 
color bands. Since the matrix depths can change, autoscaling is not dynamic and 
requires user input.

To autoscale colors on a fixed matrix, from the area map window click Matrix -> Autoscale 
Colors.

To autoscale colors on an auto-matrix, right click on the color bar and click Autoscale to 
Matrix.

• The NI-9234 has a fixed list of supported channel sample rates. Now, in the Analog 
Monitor -> I/O Channels window, if a NI-9234 is connected, the sample rate field is 
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replaced with a drop-down menu showing these supported sample rates.

To use this new option, first connect a NI-9234. In HYPACK Hardware, add the Subbot.dll 
driver, and in Setup select Analog (NI USB). In HYPACK Survey, go to the Analog Monitor 
window and click [I/O Channels]. In the I/O Channels window, check the Manually 
Override Channel Sample Rate box, then select a sample rate from the list. Click [OK] to 
apply the sample rate.

• Users can now choose to name LOG files with ISO Standard (European) date 
format (YYYYMMDD). This format also applies to RAW, HSX, HS2X and XYZ files.
To use this option, in HYPACK SURVEY click Options -> Project Information. In the 
Project Data window, click ISO Standard Date (YYYYMMDD), then [OK]. Subsequent 
LOG, RAW, HSX, HS2X, and XYZ files are named using date and time in the following 
format: YYYYMMDD_HHMM.file type.
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In the following example on the right, LOG and RAW files are now named using the new 
date standard.

SURVEY DATA TRANSFER

The Survey Data Transfer window has received 
a few updates. To open the Survey Data 
Transfer window and use these new features, 

from the HYPACK® Shell click Survey -> Survey 
Data Transfer.

• The Start with Survey checkbox has been 
added to the Options section. When this 
box is checked, the Survey Data Transfer 
program automatically opens and begins file 

transfer when HYPACK® SURVEY is 
opened.

• Users can now select and transfer XYZ 
and HS2x files. The program monitors the 
Edit folder for HS2x files, and the Sort folder 
for XYZ files.

• Only one instance of Survey Data 
Transfer runs at any given time.
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SIDE SCAN SURVEY
• Users can now choose to name LOG and HSX files generated from Side Scan 

Survey with the ISO Standard (European) date format (YYYYMMDD).
To use this option, from the HYPACK Shell first click Survey -> HYPACK Survey and Side 
Scan Survey to open and run both programs simultaneously. In the HYPACK Survey 
(also called Channel) window click Options -> Project Information. In the Project Data 
window, click ISO Standard Date (YYYYMMDD), then [OK]. Subsequent LOG and HSX 
files are named using date and time in the following format: YYYYMMDD_HHMM.file 
type.
In the following example on the right, LOG and RAW files saved from Side Scan Survey 
are now named using the new date standard.

• Geodesy ini values are now written into HSX header in side scan.
• Users can now select the default target group to add targets to when marking 

targets in Side Scan Survey. To use this new feature:
1. Open Side Scan Survey from the HYPACK Shell by clicking Survey -> HYPACK Survey 

and Side Scan Survey.
2. In the Side Scan Survey window, click Targets -> Target Parameters…

This opens the Side Scan Options window.
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3. In the Side Scan Options window, select Targets from the list on the left. From the Default 
Target Group dropdown, click on the target group you want your targets to be saved to. 
As you can see, the target groups in the project are listed in the menu. Then, click [Close].

HYSWEEP® SURVEY
• HYSWEEP® Water Column Logger now properly supports and displays TruePix 

compressed water column imagery. See the addition of the Pass Through Port field in 
R2Sonic Device Setup in the HYSWEEP Device Driver Updates for more information on 
setting up TruePix logging for R2Sonic devices.

• Multiple updates were made to the HYSWEEP® SURVEY Profile, 3-D Seafloor, and 
Waterfall windows. For more information, refer to New Zoom and Color Range 
Functionality in HYSWEEP by Andrew Clos.
The following is an overview of these changes:
> Auto Scale Profile option added, which enables automatic range scaling based 

on the changing depth of the swath. Enable or disable the auto scale function by 
right clicking the black portion of the Profile Window, or by using the newly added 
Auto Scale Profile checkbox located in the Multibeam Display tab in the View Options 
window.

> Horizontal and vertical slider bars are added to the profile window to enable 
limited zooming of the swath within the window. These slider bars can be enabled 
or disable by right clicking either slider bar.

> The 3-D Seafloor window can now automatically scale its color range based on 
the changing water depth of the swath. Use the newly added Scale Color Map to 
Depth Range checkbox to enable and disable this feature.
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• HYSWEEP® SURVEY now monitors and detects time tags that “jump back” in time. 
When this error occurs, the Devices indicator turns yellow.

Click the Devices indicator to display the Error Log window, which will include a 
“Backward Time Jump” message.

• Users can now choose to name LOG and HSX files generated from HYSWEEP 
Survey with the ISO Standard (European) date format (YYYYMMDD). 
To use this option, from the HYPACK Shell first click Survey -> HYPACK Survey and 
HYSWEEP Survey to open and run both programs simultaneously. In the HYPACK 
Survey (also called Channel) window click Options -> Project Information. In the Project 
Data window, click ISO Standard Date (YYYYMMDD), then [OK]. Subsequent LOG and 
HSX files are named using date and time in the following format: 
YYYYMMDD_HHMM.file type.
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In the following example on the right, LOG and RAW files saved from HYSWEEP Survey 
are now named using the new date standard.

• Valeport SWiFT CTD Support: Users can now download casts from the Valeport SWiFT 

CTD from HYSWEEP® with the same procedures used for the SVP. For more 
information, see the Sound Velocity section.

• HYSWEEP® Water Column Logger now supports and displays TruePix compressed 

water column imagery. See the update on R2Sonic devices in the HYSWEEP® Device 
Driver Updates for more information on setting up TruePix logging for R2Sonic devices.

BUG FIXES

• Sound Velocity table: Previously, readings in the Sound Velocity table would have data 
lines containing depth values of zero on every other line. These zero-depth lines are 
now removed and no longer appear in this table. Make sure you have the newest 
version of Hysweep.exe and mbHardware.dll to prevent this from happening again.

• Fixed an issue where some casts were truncated and did not show some of the 
deepest depth readings and velocity data points.
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DATA PROCESSING

64-BIT SINGLE BEAM EDITOR (SBMAX64)
• Users can now enable contour labeling with the 

newly added Label all Contours checkbox in the 
Contours window. When checked, all contours are 
labeled using the settings defined in the Contour Setting 
window.

To use this feature, open SBMAX64, load your survey 
files, and click [Contour] to open the Contours window. 
From here, check the Label all Contours box, click [Test] 
to generate the labels, then click [Save] to save the 
contour file.

To change the contour and label properties and settings, 
from the Contours window click [Contour Attributes] and 
make your edits in the Contour Setting window.

The following is an example of the SBMAX64 window with (right) and without (left) Label 
All Contours checked.
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• In the Contours window, clicking [Autoscale Colors] now draws a new contour 
scaled using the color settings in SBMAX64. Edit color settings SBMAX64 by clicking 
View -> Color Settings... to open the Color Settings window and apply your changes.

• Added the Motion Correct Echogram option, which applies tide, draft, heave, and 
vertical offsets from Read Parameters to echogram and analog data.

To use this new option, load your data, then in Read Parameters go to the Devices tab, 
then click [Edit] to add your offsets to your device. In the Echogram and Spreadsheet 
dialogs, notice the echogram depth is currently the raw depth value. Then, open View -> 
View Options, then check the Motion Correct Echogram checkbox and click [OK]. The 
Echogram and Analog depths will now match the corrected depths in the Spreadsheet 
dialog.

• The Save Reminder and Auto Save HS2x options have been added to the 64-bit 
SINGLE BEAM EDITOR. This option works similarly to the Save Reminder/Auto Save 
HS2x option added to the 64-bit HYSWEEP EDITOR in the 2023 HYPACK release. When 
properly set up, the 64-bit SINGLE BEAM EDITOR automatically saves or prompts users 
to save any changes made to the HS2x file(s). 
> Note that only RAW and S7K loaded files can be saved to HS2x.

Files are only updated when changes are made to those specific files, so it will not save if 
files have not been changed. 
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To set up Save Reminder/Auto Save HS2x:

1. In SBMAX64, after loading your data, click File -> Save Survey.
2. In the Save Survey window, click [Save Reminder / Auto Save HS2x...]

The Save Reminder / Auto Save HS2x window appears.

Choose between either setting a save reminder or to auto save HS2x files. Both are 
described below.

Set up a Save Reminder

1. In the Save Reminder/Auto Save HSx window, check the box next to Enable.
2. If you want an auditory alarm to sound when it is time to save your file, check the box next 

to Beep. While this is checked, the Windows Background noise will occur at the 
designated time interval to remind you it is auto-saving.

3. In the Minutes box, enter the time interval at which you want your files to be autosaved or 
be reminded to save them. This value must be an integer of 1 or greater.

4. Click the Save Reminder button, then [OK]. After the user-defined time interval, which 
was entered in the Minutes box, has elapsed after the first edit, the window will briefly 
flash yellow and then the words “Save Reminder” will appear on the upper left of the 
screen.
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Set up Auto Save HS2x

1. In the Save Reminder/Auto Save HSx window, check the box next to Enable.
2. If you want an auditory alarm to sound when your file is auto-saved, check the box next to 

Beep. While this is checked, the Windows Background noise will occur at the designated 
time interval to remind you it is auto-saving.

3. In the Minutes box, enter the time interval at which you want your files to be autosaved or 
be reminded to save them. This value must be an integer of 1 or greater.

4. Click the Auto Save HS2x button, then [OK]. Auto Save HS2x automatically saves 
changes you have made to the corresponding HS2x files after the user-defined time 
interval has elapsed after the first edit.

If you want to manually choose which HS2x files to save, check the Overwrite Prompt box. 
While Overwrite Prompt is checked, a prompt window appears at the designated time interval 
after the first change is made to ask if you want to save your edits by overwriting the HS2x 
file(s). For example, if you designate an Auto Save time of 1 minute, if you open Stage 2 
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editing at 2:00 PM, grab some coffee and begin editing at 2:05 PM, an Overwrite Prompt will 
appear at 2:06 PM.

The Overwrite Prompt window displays the HS2x file name, and offers several save

options:

> [Yes] saves the changes to the displayed HS2x file. If you save using this method, the 
window will cycle through each file listed on the left, allowing you use [Yes] or [No] to 
save or ignore changes made.

> [Yes to All] batch saves the changes made to all HS2x files that are listed on the left.
> [No] does not save changes made to the HS2x file whose name is displayed in the 

window. If you save using this method, the window will cycle through each file listed 
on the left, allowing you use [Yes] or [No] to save or ignore changes made.

> [Cancel] does not save changes made to all HS2x files listed on the left.

If [No] or [Cancel] are selected, users will be repeatedly prompted to save at every user-
defined time interval, even if no changes are made, until the changes are saved. If no 
changes are made within the editor, the prompt will not appear. The overwrite prompt will 
appear or auto save will occur X minutes after the first change is made.

• New: The Offline Statistics window has been added to the 64-bit Single Beam 
Editor.
This window displays an offline histogram of the survey data and lists the average, 
minimum, maximum, and standard deviation values. It provides an average position, in 
case you logged data over a point for a couple of minutes to get a statistically calculated 
position, which can be used to verify the RTK Tide and Positioning System's accuracy 
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and precision.

To view this information, after loading a project, click File -> Offline Statistics to open the 
Offline Statistics window.
> The Offline Interval field adjusts the histogram interval along the vertical axis.
> Toggle between calculating offline statistics for the current line or all lines.
> [Save Screen to RTF] creates an RTF file that contains a screenshot of the Offline 

Statistics window, the offline interval value, and the selected line option.
> At the very bottom of the histogram, the number of points used to calculate the 

histogram is displayed on the left, and the horizontal scale of the histogram is on the 
right.

• New: Sounding Migration has been added to the 64-bit ingle Beam Editor.
Similar to the Sounding Migration function in the 32-bit Single Beam Editor, this re-
computes the XY position of a depth based on the transducer cone angle and slope of the 
bottom.
To use this, open your data in SBMAX64, then click File -> Sounding Migration. In the 
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Sounding Migration window, fill in the values for Depth 1 and Depth 2. Click [Go] to re-
compute the position of the sounding.

• The Device Offsets window has received a couple of updates:
> The Device Offsets window now has a note at the bottom left that states the units the 

offsets are in.
> If RTK Tides is checked and the Vertical offset for the Tide device is changed and you 

click [OK], Device Offsets now displays a message that recommends using the 
HYPACK Raw File Adjustments to recalculate RTK tides.

The Device Offsets window is accessible by clicking File -> Read Parameters, selecting 
the Devices tab, then clicking [Edit].
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ECHOGRAM WINDOW

The Auto Digitize icon has been added to the Echogram window in SBMAX64. The 
icons in the toolbar have also been rearranged to group digitizing icons together.

To auto digitize either frequencies, Click [Auto] to open the Auto Digitize window.

Auto Digitize Window

You will need to set up the following parameters:

• Choose between Depth 1 or Depth 2.

• Select a Bottom Tracking method:

> Find first peak - first prominent increase in return strength.
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> Gradient - most sudden change of strength.

> Threshold - Uses user-defined threshold strength. Use Blanking and/or the 
Sensitivity slider to set the threshold.

• Blanking tells the program to ignore all signal down to the defined depth.

> 0 is the same as no bottom tracking.

> Low setting eliminates the effects of backscatter to help find the true bottom.

> Very high setting can actually set the bottom tracking at a depth greater than the true 
depth.

• Swell Correct takes swell into account for the depth calculation. Removes the effects of 
heave.

• Remove Outliers (recommended) ignores scattered data in the water column.

• Sensitivity slider sets the level of intensity at which the bottom is classified.

• [Calculate] displays the auto digitized depth on the echogram window in blue. This 
function uses the current line chosen. Calculated depths are kept when users switch to a 
different line and returns to the previous line with calculations already performed.

• [Reset] - Clears calculated depths of current line/depth combination.

• [Apply] saves the auto digitized depth. This option only saves the current line/depth 
combination. Click Undo in the SBMAX64 window to reverse these changes.

• [Close] closes the Auto Digitize window.

• Users can now adjust the signal scales of separate echogram windows 
independently of each other. Previously, signal adjustments were linked between both 
echogram windows. This new update makes viewing separate echograms easier.

• The Signal Scale arrow buttons have been swapped in the echogram window to 
make usage more intuitive. We've also added +/- symbols on the buttons. The [>+] 
button now increases the signal, and the [-<] button decreases it.

• Right-clicking and dragging the graph in the Echogram window 
automatically pans the graph in the Profile Window and vice versa if the 
Profile and Echogram windows are open at the same time, and the Sync Echo/
Profile icon is enabled.
Zooming with the mouse scroll wheel also simultaneously affects both windows.
January / 2024  43



• Users can now export signal intensity data from echograms, and a new Export 
button has been added to the SBMAX64 echogram window to create these ASCII 
*.txt files.

To us this new function, you will need to first load a *.raw file and open the data in the 
echogram.

From the HYPACK Shell click Processing -> Single Beam Editor (64 bit), and the 
SBMAX64 window opens. Click Load Survey, and in the Raw folder select the LOG file 
and click [Open]. Click any of the *.raw files in the Catalog window, then click [Select]. In 
the Read Parameters window, click [OK]. Back in the SBMAX64 window, click 
[Echogram] to open the echogram window(s).

Once in the Echogram window, click [Export]. In the Save dialog, choose the desired 
folder to save the exported files, then click [Select Folder]. The program exports each 
sample as a number, and data is grouped into rows by ping.

As you can see, each file contains intensity data from a single depth channel. File names 
are in the format of RawFileName.RAW_Channel#.txt.
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SORT PROGRAM

• Added “Sort with Golden Sounding Priority” option to the Sort window. This option 
behaves similarly to Sort with Priority, and allows you to give Golden Soundings priority 
over others in the Sort routine. Golden Soundings are sorted first. Then, when compared 
to other non-priority data, Golden Soundings are retained regardless of the comparison 
result.
To use this new option, from the HYPACK Shell click Processing -> Sounding Selection -
> Sort.
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SIDE SCAN PROCESSING

TARGETING AND MOSAICKING BETA

Some updates have been made to the Targeting and Mosaicking Beta program, which are 
covered in “Targeting and Mosaicking Beta 2023 Q1 Updates” by Daniel Tobin. The following 
is an overview of the new feature.

• Added a new view option that simultaneously shows Scanview and Altitude View. 

To view both windows together, launch HYPACK® and click Side Scan -> Targeting and 
Mosaicking (Beta), then click [S+A] under the Stages section in the Targeting Mosaicking 
Beta program. The Scanview will be displayed above Altitude View window. Make sure 
you are in the Scanview tab.

Click a location in the Altitude View and the Scanview will display imagery and data at that 
position. You can also scroll through the Scanview - as you do so, the blue box in the 
Altitude View will show your current position. For more information, 
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• Removed window options from the View menu, since they are all available as tabs 
within the Side Scan Targeting and Mosaicking window. We've only retained the 
Show Debug Window option.

64-BIT HYSWEEP® EDITOR (MBMAX64)
A couple of new options have been added to the Device Offsets UI in Read Parameters -> 
Devices Tab -> [Edit]. These options are the “Installed on Towfish” and “Installed on Rotator” 
checkboxes.

• Device Offsets now show the mounting location of the MRU, Heading, and Sonar 
devices with the new “Installed on Towfish” checkbox in Device Offsets. With the 
“Installed on Towfish” checkbox, users can ensure that dynamic draft intended for the 
boat is not applied to a mobile and its associated devices, and vice versa.

BEFORE AFTER
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The device location can be changed on file loading, however it is disabled after files are 
loaded.

• Users can now specify if a sonar is installed on a rotator with the “Installed 
Rotator” checkbox. To set the rotator angle, click [Offsets] to open the Rotator Offsets 
window.

The checkbox and offsets button are disabled after files are loaded. Reload the files to 
make any changes.

• The HYPACK 2023 Q2 release introduced the option to add custom accuracy 
standards to the TPU Editor. These custom accuracy standards can now be read in 
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MBMAX64 and used in HYSWEEP CUBE, auto-filters, and in matrix display/export.

To use a custom accuracy standard from the TPU Editor in MBMAX64, from the HYPACK 
Shell click HYSWEEP -> HYSWEEP Editor (64-bit) to open MBMAX64. In MBMAX64, 
click Load Survey, select the desired LOG and RAW files, and in the Read Parameters 
window under the TPU section, select the custom accuracy standard from the Accuracy 
Standard drop down menu.

For more information on adding custom standards in the TPU editor, refer to Custom 
Devices and Standards in the TPU Editor by Jocelyn Kane.
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• Added the [S7K File Settings…] option in the Corrections tab of the Read 
Parameters window, which allows users to set the S7K height mode.

Click [S7K File Settings…] to open the S7K File Settings window and select between 
GPS Height and Dynamic Draft. This option is useful when determining depth for S7K 
files logged from underwater vehicles (ie: AUV, ROV), however this works for vehicles 
both above and below the water

> This button is only enabled when loading S7K files.
> Only S7K files from Reson and NORBIT are loaded (Remember, S7K files generated 

by PDS software are not supported).
• Added the Append Golden Soundings option in the Save Survey window. Users can 

now append golden soundings to final (gridded) XYZ output files by checking this option. 
If you're saving cell averages to XYZ and a cell contains a golden sounding, golden 
sounding depth will override average depth. For more information, refer to Golden 
Sounding Update in MBMAX64 by Mike Kalmbach.

To append the golden soundings to an XYZ file, from the 64-bit HYSWEEP EDITOR:
1. Click File -> Save Survey.
2. Under File Format, select XYZ.
3. Under XYZ Options, select Save One Point per Cell, then check Append Golden 
Soundings.
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4. Click [Save All Files...]. In the Save As window, give your XYZ file a name, then click 
[Save].

Note that which golden soundings are appended is dependent on whether the “Link 
Golden Soundings to HYPACK Database” option is checked in the Edit -> Settings menu:
> Unchecked: Golden sounding flags are kept in edited HS2x files but not exported to 

the database. When saving to XYZ, only the soundings from loaded files are 
appended.

> Checked (default): Golden sounding flags are kept both in the edited HS2x and the 
HYPACK Golden soundings database. When saving to XYZ, the HYPACK golden 
soundings in the database are appended.
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• In MBMAX64, the selected sounding in the Swath Editor is now also displayed in 
the Water Column window. In the example below, a line is drawn from the origin through 
the cursor point.

TPU-RELATED UPDATES

Multiple TPU-related updates have been made to MBMAX64. See TPU Updates in 
MBMAX64 by Mike Kalmbach for more information, however these changes are summarized 
below.

• Added TVU, THU, and TPU options to the Selection drop down menu, which allows 
users to show uncertainties in the matrix display.
52

https://www.xylem.com/siteassets/brand/hypack/resources/newsletter/2023/july/update-notes/tpu-updates-in-mbmax64---mike-kalmbach.pdf
https://www.xylem.com/siteassets/brand/hypack/resources/newsletter/2023/july/update-notes/tpu-updates-in-mbmax64---mike-kalmbach.pdf


If you select:
> TVU (Total Vertical Uncertainty) - Cell is green if one or more soundings in the cell 

meet uncertainty limits. Red otherwise.
> THU (Total Horizontal Uncertainty) - Same green or red color coding as with TVU.
> TPU (Total Propagated Uncertainty) - Cell is green if both TVU and THU meet 

uncertainty limits.

Note that you must have Calculate TPU checked and an accuracy standard selected 
in File -> Read Parameters. Otherwise coloring is all red.

• Added TVU, THU, and TPU to MTX and XYZ Selection options when saving to MTX 
and XYZ files, respectively. 
For MTX files, you can select among TVU, THU, and TPU. The uncertainty coding 
replaces Z.
For XYZ files, you can select between XYZ, TVU and XYZ, THU. Use the Z multiplier to 
scale up small TVU and THU values if needed. The output files can be loaded elsewhere 
for contouring, analysis, etc. Although depth is not included in the output, the files are 
saved as *.XYZ, with TVU or THU replacing depth Z.
Coloring is the same as in the matrix, 0 = red, 1 = green.

• The TPU checkbox has been added to the Sweep tab 
in the Search and Filter Options window. This option 
filters and removes soundings outside TVU or THU 
limits. 

To use this option:
1. First, make sure MBMAX64 is calculating TPU. From 
the top menu, click File -> Read Parameters, then in the 
Read Parameters window, check Calculate TPU and 
select an accuracy standard.
2. Click Edit -> Search and Filter Options to open the Search and Filter Options window.
3. Click the Sweep tab, check the TPU box, then click the [Update Filter Preview] button.
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The soundings outside TPU limits are marked with a yellow X.

4. To apply the filter, go to the Actions tab, then click [All Files] or [Selected Files] to apply 
the filter to all data or to soundings on selected lines, respectively.

Note: Use the Undo icon in the left menu Toolbox to reverse this operation.

The following images show how the TPU filter is applied.

Left - Out to 20 or so degrees from the nadir, red shows that the TVU exceeds limits. At 
the edge of the swath, the THU exceeds limits.

Center - Filter preview is applied and marks all soundings that exceed TPU limits with a 
yellow X.

Right - These soundings are removed after the filter is applied.
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• Added the IHO Exclusive Order accuracy standard to the Read Parameters window 
-> Survey tab -> Accuracy Standard dropdown. The accuracy standard sets TPU 
limits. That is, TVU and THU should be less than the selected standard.
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• Added the checkbox “Use Uncertainty Reported by Sonar” to the Read Parameters 
window -> Survey tab -> TPU section. 

Some MBES systems report a range uncertainty, which were previously automatically 
used in TVU (Total Vertical Uncertainty) calculations in MBMAX64. With the new 
checkbox, users can now choose the option they want to use:

> Check “Use Uncertainty Reported by Sonar” to use the uncertainty value from the 
sonar in the TVU calculation. When this option is checked, TVU will be partly 
dependent on sonar reporting of uncertainty. Note that uncertainties may vary 
depending on HYPACK software and device firmware versions.

> Uncheck “Use Uncertainty Reported by Sonar” to use the standard TVU calculation 
and ignore the uncertainty value. When this option is unchecked, TVU and THU 
values in editing are identical or very close to those shown in the TPU editor 
estimation graphs. By default, “Use Uncertainty Reported by Sonar” is unchecked.

• Additional updates have been made to TVU and THU values:
> TVU and THU are now saved to two decimal places when saving to XYZ, TVU, and 

THU formats.
> TVU and THU are now shown to two decimal places in Sounding Info.
> TVU and THU color maximum are now shown to two decimal places.

• Bug fixes. These apply to calculations using uncertainty reported by the sonar:
> Fixed missing conversion from work units to cm when reading uncertainty from HSX 

files.
> Fixed missing conversion from cm to meters in TPU calculations.
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PROCESSING OTHER DATA TYPES

MAGNETOMETER EDITOR

• The Magnetometer Editor now supports data values beyond two decimal places. 
The number of decimal places will depend on the difference between max and min value 
range, so users should be able to see small differences with sensitive sensors.

• Added the Adjust Value dialog, which allows users to manually change units of 
values or add offsets to correct data from the device. 
To use this tool, click Tools -> Simple Adjustment, and the Adjust Value window will 
appear.

Select between Add or Multiply. Add allows you to add an offset, while multiply applies a 
multiplier to the data from the device. Enter the value of the offset or multiplier to the 
Factor field. Select the data you want apply this offset or multiplier to from the Value to 
Adjust drop down. Click [OK] to save these settings.

Some examples:
> To convert data in mg to ug, select Multiply and type 1000 in the Factor field.
> To convert data in meters to feet, select Multiply and type 3.28084 in the Factor field.
> To convert data in Celsius to Fahrenheit, add 32 as the factor, then multiply with 1.8 

as the factor.
• TIN DXF now supports more decimal places for small values. These changes support 

the YSI and Mag dll SMI outputs 3 decimal places for the SMI records, i3XO bin files, and 
Echomapper log files.
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ENVIRONMENTAL EDITOR

• The Environmental Editor now supports data values beyond two decimal places, 
and the Adjust Value dialog has been added as well. Refer to the Magnetometer 
Editor section for more information.

• Some additional updates have been made to the Profile Window:
> Improved autoscaling for small values so the smallest range is less than the previous 

minimum of 0-5. This is to support the very small values (0.001 - 0.000x) that most 
environmental sensors record.

> Window is automatically rescaled when range values go to three decimal places to 
prevent values on the right axis from being clipped.

> Labels for displayed values are now shown at the top of the graph in the color 
corresponding to the data.

• In the Spreadsheet window, column widths are now automatically adjusted to fit 
the header name when you click on the header for that column. The window also 
keeps the new column width.

ADCP PROFILE

• Added the Delete Cell and Delete Ensemble functions to the Profile tab toolbar to 
edit raw data. For more information on using these features, refer to Cleaning Up Data in 
ADCP Profile by Ken Aiken.

To use either of these new features:
1. Click the Delete Cell or Delete Ensemble button. The button will turn blue when 
enabled. 
2. Click anywhere in the profile to delete cells/ensembles.
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The image below shows an example of deleted ensembles (left) and cells (right) boxed in 
red.

NOTE: These edits currently cannot be saved. Closing ADCP Profile and reopening it will 
reset these changes.

FINAL PRODUCTS

HYPLOT MAX
• Users can now select multiple charts and reorder them together in the Draw Order 

tab under the Charts section. To select more than one chart, hold CTRL and click on 
the chart names, then click [Front] or [Back] to move them. The following images show 
this behavior - the left image shows the selected charts, the right image shows the order 
of the charts after the top [Back] button has been clicked.
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• Users can now group and reorder items by clicking and dragging the item name in 
the Items tree view. This includes title blocks, map areas, map items, and plot 
items.

NOTE: Map items (color bar, compass, north arrow, or scale bar) can only exist as child 
items of a map area. While you can add map items to different map areas or reorder 
them within a map area to change the draw order, you cannot move them outside of a 
map area.

> Group items by nesting them under a parent item. To nest items, from the Items 
tree view on the left, click and drag an item and drop it on top of the designated parent 
item’s name (cursor must be on top of the name). The item will be added to the top of 
the list of child items.

If there are already multiple child items, drag the item to the desired position (cursor 
must be next to the names) and drop the item when a split line appears.
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> Child items move with their parent item but also move independently. Multiple 
nesting levels are supported and interesting combinations are possible like having a 
map as a child of a text element.

> You may have noticed from the previous two examples that the split line has 
ends that may curve up or down. The ends curve in the direction of the item that 
will be a sibling of the item you are dragging. These curves are especially useful 
when you are positioning an item before or after an expanded item with children.

In this first example, the Shape item will be positioned between the Arrow and Color 
Bar items.
• To designate Shape as a sibling of Text and Arrow (and a child of North Arrow), 

click and drag Shape between Arrow and Color Bar, and drop when the ends of 
the split line curve up.

To designate Shape as a sibling of North Arrow, Color Bar, and Scale Bar (and a child 
of Map Area), click and drag Shape between Arrow and Color Bar, and drop when the 
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ends of the split line curve down.

In this second example, Shape will be positioned between Map Area and North Arrow.
• If the curved ends point up, Shape becomes a sibling of Map Area (child of New 

Sheet), and is positioned after Map Area and its expanded children.
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• If the curved ends point down, Shape becomes a sibling of North Arrow (child of 
Map Area).

> Reordering items affects the order they are drawn on the plot. Items at the top of 
the list are drawn before the items below them.
The example image below shows the order map items are listed and how that 
corresponds to the draw order in the plot. When Color Bar is listed above Compass, 
Color Bar is drawn first and Compass is drawn on top. When Color Bar is listed below, 
it is drawn on top of Compass.

• Removed the Rotation option for Text plot items. A Text plot item consists of a textbox 
with text inside. At this time, HYPLOT MAX cannot support the rotation of both the textbox 
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and text.

However! You can still rotate the text itself by using the Orientation option in the 
Properties menu. Choose between Horizontal, Vertical Up, and Vertical Down. You may 
need to readjust the textbox to fit the text in the new orientation. An example of each 
option is shown below:
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CROSS SECTIONS AND VOLUMES

• There are new options for saving points in Cross Sections and Volumes: Users can 
choose to save all points in one file, points for each line in separate files, or to save 
only the points in the current line. For all options, users can save data to XYZ or CSV 
files.

To use these new save options, in the Cross Sections and Volumes window, navigate to 
the View tab. For each line, click each point you want to mark in the profile window. Once 
you've finished creating your points, in the Points section click the Save icon. You will see 
the three save options:
> Combined: All points are saved to the same file. Choose file name, save location, 

and file type.
> Individual: Choose between saving the points of individual lines using the line 

number or base survey name for the file name of each output file. Select the folder to 
save the files in, and a warning will appear if an existing file will be overwritten. Note 
that any files that do not have points in them will be deleted.

> Current Line Only: Save all points in the current line to a file. Choose file name, save 
location, and file type.

• Added the Smoothing and Range options to Beach Variable Design Template in the 
Graph Options -> Volume tab. Check “Smoothing” to connect the variable design 
template segments at their intersections. Check “Range” to limit this feature to 
intersections with a DBL value within +/- the value of the user-entered number from the 
original intersection of the two segments. The template segments are only smoothed if 
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the intersection line touches the segment within its points.

An example of smoothing applied to a beach variable design template is shown below.
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TIN MODEL

• Fixed an issue where checking Show Picture in the Export window resulted in 
nothing displaying in the in the picture area of the Volumes dialog. Now, when Show 
Picture is checked, the channel, lines, and borders are shown while volumes are 
calculated, and the TIN model will be drawn when calculations finish.

• The TIN Model program now displays the warning message “Ignored templates, 
complex lines” next to the file name in the main window if a *.lnw is loaded with 
templates but has lines with more than two points. Note that templates cannot be 
displayed with complex lines.

• The 2D Section View Parameters dialog has been updated to display section names 
instead of the section index.
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ENC EDITOR

NEW: SHOM AML

HYPACK now supports SHOM AML in the ENC Editor with the new SHOM AML tool, 
which allows you to create AML-compliant charts and export them as S57 files. With 
this tool, you can set and edit attributes including metadata and import the files needed to 
create your chart. Supported files you can use to build your AML charts include XYZ, DXF, 
KML, KMZ, BRD, LNW, and TGT files.

SHOM AML Dialog

To generate S57 files using the SHOM AML Tool:

1. Prepare your data files. Consider the density of the soundings in your data set. You may 
need to thin your data to improve readability when you display the chart.

2. Launch the ENC Editor.

3. Click Processing -> SHOM AML. The SHOM AML dialog appears.
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4. Modify attributes and upload files to each item in the AML Chart tree view by 
double clicking on each item name. This will open the attribute editor or file upload 
dialog associated with that item.

5. Once you’ve set up your AML Chart, click [Create File] to give your chart a name 
and save it as an S57 chart.

THE FOLLOWING LISTS THE UPDATES AND NEW FEATURES ADDED TO THE SHOM AML 
TOOL:

• Users now have two ways to edit each item in the tree, they can either double click 
the item name, or click on or use the arrow key to highlight the item name and press 
Enter.

• The SHOM AML tree has been reorganized, and some new attributes and minor 
fixes have been added:
> The Chart Boundaries item has been moved to the top of the tree to show its 

importance.
> Added Dataset Name, Intended Usage, and Protective Marking items to the SHOM 

AML dialog.
> Production Agency attribute editor and display now works correctly.

• Elements in the SHOM AML tree are now highlighted with colors to indicate the 
following statuses: 
> Red: Warning, item parameters or source file must be set. 
> Yellow: Item parameters or source file not set, optional. 
> Green: Item parameters or source file set and ready.

• TGT and KMZ files are now supported in the SHOM AML and general import dialog. 
Specifically for SHOM AML, you can now import TGT files for Beach Exit (Point) and 
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Building, Single (Point); and you can now import KMZ files for Coastline (Line) and Road 
(Line).

• The file hySchema.hsf contains codes and descriptions of attributes that are 
selectable for certain items in the SHOM AML dialog.
> Corrected format specifiers inside hySchema.hsf.
> Definitions from hySchema.hsf are now displayed in Attribute Editor for items 

with Code String attribute types. Some examples of these types of items include 
Production Agency, Protective Marking, and Category of coastline.

For example, you can select a code corresponding to a hydrographic agency for the 
Production Agency attribute editor. The code and description correspond to the 
information contained in hySchema.hsf.

• The Attribute Editor now allows editing of string-type attributes in a memo 
component, which makes it much easier to edit lengthy text data. You will see this 
memo component for the items under the Production Information (Area) tree as well as 
some of the attribute values found in the Environment, Seabed and Beach tree. Double 
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click on the desired item to open the Edit Attribute window, edit the text in the memo 
component, then click [OK].

• After clicking [Create File], a completion message now appears at end of the save 
process.

• In the SHOM AML dialog, users can now import a DXF file generated in the TIN 
Editor by using the newly added Depth Contour field. Importing a TIN Editor-
generated DXF file creates Depth Area and Depth Contour chart elements, and 
clips these elements to the chart boundaries.

Before using this new feature, users must load an XYZ file into the TIN Editor and generate a 
DXF file with contours and solid areas:

1. From the HYPACK Shell, click Final Products -> TIN Model to open the TIN Editor.
2. Click File -> Open to open an XYZ file.
3. Click Export -> DXF to open the Export window.
January / 2024  71



4. Make sure Contours and Solid Area options are checked. Also, set the other desired 
options for the export file.

5. Click [Output File], and give your export file a name.
6. Click [Export] to create the DXF file, then [Exit] to close the Export window.

Close the TIN Editor.

To import the DXF File to the ENC Editor using the SHOM AML dialog:

1. From the HYPACK Shell, click Final Products -> ENC Editor. The ENC Editor window 
appears.

2. Click Processing -> SHOM AML. The SHOM AML dialog appears.
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3. Expand Contour Line Bathymetry and check Depth Contour.

4. Double click on “Depth Contour”. You can also highlight Depth Contour and press [Enter]. 
The Contour File dialog appears.

5. In the Contour File dialog, click […] and select the DXF file created in the TIN Editor, then 
click [OK]. The Depth Areas and Depth Contours will be displayed in the final chart.
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UTILITIES

SOUND VELOCITY

• Added support for the Valeport SWiFT CTD.

> Set up, use, process, and download Valeport SWiFT CTD data from HYPACK® or 

HYSWEEP® the same way you would for the Valeport SWiFT SVP device.
> In HYPACK Hardware Setup under HYSWEEP Devices, add the Valeport SWiFT 

SVP driver to use with either SVP or CTD devices. Detection of whether you have a 
CTD or SVP connected occurs automatically without further user input.

> For instructions on processing Valeport SWiFT data, see:
“An Update on Valeport SWiFT Usage within HYPACK” by Andrew Clos.

SBET EDITOR

Several new features have been added to the SBET Editor which are covered in detail in 
“SBET Editor Updates” by Jocelyn Kane. Here is a summary of the updates:

• The blue POS/MV True Heave line is now drawn after a true heave file is loaded. 
Previously, a blue line for heave was drawn at 0 even if a POS/MV True Heave file is not 
loaded. This update ensures the accuracy of the SBET File Editor display by drawing 
heave only from a loaded file.

• Zoom Extents now only uses visible data points to determine and set the window 
view. This means if the data has been edited and the Show Original Data box is 
unchecked, zoom extents only uses the remaining data points to determine the view. If 
Show Original Data is checked, Zoom Extents will take into account the original dataset to 
determine the view.

• Latitude and Longitude display boxes have been added to the top of the SBET File 
Editor window. These boxes display the Lat/Lon values where the cursor is positioned.

• The Delete button has been added to the toolbar, which enables users to delete 
data above or below a specified value. Users can also select a specific part of the data 
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that they want to the deletion and interpolation to apply. This addition helps users remove 
data spikes, which you can see in the example before/after images below.

TIDE ANALYZER

• Users can now upload and compare up to five separate tide files.
To open the Tide Analyzer, from the HYPACK Shell click Processing -> Tides -> Tide 
Analyzer.

> In addition to *.raw, *.log, *.hsx, *.hs2x, and *.tid files, users can now also upload 
*.txt and *.csv files.

> To display or hide tide data on the graph, check or uncheck the corresponding box 
above the Tide File name.
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> To change the color used to draw the tide data on the graph, click on the 
colored rectangle above the corresponding Tide File name to select a different 
color from the Color dialog, then click [OK].

> If you've loaded more than one Tide File, select the tide file you want to use to 
edit your Working File. Under the Smoothing section, type the number of the file you 
want to use in the Comparison Tide File box.
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