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CARIS BASE Editor 4.2.5

Highlights
 Reference model template holes

To improve the flexibility and efficiency in creating models, it is now possible to accept and/or add 
holes to reference model templates. Also, internal holes in LandXML reference models are now 
read and interpreted as holes in the templates.
Holes in reference model templates had been disallowed as they were often caused by digitizing 
issues, and calculations based on such models could misrepresent the data. While it had been 
possible to explicitly add holes in reference model surfaces to model intentional holes, holes are 
not always contained within a single reference model surface. Now, it is possible to explicitly add 
individual holes directly to templates. Because holes remain potentially problematic, they are still 
reported as validation errors, and it is necessary to individually accept each reported hole as a valid 
hole. 

Enhancements

BASE Editor

Reference Description

Format Support

A new Simplify LandXML Files option has been added to the Coverages category in Tools 
> Options. If set, adjacent hole triangles and adjacent horizontal triangles at the same 
depth are automatically combined into larger reference model surfaces.

Reference model XML files can now save "hole" information for templates. This 
information is only available in newer versions of the application. Reference models with 
hole information will still open in older versions, but will not show the holes as holes.

Interior invisible faces in LandXML files are now read from the file and are automatically 
applied as holes to their template. 
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Engineering Analysis

Reference Description

Coordinate Reference Systems

When saving a reference model, the horizontal coordinate reference system (CRS) key, if 
present, is stored for backwards compatibility. Now, the full coordinate reference system 
definition is also stored, which allows storing and reopening a wider variety of datasets. In 
particular, the CRS for LandXML files saved as CARIS reference models is now stored in a 
way that newer applications can reopen the models without any user intervention. 

Warning messages are now displayed for multiple EAM commands if the input data and 
the reference models have different vertical CRS

Model

01202166 It is now possible to set the slope of a segment of a cross-section in the Coordinates 
window. Either the percentage slope or the ratio slope can be manually entered. Setting 
the value of the slope will automatically adjust the elevation of the second point of the 
segment, with the necessary effect on the next segment. Entering a positive value for the 
slope causes the right point in the segment to be above the left point in the segment; a 
negative value for the slope causes the right point in the segment to be below the left point 
in the segment. 

Templates now support holes. Specifically, a Holes tab was added to the Model Feature 
window for templates, where holes can be added and removed - and either shown or not 
shown. The Verify Model command was also updated to provide new links to accept 
specific holes in the template.

When creating a reference model, there is now an option to select the vertical CRS. This 
metadata can be viewed in the Properties of the reference model source.
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Maintenance

BASE Editor

Reference Description

3D Display

Tooltips are now displayed for coverages open in 3D. 

Format Support

Numeric bands in GeoTIFF files were treated as scaler bands with no direction. Now, 
numeric bands in GeoTIFF files are always interpreted as elevation bands. 

Mosaics created in certain versions of HIPS could not be opened in the application. This 
was caused by a mismatch in the short key used for decibels; different cases have been 
used by different versions of HIPS. Capitalization in units is now ignored. As a result, 
mosaics that reference values in db or dB or any other capitalization variant can now all be 
opened. 

Properties

The Show Rejected Points property for point clouds is now respected. 
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CARIS BASE Editor 4.2.4

Enhancements

BASE Editor

BASE Manager

Reference Description

Batch Tools

The extent option is now optional for the JoinPoints process in CARIS Batch.

Coverage Tools

The SPINE water level service, which can be used as a source for vertical shifting a 
coverage, used to be deployed as a separate installation. It is now deployed as a module 
in BASE Editor to be more consistent with the modular structure that is being implemented. 

It is recommended that any installed SPINE plugin be uninstalled.

Miscellaneous

A new Trademarks and Licensing dialog box can be opened from the Help menu. This 
provides a link to the CARIS trademarks information, as well as the licensing information 
for the third-party libraries shipped with the application. 

As this functionality has been added through a new menu item, it is necessary to use 
Window > Layout > Reset Default Layout in order to get access to this command.

Properties

00901647, 
01000375

Since BE 4.2.0, most properties have been shared between the 2D and 3D views. For 
example, the Filter Colour, Tolerance, and Inclusion properties are shared in both 2D and 
3D for raster images with those properties, allowing nodes of a specified colour to be 
filtered out of all relevant views. 

TIN

The shading of triangles has been improved. The differences are relatively small for TINs.

Reference Description

Batch Tools

The BASE Manager executables no longer require users to specify the password to log in 
to the BDB Server database. If no password is supplied in the initial command, the 
command prompt will request it to be specified afterwards. The affected executables 
include bathydbchangepw.exe, bathydbdiagnostics.exe and bathydbserverloader.exe. 
This was done to maintain security when command prompts are logged.



CARIS BASE Editor 4.2.4: Maintenance

CARIS BASE Editor 4.2 Changes List 9

Maintenance

BASE Editor

Reference Description

3D Display

Transparency properties, such as those for reference model surfaces and reference model 
templates in 3D, are now used. This allows visualizing the data just below a reference 
model, for example.

Since BE 4.2.0, the scale is no longer displayed in the status bar for the 3D view. Instead, 
elevation values are displayed, based on the location of the mouse cursor.

The unit of the Vertical Position property for 3D positioning of raster images is now treated 
as an elevation quantity and now respects the z-axis convention set in the application.

The Colour By property for coverage bands in the Properties window was being applied in 
2D, but not in 3D. Now, it is applied in both 2D and 3D.

The values in the colour legend displayed in 3D now respect the z-axis convention set in 
the application.

Track lines from HIPS and SIPS project files (*.hips) now display correctly in the 3D view.

Batch Tools

The CARIS Batch processes for exporting BAG metadata would fail with an error message 
for any Party Role value that contained an underscore (‘RESOURCE_PROVIDER’, 
‘POINT_OF_CONTACT’, ‘PRINCIPAL_INVESTIGATOR’). Values with underscores now 
process successfully.

Descriptive error messages are now displayed when incorrect feature acronyms are 
specified for the contour creation process.

Coordinate Reference Systems

Coverages with geographic coordinate reference systems were incorrectly reporting their 
extents, dimensions and (if relevant) resolutions as if the values were in metres. The 
values are now displayed based on the appropriate geographic coordinate and distance 
properties set in Tools > Options > Units.

Coordinate reference systems (CRS) of third-party files were displayed as “unnamed” CRS 
in some cases. The EPSG naming convention is now used for these CRS. Geodetic CRS 
are displayed with the name of the datum and projected CRS are displayed with both the 
name of the underlying geodetic CRS and the name of the projection.

Coverage Tools

A warning message is now displayed in the combine process if the coverages do not all 
have the same primary band name. If this warning is displayed, it is recommended that a 
rule based on the primary z value be used, rather than a rule based on a band value, such 
as Depth.

Combining multiple point clouds together, through the Copy/Join or Combine processes, 
could result in internal hidden bands being displayed in the resulting point cloud. The 
bands are now properly hidden in the resulting point cloud.
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Dialog boxes that create new files will now remember the last folder used for the output of 
the current process and use that location as the default output folder the next time the 
process is run. Affected processes include Export Raster Product, Export Surface 
Metadata, Export Surface to ASCII, Finalize Surface, Generalize Surface, Vertical Shift 
Surface, Warp Surface, and Copy/Join Soundings.

In Subset Editor, the initial display of the views automatically attempted to maximize the 
display of the data, regardless of the Auto Exaggeration setting. Now, if Auto Exaggeration 
is turned on in the Properties of the Subset Editor layer, then moving the slice resets the 
view to attempt to maximize the display of the data. Turning off the Auto Exaggeration 
property no longer affects the display immediately, and moving the slice after turning off 
the setting will now display the views with the same camera angle and zoom level as it had 
prior to the property being turned off.

The Select All command can now be used to select all the nodes in a raster surface that 
has been gridded relative to a plane.

Support for maintaining designated soundings in CSAR files has been updated. No 
functional changes are expected as a result of this specific change.

Export/Import

Exporting to a raster image format used to give an error about duplicate attribute 
definitions. Now, the export completes successfully.

A better error message is now displayed when attempting to export the view to GeoTIFF 
when the coordinate reference system of the view is not supported by GeoTIFF.

In the Import Wizard, the output resolution used to be interpreted as a value in metres, 
even if the input coordinate reference system (CRS) was geographic and the output CRS 
was set to be the same as the input CRS. Now, the output resolution field uses the units of 
the specified CRS.

When using the Import Wizard, the Horizontal output coordinate reference system (CRS) 
check box is now always unchecked by default. This means the default behaviour is now 
to create the new coverage using the same CRS as the input data.

CSAR raster surfaces could not be imported through the Import Wizard / ImportPoints 
process; an error message about the position band identifier not being set was displayed. 
The position information is now handled more consistently for raster surfaces and point 
clouds, allowing either to be imported.

Features

01503306 The Create by Attribute Value and Select by Attribute Value commands were reporting an 
error for numeric attributes if a value larger than 999 was specified. The layer or selection 
is now created successfully.

When the area of an object cannot be calculated, a message is now displayed in the 
Output window and not through an error message dialog box.

When creating source area features from a contributor band for coverages that do not 
have the names of the contributor fields stored, the dialog box used to show only sample 
values from the coverage. If not all of the values were unique in the dialog box, the ones 
with duplicate names were not mapped to the source area features. The dialog box now 
shows the attribute number as well as a sample value from the file, to ensure that the field 
names for all values in the dialog box are unique and the mapping to source areas is 
successful for all fields. 

The dialog box for creating source area features also now supports resizing the columns 
containing the attributes to be parsed, to more easily read longer source attribute names.

Reference Description
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When browsing for a colour range to apply to feature attributes, the dialog box now 
remembers the last folder selected and starts at that location.

Performing a sounding selection using a clipping layer containing one or more hole type 
cvrage features used to only create soundings for the portion of the source coverage that 
was currently visible in the Display window. Soundings are now created for all portions of 
the source coverage not inside the hole.

Choosing to view soundings using a fractional display for the values in a feature layer was 
causing warnings to be displayed in the Output window and could cause the application to 
close unexpectedly. The soundings are now displayed without unnecessary warnings.

The default sounding suppression options are now set for raster surfaces when no 
sounding rounding rule is selected. This fixes the display of the line under digits 
representing negative values in the raster surface.

Clicking on the property for drawing of engineering digits would turn on engineering digits, 
but would not check the check box and it could not be turned off. Engineering digit display 
can now be turned on and off as expected.

Format Support

The older CARIS format for Multi-resolution Rasters (*.bms) is no longer supported.

Error messages could be displayed when selecting features with no geometries, such as 
area objects that collapsed to points in DGN files. Features with no geometries are now 
skipped when performing selections.

Selecting text objects in a DGN file could cause the application to close. This was caused 
by an attempt to calculate the area of the text. The area field is no longer populated, and 
text objects in DGN files can be selected successfully.

Point cloud support has been updated to include more support for 2D points. No functional 
changes are expected as a result of this set of changes. 

Connecting to CARIS Onboard services has been updated, but no functional differences 
are expected.

In preparation for the future support of a new coverage type in some processes, numerous 
improvements have been made. No functional differences are expected for the currently 
supported coverage types.

Installation

Schemas for format information files (info files) are now deployed with the application.

Miscellaneous

The underlying process framework has been updated as part of the migration towards 
using Process Designer to manage chains of processes. No functional changes are 
expected from these changes.

The method used to create the Python API documentation has been updated. A few links 
to external websites, such as for descriptions of float types, have been removed.

Extra large icons were shown in the Help menu if using a computer with a Windows 10 
operating system. Icons are now displayed as expected.

Redrawing the view while a selection was in the middle of being drawn could cause the 
application to close. Now, the drawing of the selection finishes before the view is redrawn.

A number of error messages have been updated or added, replacing some internal error 
messages.

Reference Description
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Limits and Boundaries

General Notices
 Surface Extract Maintenance

Surface extract has been updated in preparation for making it available through CARIS Batch. As a 
result, extracting from a raster surface gridded relative to a plane is temporarily disabled in this 
update.

The reporting of messages has been streamlined, but no functional difference is expected. 

Options

Certain colour legend options were not being applied. The option to set the colour of the 
labels in the legend has been removed. The other properties have been updated to ensure 
they pick up the values set in Tools > Options.

Invalid Tools > Options settings could cause the old Tools > Options dialog box to be 
displayed when the application was started. This happened, for example, when the 
application was installed to one location, uninstalled, and then installed to a new location. 
Now, the expected dialog box is displayed, and file paths are checked to ensure they are 
valid.

Properties

For reference models and vector files that have not yet been converted to the new style of 
properties, which share content for all views, the wrong set of properties could be shown, 
depending on the order of clicking in the Layers window. Attempting to change the 
properties could also cause an error and/or could cause the application to close 
unexpectedly. The appropriate properties are now shown for the active view, and can 
generally be updated and applied to the display.

Reference Description

Templates

Previously, only the object acronyms were saved in the LBM templates. Now, object 
properties are also saved. Note that templates saved from previous versions will still only 
contain the object acronyms and not the properties.

Reference Description
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CARIS BASE Editor 4.2.3

General Notices
 Coverage Generation Issue

A critical issue was identified affecting some processes that generate CSAR raster surfaces and 
point clouds. The issue could result in the generation of an incomplete output coverage or in a 
process failure. In many cases, the issue would have no effect at all and the coverage would be 
generated correctly. In particular, raster surfaces and point clouds generated using the import 
points (Import Wizard), grid points, combine, join, interpolate holidays, and interpolate from TIN 
processes are affected. The issue is fully addressed in BASE Editor 4.2.3.
The issue exists in BASE Editor versions 4.2.0, 4.2.1 and 4.2.2. It would be prudent to regenerate 
coverages made with any of the listed processes with those versions of BASE Editor. We apologize 
for any inconveniences that this may have caused.

Enhancements

BASE Editor

Reference Description

Export

01301185,  
01402060,  
01500007,  
01503036,  
01600326

When exporting a raster surface to the ESRI ASCII grid format, the value used to 
represent nodes with no known value has been updated to be a value like -99999.0, 
depending on the band type, to be more consistent with the no data values used by other 
software for this format.
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Maintenance

BASE Editor

Reference Description

Batch Tools

The error message when attempting to use the AddToRasterCombine processes in BE 
4.2.x using a combined surface created in BE 4.1.x has been improved to better inform 
users when a combined raster surface was created with an older version of the software 
and is not supported.

Coverage Tools

Several processes that create CSAR coverages (raster surfaces and point clouds) could 
produce inconsistent results since BE 4.2.0. Observed behaviour includes that sometimes 
the coverages were created as expected, sometimes the coverages were created based 
on only a subset of the input points, and sometimes the coverage creation would fail. This 
problem has been corrected and raster coverages are now created correctly. 

Interpolating a raster surface from a TIN created from features, for example features in a 
HOB file, used to give an internal error message. Now, it completes successfully.

When shifting a coverage using an ASCII file, additional file extensions are now provided 
in the drop-down filter to make it easier to find the appropriate ASCII file.

Export

01301482 Exporting a selection of features to ASCII could create an ASCII file with a mismatch 
between the headers and the delimiters. This happened when a delimiter between fields 
was also used internally in one of the values, such as when a semi-colon was present in 
the display information field and used as a delimiter. Now, quotation marks are used 
around all populated values in the exported ASCII, allowing third-party applications to 
properly match the headers and values.

Format Support

Mosaics created in older versions of HIPS could not be opened in the application. This was 
caused by a mismatch in the short key used for decibels. The short key is now “db” and 
these mosaics can now be opened.

Properties

Changing the z-axis convention could change the order of minimum/maximum properties 
in the Properties window for elevation bands, in addition to properly changing the values. 
Now, the order of the properties stays consistent when the z-axis convention is changed, 
and the values of the properties still change properly.

Raster image colour channel information is now saved in an .aux.xml file when the channel 
properties are changed within the application.

The line weight for geographic and projected grids now supports decimal values, and the 
default weight has been updated to be the smallest supported value, 0.01.
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BASE Manager

Miscellaneous

Changing settings in Tools > Options and Tools > Modules were only saved when the 
application was closed. As a result, starting a new instance of the application after 
changing the settings would still use the old settings. Now, the settings are saved as soon 
as they are applied.

If additional environment variables were needed when the application was started, and the 
Cancel button was pressed on the Options dialog box, the application continued to start 
and an error message was displayed, depending on which mandatory environment 
variables were not set. Starting the application is now cancelled if the Cancel button is 
pressed.

Reference Description

Database Objects

It is now possible to use the Edit > Survey command to change the extents of an existing 
survey object in a BDB Server database.

Reference Description
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CARIS BASE Editor 4.2.2

Enhancements

BASE Editor

Maintenance

BASE Editor

Reference Description

2D Display

In order to better display side scan data from sources such as CARIS Onboard, two new 
colour maps are deployed with the application, specifically the Copper and the Terra di 
Siena colour maps.

Reference Description

3D Display

Transparency is available for both raster surfaces and raster images in 2D, but only for 
raster images in 3D. Transparency has been disabled for raster surfaces in 3D.

Values in the vertical position property are now applied when displaying the same raster 
image a second time in the 3D view.

Viewing a WMS in 3D could fail with an error message about a NULL source if the 
resolution was very fine compared to the extents of the data. Now, the resolution is 
increased to be coarser if too many cells would result, and the WMS is displayed in 3D.

Drawing a raster as points in the 3D view could cause the application to become 
unresponsive. This has been fixed.

Batch Tools

For the CombineToRaster and ServerCombineToRaster processes, the short key for the 
UseCellCentres option has been updated to be ‘n’, in order to ensure that there are unique 
short keys for all options.

Coordinate Reference Systems

01500134 Raster surfaces, such as ECW files, that support specifying the coordinate reference 
system through the Properties window CRS entry now apply the user-specificied CRS, and 
save the new CRS in an RXL file.

01600280 User defined transformations in coordinate reference systems are now respected when 
opening GML files, fixing some issues with incorrectly displayed data.

Exporting a profile to ASCII or DXF could fail with an error message about not finding a 
coordinate reference system (CRS) with an empty identifier, depending on the CRS used. 
Now, instead of storing the CRS identifier, the CRS well-known text is stored in the 
application settings, so any supported CRS can be used.
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Since BE 4.2.0, as part of the rework for coordinate reference systems (CRS) and the 3D 
view, TINs with a geographic CRS are now displayed correctly. 

Coverages

01401004 As of BE 4.2.0, bands have a read-only minimum and maximum value. This value is not 
changed by grouping and ungrouping. Grouping coverages applies a uniform colour range 
over all coverages, by design, and coverages that are subsequently ungrouped retain that 
uniform colour range. If it is desired to restore the original colour range, the read-only 
minimum and maximum values can be manually copied into the colour range fields.

It is now possible to clear the comments and platform names for CSAR coverages through 
the Properties window.

Coverage Tools

Generalized surfaces are now opening automatically after the generalize process is run 
through the application.

Selecting points in Subset Editor could cause the application to close randomly if areas 
within the selection were empty of data. The selection now completes successfully.

It is now possible to use the Close command to remove an item from the list of Reference 
Sources in Subset Editor. The sources still remain open in the application.

The Combine Surfaces deconfliction page is now only marked as complete, with the check 
mark at the left, when one or more fully populated deconfliction rules have been defined.

Rules for selecting objects in a query and rules for deconflicting coverages in combine 
could not be created in the same application as they were stored in the same internal 
storage but contained incompatible content. Now, the different types of rules are kept 
separate internally, and both kinds of rules can be created. 

This was experienced by users who created a database query and then created a combine 
rule, resulting in an uninformative error message. There might be other circumstances that 
would also produce failure cases as a result of the rule incompatibility. 

When performing a vertical shift using the SPINE water level service, the password is now 
hidden as it is typed, and the password is not stored in the process lineage.

Edits made to a TIN created from a HOB layer were not being reapplied when the file was 
reopened and the TIN created again from the same layer. A .tls file is now stored, so any 
user edits to the TIN are now reapplied when the TIN is created again.

Import

01600796 When importing a HOB file to a coverage through the Import Wizard, sounding features 
were imported with the incorrect sign. Soundings are now imported correctly.

Note that the z-axis convention is not applied, as soundings are known to be in the 
"down is positive" convention.

Miscellaneous

01600800 It is now possible to select an existing file when assigning the unique object ID file that 
contains the setting for creating FOIDs. 

The links in the main documentation page were fixed so that they will load the appropriate 
content, when accessed through a supported application such as Abobe Reader, even 
when the application is installed to a non-standard location.

Reference Description
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BASE Manager

Engineering Analysis

Reference Description

Coverages

Coverages with unsaved changes, such as updates to the bounding polygon, cannot be 
loaded into a BDB Server database. The application now prompts to save the coverage, as 
appropriate.

Export/Import

True position bands, such as Depth_Pos, may be shown in the database extraction dialog 
box, but are not exported as separate bands if they are selected for export because the 
true position information is exported with the coordinates for both ASCII and CSAR 
exports. Previously, an error message was displayed if a true position band was selected 
for export to ASCII; now a warning message is displayed in the Output window.

When importing selected objects to a BDB Server database, the Import Selected Objects 
dialog box now only lists available database layers, eliminating the possibility of selecting 
an invalid layer.

Reference Description

Shoals

As part of shoal detection, a portion of the coverage around the shoals is extracted, with a 
buffer applied to include data in the neighbourhood of the shoals. The extraction was 
failing with an error message for shoal detections from raster surfaces. The extraction, and 
shoal detection as a whole, now completes successfully.

01300560 As part of shoal detection, a portion of the coverage around the shoals is extracted, with a 
buffer applied to include data in the neighbourhood of the shoals. For projected coverages, 
the buffer was incorrectly calculated in degrees instead of ground units, resulting in much 
larger areas being extracted, often the entire dataset. The buffer is now correctly applied, 
and the extracted coverage now only contains data in the neighbourhoods around the 
shoals.

Volumes

01600660 With hyperbolic volumes, in a rare case when the intersection between a hyperbolic 
paraboloid and the model was a vertical line, infinite volumes and areas could be reported. 
The proper volume results are now reported.



CARIS BASE Editor 4.2.1: Maintenance

CARIS BASE Editor 4.2 Changes List 19

CARIS BASE Editor 4.2.1

Maintenance

BASE Editor

Reference Description

Coverages

Moving a coverage from one group to another group would fail with an error message, and 
the application would close when the next operation was attempted. Moving coverages to 
another group can now be done successfully.

Coverage Tools

Starting Subset Editor could cause the application to become unresponsive. This 
happened if Subset Editor had previously been turned on with different modules enabled. 
Previously, only a single layout file was used with Subset Editor regardless of which 
modules were enabled. Now, each module configuration has its own layout. 

Note that as a result of these changes, any Subset Editor layouts created in BE 4.2.0 are 
ignored.

When exiting Subset Editor, the Layers window was not always refreshed immediately, 
leaving orphaned Subset Editor entries in the Layers window. Attempting to use those 
layers could cause the application to become unstable. This happened if the 3D view was 
the active view, or the Engineering Analysis module was turned on. Now, a regular 2D view 
is always set as the active view when Subset Editor is closed, and the Layers window is 
refreshed as expected. 

The Cross Profile command would clear the selection and fail with an error message if the 
Profiles layer was not open prior to selecting the command. Now, the Cross Profile 
command works as expected regardless of whether the Profiles layer is already open.

The profile of TINs created for raster surfaces gridded relative to vertical walls did not 
display in the Profiles window. The profiles of the TINs can now be displayed.

Import

When importing data through the Import Wizard, the application could close unexpectedly. 
This happened randomly; the same dataset could work once and fail the next time. The 
import now consistently completes successfully.

Note that the import may take slightly longer as a result of this fix.

Installation

The Repair Installation option has been added to the BASE Editor installation files
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Engineering Analysis

General Notices
• The following general notice was missed in the BE 4.2.0 changes list:

The Add to Raster Combine processes only work with combined surfaces created in the same 
version. For example, to use ServerAddToRasterCombine in BE 4.2.0 or later, it is necessary to run 
a full server combine with BDB Server 4.2.1 or later.

Reference Description

Coverage Tools

It was not possible to create a profile for a reference model if the view had been rotated 
using the coordinate reference system of a vertical wall. Profiles can now be created for 
reference models, regardless of the view rotation in the Display window.

Miscellaneous

The Layers window now displays an indicator on the reference model layer for CARIS 
reference models if the model has been changed by another application and needs to be 
reloaded to be up to date.

The Layers window now shows the current name of the reference model if it has been 
renamed using the Save As command.
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CARIS BASE Editor 4.2.0

Highlights
 Subset Editor
The Subset Editor, which is used to visualize, validate and clean point clouds in BASE Editor™, has 
been upgraded to use our latest 3D framework. The new framework provides a modern and scalable 
platform for working effectively with large volumes of data from multibeam, laser scan, and LiDAR 
surveys. 
Along with the new 3D technology, we are also pleased to offer new functionality and a new look and 
feel in the Subset Editor. The Subset Editor now allows simultaneous editing of many clouds.  It offers 
new visualization opportunities such as custom colouring based on non-elevation data sources (i.e. 
Intensity, Uncertainty) and a more flexible use of reference data to provide context. The interactive 
experience in the Subset Editor has been brought in line with our 2D and 3D views with a move to 
shared user interface settings, controls and properties.

 New tools for analyzing vertical and inclined surfaces
New tools are available for working with raster surfaces that are referenced to vertical and inclined 
planes through the Engineering Analysis Module™. The vertical and inclined plane surfaces can be 
used in volume calculations and can be contoured creating true 3D lines that can easily be exchanged 
with other third-party applications. The addition of these tools allows for more complex workflows to be 
applied in deformation analysis of quay walls and other important infrastructure in ports and waterways.

 Improvements to the user experience
CARIS1 is engaged in an ongoing move to provide an improved user experience through integration 
and consistent handling of data inside the 2D and 3D views of the applications. The goal is to provide a 
simple interface and seamless transition when interacting with data in any view. With the BASE Editor 
4.2.0 release the user will see newly designed properties for raster, cloud and TIN datasets. A number 
of new options are presented including the ability to drape high resolution imagery (e.g. backscatter) 
over elevations in both 2D and 3D views. Also, a new user interface is provided to investigate the 
processing lineage of a dataset recorded in the metadata.

 Coordinate reference system enhancements
A new system for controlling the use and application of coordinate reference systems (CRS) in CARIS 
applications has been implemented. CARIS applications now make use of the EPSG Geodetic 
Parameter Dataset developed by the International Association of Oil and Gas Producers (IOGP). The 
EPSG dataset is used as the primary source of coordinate reference systems and transformations. The 
EPSG source can be augmented or overwritten by the familiar CARIS coordinate system files for those 
organizations that support custom and legacy CRS information. In addition to providing an extensive list 
of reference systems used all over the world, the EPSG dataset also offers access to additional 
transformation types such as NTv2, thus giving users greater flexibility and choice.
With the move to EPSG, the user interface was upgraded with a new look and with additional 
capabilities. Users can now build a favourites list, see a list of recently used CRS entries, search for 
new entries and investigate all aspects of the selected reference system or transformation.

1. This term is a trademark of CARIS (Universal Systems Ltd.), Reg. USPTO & CIPO.
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 Feature editing and mapping
CARIS has an ongoing initiative to consolidate the tools across all applications for working with vector 
geometries. This means that basic vector editing capabilities such as buffering, corridor and parallel 
line creation found in S-57 Composer™ and HPD1 Source Editor™ are now offered as part of the 
BASE Editor toolkit. Other improvements such as new geometry mapping options to convert data from 
area to point, area to line, and sounding to point, are also now available to all BASE Editor users, thus 
providing enhanced feature compilation capabilities within the application.

 Catalogue editor
A Catalogue Editor is provided for customizing objects and attributes in the pool and profile system files 
that make up the feature catalogues used in the application. The editor can be used to edit deployed 
catalogues for ENC and other chart production activities or to build them completely from scratch for 
any purpose. The creation and maintenance of catalogues was previously done with an XML editor.
As before, the Catalogue Editor is used to edit features in the Bathy DataBASE Server™ feature 
catalogue; this is accomplished now by establishing a direct connection to the database. The 
Catalogue Editor is now more general purpose and is part of the BASE Editor client application rather 
than installed as part of Bathy DataBASE Server.

 Bathy DataBASE evolution
The Bathy DataBASE2 product suite is undergoing a number of changes as CARIS prepares to offer a 
simplified product line and system architecture. Additional detailed information about each of these 
changes can be found below in the Improvement and Maintenance sections of the Changes List 
document. Contact CARIS Customer Services to discuss the potential impact of these changes in 
relation to workflows at your organization or application deployment and maintenance procedures.

• Modular architecture
System administrators should note a number of changes to the BASE Editor installation that may 
affect how the application is deployed and maintained. The system files and folders associated with 
each licensed module (i.e. BASE Manager™) are found in the .../modules/ folder in the installation 
location. This allows the separation of product specific content from the shared CARIS application 
that underpins multiple CARIS products. This work has resulted in the creation of a new module 
named Feature Editing that contains vector feature creation and editing tools common to all CARIS 
applications. The addition of this new module will require all existing licenses to be updated.

• Environment settings
The environment settings have been consolidated into the Tools > Options dialog and are 
managed exclusively through an environment system file. The Windows registry is no longer used. 
Additionally, system files that are frequently customized by the organization or user, such as 
catalogue control file, are now managed differently. Customization is applied through appended 
and overwritten entries applied at the local machine or user level. The environment system file and 
the other customizable system files can still be customized and appended to by an organization to 
support a custom deployment as in the past but through a different procedure. This is covered in 
detail in documentation provided with the installation and the CARIS Online Customer Services 
website.

1. This term is a trademark of CARIS (Universal Systems Ltd.), Reg. USPTO.
2. This term is a trademark of CARIS (Universal Systems Ltd.), Reg. USPTO.
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• Processes
Processes made available through the CARIS Batch command line interface have undergone an 
important transformation as part of a move to include CARIS Batch in all new CARIS applications. 
This allows the use a single platform for all command line tools going forward and normalizes 
processes to make access through additional interfaces in the future possible. In all cases, the 
processes and process parameters have been restructured to be consistent in use and 
presentation. In some cases, the processes were made more general in nature and more granular. 
Several new processes were added including contouring and the export of raster surfaces to the 
STL format for 3D printing. One benefit of these changes will be the opportunity to build more 
complex, cross-product automated workflows. As a result of the changes, existing command line 
and Python script based automated workflows that call CARIS Batch processes will need to be 
adjusted. Organizations should consider the impact of having to adjust automated workflows when 
deciding when and how to proceed with upgrading to the new version of Bathy DataBASE. Contact 
CARIS Customer Services with questions or guidance as needed.

• BDB Server
The client and server components of Bathy DataBASE are no longer be released concurrently and 
are versioned independently. Organizations will be advised when a compatibility break between 
client and server versions is planned. This decision was adopted in order to allow greater flexibility.
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Enhancements

BASE Editor

Reference Description

2D Display

It is now possible to rotate the 2D view to view raster surfaces face on. The default view 
remains a top-down view, but the "Use Coordinate Reference System" function can be 
used to rotate the view to view raster surfaces gridded relative to planes in the plane it was 
defined. Point clouds and 3D lines are also displayed in the rotated view as expected, and 
any raster surfaces gridded with respect to a different plane are displayed as point clouds.

Note that if you have Tools > Options set to use the coordinate reference system of the first 
open map, opening a vertical raster surface first will still result in a top-down coordinate 
system, as that is generally better to use when viewing multiple datasets at once. It is 
necessary to explicitly use "Use Coordinate Reference System" on an open raster surface 
to rotate the 2D view.

The new Tools > Swipe command splits the Display window into two panes so that you can 
visually compare two layers (chart or external file) simultaneously. Handles along the top 
and side of the window allow you to resize the viewing area of either pane. 

The new Tools > Flicker command alternates the Display window between two open layers 
(chart or external file) so that you can visually compare differences between layers 
simultaneously. The duration of each view is set through the new Layer Differences toolbar 
that can be accessed through View > Toolbars.

The range of colours available for masking in a background image (TIFF, JPEG, GIF etc) 
has been expanded with a new colour picker in the Properties window. 

The Filter Tolerance option expands the range of masking from 0 (only the selected colour 
is masked) to 100 (all image colours are visible) starting from the selected masked colour.

A Filter Inclusion reverses the masking selection so that only the selected colour is 
masked and all other colours are visible (if mask tolerance = 0).
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It is now possible to control the range of values used to display an image. This is especially 
important for multispectral images, which often only contain values in the bands that are a 
small fraction of the values available. By default, the image being displayed is very dark, 
as the lighter colours are reserved for the other, unused, values. Now, it is possible to re-
scale the data, such that the full span of lighter and darker colours are used to display the 
image. This is controlled through the Pixel Normalization property. The user can choose to 
either re-scale each band based on its data to get the best presentation of each individual 
band, or re-scale based on all values in all the bands to ensure that the presentation in 
each band is consistent with the presentation in the other bands of the same image. 

The session file format has been updated to ensure that sessions are opened with exactly 
the same settings as when the session was saved. Now,

• the active view is stored,
• view names are stored, and
• the display name for sources are stored, when needed.

Older sessions can still be opened, but sessions are saved in the new format.

Only a single session file can now be open at once. As a result, when the session is 
closed, the application will prompt to save the session, provided that any relevant changes 
were made. 

Sources in another session file can be opened in a currently active session by selecting 
the new File > Add Sources from Session command. 

A recently active session file can be reopened from the new File > Recent Sessions list. 
The number of sessions in the list is determined by the new Number of Recent Files 
Shown in Tools > Options.

The number of files shown in both the File > Recent Files and File > Recent Sessions 
menu items is controlled through the new Number of Recent Files Shown option in Tools > 
Options.

The name of an open session is now displayed on the title bar of the application.

The new Windows > Layouts > Load Layouts command opens a saved layout file. The 
layout can then be selected and used on the workstation.

This ensures that all workstations can access and use a common layout file stored in a 
network location rather than having each workstation have a local copy of the file. 

3D Display

01000300 
01302798

The resolution of raster images and draped raster images has been significantly improved.

Reference Description
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The 3D view controls have been updated. Improvements include enlarging the vertical 
exaggeration to allow more fine-grained control; the control is larger depending on the 
height of the 3D view. If the 3D view is smaller than a certain size, the control is not 
displayed. Similar changes were made to other controls, to make them more consistent 
and/or usable in various contexts. For example, the legend was moved to the left of the 
screen and similarly resizes with the view. Note that the option for turning the legend on or 
off in 3D is Tools > Options, under Display > 3D.

The controller for navigating in the 3D view was removed as it was unnecessary; there are 
other existing tools to navigate in the 3D view.

Datasets courtesy of Kraken AquaPix® InSAS

More non-elevation numeric bands can now be displayed in the 3D view. For example, 
Density, Slope, Aspect, and Holidays bands can all now be displayed. These bands 
individually display in meaningful ways, based on the raw values, but if bands with different 
kinds of data are turned on in 3D, the amount of meaningful comparison that can be done 
between the bands is limited.

Colour bands can also be displayed; they display at the node locations of the primary 
band.

3D vector lines are now drawn as 3D lines in the 3D view. 

Close All can now be used to close all open datasets, even when the 3D view is active. 

The frame rate in the 3D view has been increased and the number of dropped frames has 
been decreased. This produces a much smoother visualization with reduced flickering and 
shimmering. 

Reference Description
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The visualization options for coverages have been improved significantly. Bands in point 
cloud, rasters, and TIN layers have consistent colouring options. It is possible to setup the 
colouring both on a colour file and by draping an image on the coverage. This can be 
applied to the coverage as a collection of points, as a collection of digits, displayed as a 
surface (TINs or rasters), and/or as a wireframe (TINs) or cell boundaries (raster). It is 
possible to turn these various representations on or off as needed. The specified colouring 
is applied to all representations by default, but if one of the representations needs to be 
displayed prominently over any other representation, it is possible to apply an override 
colour.

For example, it is possible to display a raster surface, drape a raster image over the 
surface and use a rainbow colour file to display any parts of the raster surface not covered 
by the raster image. It is also possible to simultaneously display the raster surface cell 
boundaries in red and the nodes in black over top of surface representation.

The display of the various representations is done in the order of the properties. For 
example, a raster is first displayed as a surface, then as points, then as cell boundaries, 
then as digits. This ensures that any number of the options can be turned on at once and 
all can be displayed.

Batch Tools

CARIS Batch is intended to be single command line tool for all CARIS applications; 
replacing older command line executables with new command line processes in CARIS 
Batch will continue in future versions. Existing processes in CARIS Batch have been 
restructured to have consistent styles and parameter names. This has been done in order 
to simplify chaining multiple processes together, and to allow exposing the same 
meaningful sets of functionality through multiple interfaces. This has resulted in new 
options being available in some processes, and some changes in behaviour; in certain 
cases, some functionality may have been removed from one process and exposed in 
another process, such that the two processes can now be run in sequence to meet the 
same need.

The main CARIS Batch executable has also been updated to have new options --verbose 
to have more detailed information displayed in the command prompt window, and --version 
to identify the version associated with this executable. Note that the version of CARIS 
Batch is associated with internal versioning of the framework shared by all CARIS 
applications, and is not directly linked to the version of the specific application that it is 
deployed with. 

Reference Description
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The ExportRaster process replaces the SurfaceExport process. Note that the new process 
accepts either raster surface or raster image inputs; the output will always be the same 
type as the input. That is, a raster surface input will always be exported as a raster surface, 
and a raster image input will always be exported as a raster image. To produce a raster 
image from a raster surface, use the RenderRaster process.

Clipping and tiling are no longer part of the process to export a raster, but are independent 
processes, ClipRaster and TileRaster. This simplifies chaining processes together to form 
complicated workflows.

It is now possible to export a raster to a CSAR using the ExportRaster process. This has 
more options than the CopyToCSAR process, specifically the ability to specify a limited 
number of bands to be exported. Raster surfaces and raster images can be exported to 
CSAR.

When exporting a raster to a GeoTIFF or CSAR, it is possible to use the new keyword ALL 
to include all bands in the output. It is also now possible to specify the compression type 
for GeoTIFF output.

It is also now possible to export a raster image to JPEG or PNG, as well as to CSAR, and 
GeoTIFF which had been supported in previous versions.

The ExportRaster process can also be used to export raster surfaces to the STL format, a 
common interchange format for 3D printers.

The RenderRaster process replaces the ImageExport process. The RenderRaster process 
always creates a CSAR raster image; to create other raster image formats (GeoTIFF, PNG, 
JPEG), run ExportRaster after running RenderRaster.

Note that clipping and tiling are now provided as separate processes that can be chained 
together as appropriate with other processes.

The ShiftElevationBands process replaces the VerticalShift process. The most important 
difference is that it is now possible to specify both bands that are to be shifted (input 
bands) and bands to be carried over with their original values (include bands). It is possible 
to use the new keyword ALL; if used for input bands, all elevation bands are shifted, and if 
used for include bands, all bands other than the input bands are included. The primary 
elevation band of the source coverage is always shifted as an input band. When shifting by 
a single value, the value must be an elevation, with the up is positive Z-value convention, 
and must specify the unit. Note that shifting by BIN files has been consolidated into the 
more general shifting by raster surfaces. 

01500742 The ContourRaster process has been added to allow creating isolines of equal value of an 
attribute. It is expected that depth area creation will be added in a future version. 

When contouring through the command line, it is now possible to specify DXF as the 
output format. While contouring with the HOB output format always produces 2D 
geometries with the contour level stored in an attribute, contouring to DXF output format 
always produces 3D geometries based on spatial data with the contour level stored 
implicitly in the geometry. As a result, contouring with DXF output allows contouring raster 
surfaces gridded relative to planes, such as raster surfaces representing vertical walls. 

The FillRasterHolidays process replaces the Interpolation process. The most important 
difference is that it is now possible to specify both the band that is to be interpolated (input 
band) and bands to be carried over with their original values (include bands). It is possible 
to use the new keyword ALL to include all bands other than the input band. 

The ClassifyRasterHolidays process replaces the IdentifyHolidays process. The 
functionality of the two processes is fundamentally the same. 

Reference Description
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The JoinPoints process replaces the CloudJoin process. The new process creates a 
Contributor layer, and allows specifying how to populate those values. The 
ServerJoinPoints process is now available if the points are in a BDB™ Server database 
and the database object metadata are to be used to populate the Contributor layer.

Note that JoinPoints always creates a new point cloud. It cannot be used to modify one of 
the inputs.

The CombineToRaster process replaces the Combine process. The 
ServerCombineToRaster process replaces the ServerCombine process. The functionality 
of the processes are fundamentally the same. 

The AddToRasterCombine process has been reworked. The main difference is that the 
first input must now be the combined raster that is the source of the combine parameters. 
Note that you can only add to a combined raster created in the same set of software 
versions, i.e. the combined raster must have been created in BE 4.2.x for 
AddToRasterCombine to add to it in BE 4.2.x. The ServerAddToRasterCombine process 
has been similarly reworked, and has a similar restriction. 

The ImportPoints process replaces the SurfaceImport process. It is possible to use the 
new keyword ALL to include all bands other than the primary band. Note that the default z-
axis convention of the input for most formats is that up is positive.

When importing to a raster, it is now possible to specify any anchor location for the centre 
of a cell; this can be used to align the output raster surface with an existing grid. The 
anchor can be outside the extent of the data as it is simply used to anchor the grid. Any x 
and y coordinates can be used for the anchor, and the default is to create grids with the cell 
centres at multiples of the resolution. There is a special keyword HALF_RES that can be 
used to create grids that are aligned with their lower left corners at multiples of the 
resolution.

The configuration file option to specify an XML file containing the options for the process is 
no longer required as the support for the various options has been integrated into the 
process. 

When using ImportPoints with NTX input, the option to Include3DSymbol is now 
repeatable, and requires specifying which symbols are to be imported. The ALL keyword is 
available to import all 3D symbols.

Also, the format for accepting and rejecting based on the NTX flag has been adjusted. 
Now, each of the three flags, Selected, Suppressed, and Background, can be set explicitly 
to be accepted or rejected. This allows the default behaviour in the command line to be to 
accept Selected soundings and reject the others. 

The ExportCoverageToASCII process replaces the SurfaceToASCII process. It is possible 
to use the new keyword ALL to include all bands. Note that the bands require specifying a 
precision, and that is also the case when using the ALL keyword. A typical usage may be "-
-include-band ALL 2" to include all bands with two decimal places of precision, where 
applicable. Note that if you explicitly specify bands with other precision before using the 
ALL keyword, the specific definitions will be respected for those bands and the settings for 
ALL will be used for the bands not specifically otherwise set.

The order of the bands in the output is controlled by the order of the bands specified in the 
command line. Note that any bands added through the use of the ALL keyword are sorted 
alphabetically. 

Reference Description
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The WarpRaster process replaces the SurfaceWarp process for raster inputs. It is now 
possible to specify any anchor location for the centre of a cell; this can be used to align the 
output raster surface with an existing grid. The anchor can be outside the extent of the 
data as it is simply used to anchor the grid. Any x and y coordinates can be used for the 
anchor, and the default is to create grids with the cell centres at multiples of the resolution. 
There is a special keyword HALF_RES that can be used to create grids that are aligned 
with their lower left corners at multiples of the resolution.

It is also now possible to use the new keyword ALL to include all bands other than the input 
band. Note that the bands require specifying an interpolation and sampling, and that is 
also the case when using the ALL keyword. A typical usage may be "--include-band ALL 
NONE FOLLOW_PRIMARY" to include all additional bands, performing no interpolation 
and simply taking the value for each band from the winning node in the primary band. Note 
that if you explicitly specify bands with other interpolation or sampling before using the ALL 
keyword, the specific definitions will be respected for those bands and the settings for ALL 
will be used for the bands not specifically otherwise set. 

The WarpPoints process replaces the SurfaceWarp process for point cloud inputs. 

The FinalizeRaster process replaces the Finalize process. Note that when specifying 
elevation values, the value must have the up is positive Z-value convention, and the unit 
must be specified. For example, filtering out all depths in the primary elevation band 
shoaler than 2 metres or deeper than 4 metres would be "--filter -4m -2m". It is possible to 
use the new keyword ALL to include all bands other than the primary elevation band. 

The GeneralizeRaster process replaces the Generalize process. Note that when 
specifying values, the unit must be specified. It is possible to use the new keyword ALL to 
include all bands other than the primary elevation band. 

The CopyToCSAR process replaces the SaveAsCSAR process. The functionality of the 
two processes is fundamentally the same. 

The ExportCoverageMetadata process replaces the MetadataExport process. The 
functionality of the two processes is fundamentally the same. It is no longer required, or 
possible, to specify the band for the BAG metadata export as the specified band name was 
never included as part of the metadata. 

The DescribeRasterProduct process replaces the RasterProduct process. The 
functionality of the two processes is fundamentally the same. 

The GridPoints process has been reworked. It is now possible to specify any anchor 
location for the centre of a cell; this can be used to align the output raster surface with an 
existing grid. The anchor can be outside the extent of the data as it is simply used to 
anchor the grid. Any x and y coordinates can be used for the anchor, and the default is to 
create grids with the cell centres at multiples of the resolution. There is a special keyword 
HALF_RES that can be used to create grids that are aligned with their lower left corners at 
multiples of the resolution. 

It is now possible to add general textual metadata to CSARs created through many 
processes using the --comments option. The can be used to provide context for the 
coverages. This replaces the Description option that had previously only been available for 
the combine processes. 

Reference Description
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Coordinate Reference Systems

When selecting a coordinate reference system (CRS), a new searchable dialog is 
presented. It is possible to search from the available CRS by entering any part of a CRS 
identifier, name, or area of use. 

There are a number of tabs, including the current CRS, the search results, as well as 
recently used CRS, and favourites. Any CRS can be set as a favourite by hovering the 
mouse over the entry and clicking on the grey star; clicking on a gold star removes it from 
the favourites list. 

Reference Description
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When displaying coordinate reference system (CRS) information in the application, a more 
complete definition of the CRS is available, including any vertical CRS metadata available. 
That includes the CRS of open sources through the Properties window as well as the CRS 
of the view through the status bar, as well as in various messages. Generally, clicking on 
the CRS displays the "Select Coordinate Reference System" dialog, which shows the 
current CRS. There is an information icon for the CRS that can be used to display the 
"Coordinate Reference System" dialog, which contains expandable details and a well-
known text representation of the CRS.

Note that certain CRS, such as the CRS of BSB KAP, are not encoded in a way that they 
can be displayed with this detail. The CRS is blank in the properties for these files.

The "Select Coordinate Reference System" dialog shown when querying the current CRS 
can also be used to update the CRS of the view, and to update the CRS of certain sources. 

01401647 Certain sources opened in the application ask for the user to specify the CRS of the 
source. If it is later determined that a different CRS should be selected for a given source, 
it is now possible to change the previously selected CRS by clicking on the ... browse 
button for the CRS in the Properties window for the source. This also updates an RXL file 
created by the application and will result in this CRS also being used for this source when 
it is opened in the future.

Note that the RXL file generated now contains more CRS information, but that it cannot be 
read by older applications. Newer and older applications use the same RXL files, so 
opening a source first in a newer application and generating an RXL file and then opening 
the source in an older application will replace the RXL file. Valid old style RXL files can still 
be used in this version.

The same is true for files such as raster surfaces that are gridded relative to a plane and 
the GRD files for Template Editor. More CRS information is stored, in a format that older 
applications cannot parse, so new files created in the application cannot be read by older 
versions. Valid files created in older applications can still be opened in this version. 
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More flexibility has been added for how organizations can control the coordinate reference 
systems (CRS) available in the application. Three CRS are always available - an 
unregistered engineering datum, a projected mercator CRS, and an unprojected WG84 
CRS. If a file database like a local copy of the EPSG database and/or a map definition file 
are referenced by environment variables, those CRS are also available. By default, both 
the EPSG.db and MapDef.dat files are installed and CRS from both are available in the 
application.

As part of this separation between standard CRS and CARIS definitions, duplicate entries 
in CARIS' custom CRS support files have been removed. In the majority of cases, those 
were exact duplicates of entries in the EPSG database, but in some cases there were 
some rounding differences so it is possible there could be some variation. Similarly, the 
ellipsoid semi-major axis values were made more precise to better match the definitions in 
EPSG, but the differences in transformations are expected to be less than a millimetre. 
Also, the mercator projection that had previously been used was mercator variant C. As 
mercator variants A and B are more common, they are now used instead. This improves 
the exchange of data with third parties, though again there might be some rounding 
differences compared to results in previous versions. The Google mercator implementation 
was simplified as a result of this work, and ME projections are internally converted to MR 
projections.

As more standard CRS definitions are being used, GeoTIFFs are now created with a more 
standard header. Specifically, GeoTIFFs were always written out with a 
GeographicTypeGeoKey reference before; now, GeoTIFFs with a projected CRS are 
written with a ProjectedCSTypeGeoKey.

Another instance of the simplification performed relates to Gauss Kruger, which had 
previously reported as a distinct projection entry, but which is a specific Transverse 
Mercator projection. Gauss Kruger projections can still be specified using the GK code, but 
will be handled internally as Transverse Mercator projections and reported as such. 
Similarly, Universal Transverse Mercator projections are specific Transverse Mercator 
projections and are now reported as Transverse Mercator projections. 

00803613 

01101572 

01201238

It is now possible to control the coordinate reference system (CRS) transformation method 
for a specified CRS. The boundcrs.dat support file allows binding a specified CRS to a 
corresponding transformation method, with an overall identifier for this pair. By default, the 
identifiers are mapdef codes provided in older applications and the transformations match 
what was done in the older applications. The transformation methods in the support file 
can be updated as appropriate, and the binding file stored in a network location referenced 
by all users in an organization.

In particular, allowing specifying the transformation methodology allows for the support of 
grid shift methodologies such as NTv2, NADCON and OSTN. Grid shift files are installed 
by default for NADCON, OSTN and RD NAP grid shifts. Additional grid shift files can be 
added through the Tools > Options > Files and Folders > Grid Shift Transformations 
environment variable.

As there can now be multiple identifiers for bound pairs for a given CRS, each with their 
own distinct transformation methods, the transformation method is now included when the 
CRS is displayed in the application. Also, when the CRS is defined in the mapdef.dat 
support file, its description is also used for the display of the CRS in the application.

To support specifying transformations, references to two ellipsoids BEGR and BEHH were 
added to the MapDef.dat support file as geographic CRS. 

Coordinate reference system entries were added to the datum.dat file for ellipsoids used 
particularly in the Philippines. 

To improve clarity, the terms 'projection' and 'coordinate system' have been replaced by 
'coordinate reference system' in a number of contexts in the application. 
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Coverages

Lineage information for any CSAR file is now available as a property in the properties 
window. This displays a dialog showing every operation that has been run to create the 
CSAR in its current form, including the parameters used. The information displayed is 
richer for processes run in BASE Editor 4.2.0 and later, but details of processes run with 
older software is displayed.

Note that the username and password part of URIs for coverages in a BDB Server 
database are never stored as part of the lineage information.

When the resolution of a raster is changed in the generalize process, the warp raster 
process is used internally, so warp raster appears in the lineage of generalized raster 
surfaces. 

01002590 The properties for CSAR rasters and point clouds have been updated significantly. One of 
the most important changes is that there is a single set of properties for a given band, for 
all views. As such, any setting affecting the visualization of the data is done once and is 
immediately applied when any open view is next drawn, or when new views are opened.

Note that the Layers window still controls whether specific bands are drawn, and while the 
Layers window has been updated to be essentially the same in 2D and 3D, the controls for 
actually drawing a given band are still specific to the type of view. This is done to limit 
unintentionally turning on large amounts of data in 3D.

Another change is that the properties have been reorganized to reduce nesting. This 
makes it easier to use narrower Properties windows, leaving more room in the layout for 
the visualization of the data.

The properties for bands also now include more general information about the bands, such 
as the type of data contained in the band. 
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As part of the reworked properties, the visualization options for coverages in both 2D and 
3D have been improved significantly. Bands in point cloud, rasters, and TIN layers have 
consistent colouring options. It is possible to setup the colouring both on a colour file and 
by draping an image on the coverage. This can be applied to the coverage as a collection 
of points, as a collection of digits, displayed as a surface (TINs or rasters), and/or as a 
wireframe (TINs) or cell boundaries (raster). It is possible to turn these various 
representations on or off as needed. The specified colouring is applied to all 
representations by default, but if one of the representations needs to be displayed 
prominently over any other representation, it is possible to apply an override colour.

Datasets courtesy of Kraken AquaPix® InSAS

For example, it is possible to display a raster surface, drape a raster image over the 
surface and use a rainbow colour file to display any parts of the raster surface not covered 
by the raster image. It is also possible to simultaneously display the raster surface cell 
boundaries in red and the nodes in black over top of surface representation.

The display of the various representations is done in the order of the properties. For 
example, a raster is first displayed as a surface, then as points, then as cell boundaries, 
then as digits. This ensures that any number of the options can be turned on at once and 
all can be displayed.

The CSAR properties for "Data Start Date" and "Data End Date" have been replaced by 
minimum and maximum time (temporal) extents. When importing data, times in the source 
data are used to populate these fields, which are then editable properties of the CSAR files

TINs now are displayed as separate sources in the Layers list.

Note that the TINs are no longer automatically closed when source of the original points is 
closed, but if the source of the original points is closed, the TINs cannot be modified in any 
way that requires access to the original points. For example, Reset TIN cannot be run on a 
TIN if the source of the original points is closed.

TINs can now be created for raster surfaces gridded relative to planes. 

Certain operations updated the progress bar very frequently, such as creating the TIN, 
updating the progress bar for every point that was processed. However, if there were 
millions of points, updating the progress bar for each point caused the operation to take 
more time than necessary. Now, the GUI progress bar is only updated every 0.25 seconds, 
or every 1% of progress that is made, whichever is more frequent. As a result, creating a 
TIN from many points now takes less time than before. 
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HCRF raster images are now displayed in the Layers window with a parent source as well 
as the child layer. This allows access to the extents and coordinate reference system 
general properties. 

The properties displayed for raster images have been updated. Properties for the parent 
source in the layers window have the general properties for the file, including where it was 
open from, its coordinate reference system, resolution and extents. Properties for the child 
layers are now different depending on the type of raster image. All image bands have a 
general description of the data, such as the data type and number of bits used to store the 
colour for each pixel. Other options, such as colour map, filtering, channels, and pixel 
normalization, are only available for raster images that can meaningfully apply the options. 

Coverage Tools

01002815 It is now possible to colour the elevation information in subset editor based on any of the 
bands or by source. This allows much more flexible presentation.

Note that the colouring based on a string type band is done based on an internal index 
value, not based on the text, so if two point clouds are open in subset editor, the first 
source in each of the point clouds will have the same index and will be coloured the same, 
even if they come from different sources.

00900794 Subset editor has been reworked to be built off a more modern 3D framework. The 
interface is now more similar to the 3D view, and the subset editor views share the same 
Tools > Options settings as the 3D view. Other settings for the display and behaviour of the 
editor are generally set through the Layers window, with properties of the Subset Editor, 
Edit Sources, and Reference Sources nodes. This includes a number of functional 
differences; it is recommended to read through the subset editor section of the reference 
guide.

01002815 Subset editor now loads data from all open point clouds within the slice. The layers window 
is now used to control which sources are displayed in the subset editor. 

01301218

01401545

01402310

Select by lasso has been enabled in the subset editor 3D and slice views. This allows for 
more control, for example, over which subset of soundings is to be rejected. 

Reference models can now be turned on as reference sources in subset editor.

Note that the transparency properties for reference models are not currently enabled in 3D 
or subset editor. 
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Raster functionality better works on more types of data. Contouring, interpolate entire 
dataset, profiles, and compute statistics are now available for any numeric band in any 
raster, where they had previously only been available for raster surfaces. Extract is now 
available for mosaics, and raster surfaces as before. Save As is now available for mosaics, 
as well as the previous raster types. Adding mosaics to databases is now also supported. 
These processes always create CSAR rasters; these outputs could be exported to other 
formats using the raster export processes. Delete is now available for mosaics, as well as 
the previous CSAR raster types. 

01500628 The vertical shift dialog has been updated to be based on a property grid. This allows 
multiplicity. In particular, it is now possible to select multiple input bands that will be shifted 
as well as multiple include bands that will be carried forward unshifted. 

When using the vertical shift process to shift a coverage by a raster surface, it is now 
possible to select to shift by a raster surface open from a BDB Server database. 

Interpolation by range and by pointing is now supported for raster surfaces gridded relative 
to planes. This can be accomplished by rotating the 2D view to see the raster surface face 
on by using the "Use Coordinate Reference System" function, so that the functions are 
enabled and work as expected. Note that in order to edit a raster surface, it is necessary 
that only one raster surface from a single CSAR file is open, otherwise there will be 
messages about not being able to lock the surface for editing. 

Interpolating raster surfaces from TINs has been made more efficient. This was 
accomplished by improving how TINs are processed as the data is read through, taking 
advantage of the last known position in the TIN to reduce the time necessary to locate the 
current point. In house testing has shown that linear interpolation of a very large dataset 
that took at least 4 hours 23 minutes to process in BE 4.1.x now takes as little as 2 hours 
17 minutes to process. This is slightly more than half the time it used to take. The actual 
performance improvement depends on the dataset, system specifications, and options 
selected in the dialog.

Running natural neighbour interpolation on the same dataset with the same parameters 
took over 7 hours in BE 4.1.x and less than 4.5 hours in BE 4.2.0. 
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Profiles of raster surfaces can only be created if the profile line is perpendicular to the 
plane of the raster surface. This limited what profiles could be created in previous versions, 
as profiles always had to be digitized in a top-down view, resulting in there only being 
limited possibility to create profile lines for raster surfaces representing vertical walls or 
inclined areas. These limitations are still present, but now that the view can be rotated to 
view raster surfaces face on, the profile lines can then be digitized in the plane of the raster 
surface, allowing any profile line to be digitized.

Note that the Profiles layer can only contain profile lines created relative to a single plane 
at once. Attempting to create profiles with respect to a different plane will display a warning 
message that the existing profile lines will be cleared. 

Profiles can now be created for TINs created from raster surfaces gridded to specified 
planes. 

01301126 There are now options in the warp process to perform interpolation based on the bicubic 
algorithm, or a bicubic algorithm that preserves internal holes. The option previously 
labelled as the bicubic algorithm had preserved internal holes. 

When joining point clouds, through BASE Editor or CARIS Batch, it is now possible to 
specify the output coordinate reference system (CRS), both the horizontal and vertical 
components. The vertical CRS component is just metadata and does not apply any vertical 
transformations. 

Export

It is now possible to export a raster to a CSAR using the Raster Product Export dialog. It is 
possible to choose whether to create a CSAR image or a CSAR raster surface. It is also 
now possible to export a raster to JPEG or PNG. In addition, raster surfaces can now be 
exported to STL format, a common interchange format for 3D printers.

The support files used for bMIO export have been updated to support bIENC production, 
as well as bENC production as before. The usage codes 7, 8, and 9 for rivers, river 
harbours and river berthings can now be used. As well, the S-57 dataset filename 
convention has been updated to no longer encode the usage, and to have a five character 
cell code. The first three characters are still the producer code followed by B to denote a 
bathymetric ENC, and the extension is still 000. 

Features

01502919 The contouring wizard now allows creating contour lines without creating boundary 
objects. Note that boundary objects are still important if you will smooth the contours and 
then create depth areas from the smoothed contours.

The new ContourRaster CARIS Batch process also optionally allows the creation of 
boundary objects, for both HOB and DXF output formats. 

Catalogue Editor is now deployed with BASE Editor. It can be used to update local 
catalogues as well as the catalogues of BDB Server databases. The catalogues are used 
for defining the objects and attributes available for a number of vector formats supported in 
BASE Editor, including HOB, S-57, and BDB Server.

The ability to connect to BDB Server databases and edit their catalogues is dependent on 
the BASE Manager module being enabled. 

The Save As button in Catalogue Editor now works as expected, and can be used to 
create a copy of the current catalogue open in the application (both the pool and profile, as 
applicable).
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00701027

01001263

01003354

01200941

01500035

Feature mapping now supports conversion between some geometries. Mappings currently 
supported are:

• Area to Point
• Area to Line (boundary)
• Area to Text
• Point to Text
• Sounding to Point
• Text to Point

Examples are included in ..\modules\Feature 
Editing\system\Rules\Examples\Geometry_Mapping_Examples.xml.

01001263 Feature mapping now supports the creation of features from a collection of edges. 
Currently supported are:

• Area from Edges
• Lines from Edges

Examples are included in ..\modules\Feature 
Editing\system\Rules\Examples\Features_from_Edges_Mapping_Examples.xml.

01003627 Feature mapping now supports the use of mathematical operators. Operators currently 
supported are:

• Add
• Subtract
• Multiply
• Divide

You can use either a fixed value or another attribute.

 Feature mapping has been extended to support complex attributes, attributes with 
multiplicity and conversion of S-57 specially formatted attributes like SIGSEQ.

Feature mapping now supports the use of OutputMessages. A free-text string may be 
included in any feature or attribute mapping. This could be used, for example, to draw the 
user’s attention to a feature requiring further editing.

The regular expression wildcard may now be included to match feature acronyms. This 
could be used to create global mappings or a 'default mapping' as the last mapping rule in 
the file.

Examples are included in ..\modules\Feature 
Editing\system\Rules\Examples\Wildcard_Mapping_Examples.xml.

01200941 Attribute text substitutions can now be made using the new feature mapping 
<ReplaceAttributeValue> function in combination with regular expressions.

01202945 A new feature mapping <SetSpatialAttributeValue> function has been added to set spatial 
attributes.

01200888 The feature mapping <UpdateObject> function can now update multiple point features at 
the same location.

A new feature mapping function, <AssignFOIDValueToAttribute>, has been added to allow 
copying of the feature object ID to an attribute for export to a third party format.

01300669 The Append tag may now be used with <CopyAttributeValue> when using 
<CreateCollectionFeature> or <CreateCollectionFeatureFromAttribute> in feature 
mapping.

The feature mapping <AssignCurrentDateToAttribute> function has been extended to add 
<AdjustByDay> to allow for a +/- adjustment to the setting.
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It is now possible to add a user-defined set of catalogues to the default list of catalogues by 
setting the Tools > Options > Files and Folders > Catalogue Control option. As a result, it is 
no longer necessary to have all of the system catalogues and user catalogues in a single 
file, which simplifies sharing catalogues between users and applications. Note that the 
application still ships with a catalogue control file containing a number of default 
catalogues, both ones based on standards and some CARIS-specific catalogues useful for 
opening data produced in various applications and modules, and that these are always 
available. 

01500487 Many parts of the user interface have been enhanced to support S-100, including the 
Attributes, Properties and Spatial Attributes windows. This includes added support for 
hierarchical attributes and multiplicity, which required significant changes to the underlying 
technology for the grid-based windows and dialogs. Note that includes some changes in 
behaviour. For example, the ellipsis button appears when hovering the cursor over the 
value field in the Attributes window. Also, attributes can be set to undefined or unknown by 
right-clicking the mouse button in the Attributes window and selecting either value from the 
pop-up menu.

A Seabed Survey Data Model (SSDM) catalogue is now deployed with the application, and 
feature layers can be created with this catalogue, allowing digitizing and editing these 
features. Currently, the portrayal is limited and the features have to be exported to a third 
party format like GML, but these issues will be addressed in future versions of the 
application.

The catalogue name is now displayed as a property of the parent source of feature layers 
in the Layers window. 

When selecting features based on attribute value, it used to be required that a value be 
entered - whitespace was not considered valid. Now, whitespace can be used as the 
entirety of the value, or as part of the value. In particular, this allows selecting features 
when the attribute value is blank.

Custom validation quality control tests now run significantly faster, which is especially 
noticeable on larger datasets.

Validation tests have enhanced support for messages. In particular, the "CRITICAL 
ERROR" message level is now supported, in order to meet the requirements of S-58 5.1. 
In addition, messages can now have "Description" text fields, in addition to the previous 
support for "Message" text fields. 

Standard validation tests shipped with the application can now be added to a toolbar. This 
simplifies running frequently used validation QC tests. This is done using View > Toolbars 
> Customize and finding the validation check in the Commands tab, under the All 
commands category. 
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Using the escape button to cancel the running set of validation tests used to end the 
process once the currently running test completed. However, certain individual tests, such 
as "Overlapping Areas" and "Customized QC Tests," could take a long time, so finishing 
the currently running test could still take a long time. Now, these longer tests also 
individually monitor the state for cancellation requests, so these tests can now be 
cancelled in the middle of a run. Validation tests are more responsive to cancellation 
requests as a result. 

01402532

Sample custom validation tests are now deployed with the application. These can be used 
directly, and/or they can be used as samples to generate additional validation tests. 
Specifically, there are now validation tests in ..\BASE Editor\4.2\modules\BASE 
Editor\support\Validation. These include depth area validation checks that determine 
whether all depth areas have both DRVAL1 and DRVAL2 set to different values, and 
validation checks that ensure that all soundings are within depth areas or dredged areas, 
and that all depth areas or dredged areas enclose at least one sounding.

The Validation check for Invalid Attributes now also checks for invalid dates for any feature 
of DATE type, such as NMDATE and RECDAT in the S-57 ENC profile. The expected 
format for date strings remains CCYYMMDD.

The Validation test for Invalid Attributes now checks the validity of spatial attributes, in 
addition to the feature attributes it used to check. 

The Prohibited Attributes validation check (Tools > Validation) has been removed. It is not 
required as the new CARIS catalogue model does not allow attributes that are not 
permitted for a feature or spatial object. 

When running the validation check for areas to merge, there is a new option to ignore 
dividing lines and overlapping areas. By default, these are not ignored, and the results are 
the same as in previous versions. However, if the end product is intended to be VPF, it is 
important to not merge these kinds of areas, as it would produce invalid topology in VPF 
datasets. 

The Edit > Change All command has been renamed Change Selection to better match 
what the functionality actually does. 

01402751 The Edit > Change Selection command can be used to set the attribute value of selected 
features to UNKNOWN.

01301717 Only values in a catalogue can be chosen for enumerated or list attributes when changing 
attribute values through the Edit > Change Selection command.

01202338

01500762

Several dialogs allow selecting multiple feature acronyms, such as the dialog to create a 
new layer based on one or more feature acronyms. Now, a scroll bar is displayed when 
many feature acronyms are entered. 

01202877 A scroll bar is displayed in the Object Import Utility dialog box when a large number of 
scripts are opened.

Format Support

Support for opening CAD files has been upgraded. A wide variety of DWG, DXF, and 
BDXF file formats are now supported, from version 2.5 to 2014. V7 and V8 DGN (including 
V8 XM and V8I) are also supported. 

S-100 files can now be opened as read-only backdrop files. That includes both the S-100 
ISO/IEC8211 format with the .000 extension, as well as S-100 GML with the .s100gml 
extension. 

The catalogue for INT1 charts is now shipped with the application. This means that HOB 
files created in Paper Chart Composer™ with this catalogue can now be opened 
successfully, with all of the objects and attributes correctly understood by the application. 
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The Laser-Scan Internal Feature Format (IFF) has been added as a format that can be 
opened directly. This was one of the earliest formats developed explicitly for storing digital 
map information, used to store digitized paper maps.

A single environment variable for the IFF configuration in Tools > Options points to default 
support files, but can be set to a network path containing other shared default settings. 

Import

Threading is now used to improve the performance when importing and processing points. 
In house testing has shown that gridding a collection of points can now take 50% less time 
in BE 4.2.0 than in BE 4.1.17. The threaded processing consistently resulted in improved 
performance, but the level of improvement varied significantly based on the datasets 
involved and the parameters used. 

CSAR raster surfaces can now be imported into new CSAR point clouds and raster 
surfaces. 

Miscellaneous

The modules dialog is now displayed the first time the application is started. This allows 
picking the licensed modules to be included in the interface, without requiring a restart. 

The selection of licensing has been removed from the installation. It is now requested in a 
new dialog shown on first run; this is a simplified Tools > Options dialog that shows only 
the mandatory options that have not yet been set. It remains possible to change the 
licensing selection later through the Tools > Options dialog. 

Every command run in the application is now logged in 
%appdata%\CARIS\<application>\<version>\Logs. This information is useful to CARIS 
Customer Services to help diagnose any issues that occur.
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Measurement tools have been updated to work more seamlessly across views. All views 
that involve snapping to 3D points share a single measurement tool, and adding points to 
any of those views affects all of them; that includes the 3D view and subset editor 3D and 
slice views. Similarly, all views that involve snapping to 2D locations share a single 
measurement tool; that includes the main display window and any new display windows. 
Switching between views no longer automatically cancels distance measurement, 
however clicking in a window that has a different kind of measurement will cancel any 
ongoing measurement and will start a new measurement; that includes switching between 
2D and 3D views and the profile window.

Note that as part of this work, the subset editor measurement tools have been updated to 
work the same as the 3D view measurement tools. 

The Overview command now applies to the active view, whether that is a 2D view or 3D 
view. If subset editor is turned on, and a 2D view or a subset editor view is active, the 
Overview command will cause the most recent 2D view and all subset editor views to be 
reset to the overview. 

The way that lengths and areas are displayed for selected features in the selection window 
has been updated. Now, when the measurement reference is set to geodetic, the 
coordinate reference system (CRS) of the view is always considered, specifically the 
ellipsoid. If the view is not georeferenced, N/A is displayed for areas, distances and 
angles. Areas are computed using a localized Albers equal area projection; lengths are 
computed using Vincenty's algorithm. When the measurement reference is set to 
planimetric, the coordinate reference system of the view is used if it is a projected or 
engineering CRS. If the CRS of the view is geographic, N/A is displayed for areas, 
distances and angles. 

Many geometry error messages now contain additional information about the geometries 
involved. For example, crossing breaklines at different elevations now gives the values of 
the two breaklines and the coordinate that they cross. This will improve the ability to 
diagnose issues that arise and to more quickly find solutions. 

It is now possible to change the order of the columns in the Selection window by dragging 
the column headers. 

All supported length units are now shown when choosing depth, height, or ground units in 
Tools > Options > Units. Previously, some filtering had been applied to limit the units.
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Units are now used with all available precision. Previously, rounding had been performed 
at a high degree of precision (tenth decimal place). Some variations in calculations could 
result from this change.

The Tools > Options dialog has been updated to be searchable. All of the options are now 
present in a single tree. The options that are displayed are the ones that are relevant for 
the modules that are enabled. 

The organization of the options, and the defaults, have also been changed. For example, 
the Object Catalogue setting is now blank by default, meaning that opening HOB files will 
always prompt for the catalogue to be used. This option can be set to a specific catalogue 
if all HOB files should be opened with the same catalogue. 

It is now possible to change the vertical coordinate reference system file through Tools > 
Options. This allows sharing the file between multiple users. 

It is now possible to use the tab key to access properties in a dialog or window containing 
a property list. 

Help topics, including F1 help, now display the documentation in the default browser of the 
system, in an HTML-based format. This results in context-specific F1 help being available 
throughout the application. 

The interpolation icons have been updated to a consistent style, similar to other icons. The 
interpolate entire dataset, interpolate by range and interpolate by pointing were all updated 
to have the same interpolation representation along the top. 

The default layout has been adjusted. The profile window and subset editor windows have 
been moved to make them more easily used without customization of the layout. 

Modularization

The application is now consistently referred to as BASE Editor. This affects folder 
structures such as the default installation path of C:\Program Files\CARIS\BASE 
Editor\4.2. It also affects the name of the main executable, which is now called 
CARIS_BASE_Editor.exe, in order to simplify finding the application using the search 
capabilities of newer operating systems like Windows 8.1. 
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A new, simpler Modules dialog has been added to replace the Licensed Components 
Manager. This dialog controls whether the user interface should be populated with the 
commands and windows for the module, and whether a licensed seat should be requested 
for this functionality. It remains necessary to restart the application after changing the 
modules, and the layout will be reset to ensure the new commands and windows can be 
placed in appropriate locations. The about box has also been restructured to list the active 
modules, each with their own version number.

BASE Editor is listed as a module in Modules dialog in the BASE Editor application. This is 
part of an ongoing restructuring to have a single CARIS application that can be used with 
whichever set of licensed modules that meets each user's needs. As more applications 
restructure their unique functionality into modules, there will be increased consistency and 
interoperability. Each module is now installed alongside the main application, each in their 
own folder, with their own unique binary files, support files, and environment variables. 
This has resulted in the virtual elimination of the use of the registry to store information. 
Information that used to be stored in the registry is stored mostly in environment.xml files, 
but certain items are elsewhere. For example, the source plugin GUIDs are no longer 
added to the registry, but to the system\SourcePlugins.xml support file. Another example is 
some local user information, such as recently used files, is now stored in 
%appdata%\CARIS\<application>\<version>\<application>.ini. 

As each module can have its own set of files, and the application's support files are the 
collection of all of the support files of the main application and all of its modules, the 
application now collects entries of various types from many locations.

For example, mapping files, used when importing selected objects to HOB features, or 
when changing selected HOB features, used to be deployed in a single folder. They are 
now deployed with the appropriate modules. The rule files are only made available in the 
application when the relevant module has been enabled. Note that additional rule files, 
which are not part of the standard installation, can also be used easily, now; a new 
environment variable has been added at Tools > Options > Files and Folders > Rules. 

Similar changes have been made for presentation control, catalogue control, custom 
validation, and product information files. 

The AML rule file aml10toaml21.xml is no longer shipped with BASE Editor as it is 
associated with an S-57 Composer module.

Reference Description
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A licensed feature editing module is now available, which contains the generic feature 
editing capability that was previously available in other CARIS applications. This requires a 
new license string; contact CARIS Customer Services for more information.

Using the feature editing module commands, it is possible to create new features based on 
existing features. Specifically, commands exist to:

• combine adjacent non-overlapping areas into a new area feature,
• create minimum bounding rectangle area features around a selection of features,
• buffer existing features to create new features,
• create a new area feature representing a corridor inside and/or outside an existing 

line or area,
• create lines parallel to existing lines, and
• create lines or areas representing a gridded overlay for an area.

It is also possible to define relationships between features, both grouping collections of 
related features together and defining a point feature as controlling other point features 
(master and slave(s)). It is also possible to select features based on these relationships.

A Utilities toolbar is now available as part of the feature editing module. The application 
comes with a utility that opens a command prompt with the system path setup to run 
command prompt tools, such as bathydbserverloader. Note that this utility adds all the 
paths needed for any of the enabled modules; for example, bathydbserverloader requires 
BASE Manager, so BASE Manager must be enabled before spawning a command prompt 
to run that tool. Additional user utilities are loaded from any files in a folder pointed to by an 
environment variable, making it easy to share common utilities to save the selection to 
various output formats or run various command prompt tools. 

Note that it is also possible to start a command prompt with the environment setup for the 
application through a new shortcut installed in the Windows Start Menu alongside the 
application shortcut. 

As part of the move to being more modular, a number of menu items have been moved, 
generally to group similar concepts more closely together.

The options to import data as new layers in the application have been grouped together 
under File > Import. That includes the existing import wizard and object import utility, as 
well as importing selecting objects and the new import as updates options.

The options to start editors have been collected under Tools > Editors. That includes 
existing editors such as the subset editor, ASCII info file editor, vertical reference system 
editor and template editor, as well as the new catalogue editor.

The options to export data from the application have been reorganized under File > Export. 
In particular, a new submenu for exporting the selection has been added.

The options to ungroup soundings have been moved to the Edit menu. 

Reference Description
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As part of the restructuring of menus to be more modular, a number of mnemonics have 
been adjusted to ensure uniqueness and to use the most appropriate characters available. 

Support File Updates

The vertical reference system support file spatialref.db has been updated to version 8.7 of 
the EPSG database, ensuring that the vertical reference system information is current. 
Clients who have customized earlier versions of the support file may want to continue 
using their customized versions. 

Support has been added for XSLT symbolization files used for S-101 features.

01200064 The PIPSOL (submarine/on land pipeline) feature is symbolized with the correct colour. 

The presentation control file (presentationcontrol.xml) now has an additional entry for the 
lookup table of text features in the INT1 presentation section.

<TextLookup File="%PCEConfig%\lookup\tsymrefs.dic" />

Filled borders for N1.2 Marine Limits in General and N2.1 Limit of Restricted Area can now 
be symbolized, when using an INT1 presentation.

01400805 A symbol for J14 sandwaves has been added to the system master file and presentation 
files.

01400040 NGA sounding rounding rules have been added.

The productinfo.xml file has been split into one file for each product. Individual product 
information files can be added or removed from the folder to easily manage the list of 
products available when exporting a selection to S-57 file.

New river codes have been added for waterways in the USA. White River (WH) was added 
for IENCs and IENC Overlays. Southwest Passage (SW) was added for IENC overlays.

The IENC 2.3 catalogue has been updated to version 2.3.6.

The IENC 2.4 catalogue is now deployed, adding support for both for S-57 IENC 2.4 and 
S-57 IENC Overlay 2.4. 

The Agencies.txt file that lists producer agency codes has been updated to match the 
International Hydrographic Organization's list. Two agencies have been added to the list - 
I7 and 7N, for the Indian Navy and Indian National Hydrographic Office. 

The catalogue control file now specifies the data type of the catalogue. Catalogues with an 
S-100 data type are not shown in the feature layer creation dialog. 

Reference Description



CARIS BASE Editor 4.2.0: Enhancements

48 CARIS BASE Editor 4.2 Changes List

BASE Manager

Reference Description

Miscellaneous

Upgrading to BDB Server 4.2 improves the performance of attribute queries and server 
combine, and results in other improvements. See the BDB Server 4.2 changes list for more 
information.

Connecting to a BDB Server database now displays a warning message when the RDBMS 
user is about to expire. This message appears in the last seven days before expiry, and 
indicates the number of days remaining before the user expires. If this message is 
displayed, a DBA should be asked to extend the validity of the user, if appropriate, or else 
the user will be locked out.

Note that this new behaviour requires BDB Server 4.2.0 or later.

When raster surfaces were added to a BDB Server database through BASE Manager, if 
the raster surface was not in CSAR format, the CSAR equivalent was added to the 
database and the original file was automatically attached to the surfac object. This resulted 
in all of that bathymetry data being added twice. Now, the bathymetry is only added once, 
as a CSAR file. If it is desired to attach the original dataset, it is possible to use the existing 
attachments functionality to add it.

Similarly, when raster surfaces were added to a BDB Server database through 
bathydbserverloader, if the raster surface was not in CSAR format, the CSAR equivalent 
was added to the database and the original file was automatically attached to the surfac 
object. This is now optional; the ao (attach original) flag can be added if the original file is 
to be attached to the CSAR in the RDBMS. By default, the original file is not added. 
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Engineering Analysis

Limits and Boundaries

Reference Description

Conformance

Contour by reference model used to always split contours along reference model surface 
boundaries. Now, if the adjacent reference model surfaces are at the same depth, the 
contours are no longer split along the boundary. 

Vertical and Inclined Surface Analysis

Comparative volumes can now be calculated for two TINs created from raster surfaces 
gridded relative to the same plane. This provides a summary for how vertical or inclined 
structures have changed between two surveys. The calculation results can be used, for 
example, as a measure of deformation that has occurred. 

When calculating comparative volumes, it had been necessary to select two TINs as well 
as a clipping model. If no clipping was desired, a value below all of the data had to be 
specified as an infinite plane. Now, a no clipping option is available in the dialog. This 
serves the same purpose as specifying a value below all the data, but no longer requires 
entering such a value explicitly.

When calculating comparative volumes, the second list of TINs is automatically updated to 
remove any TINs that cannot be selected once the first TIN is selected. This ensures that 
the TINs are gridded relative to the same plane, and also prevents the unintentional 
selection of the same TIN twice.

Triangular volumes can now be calculated for a TIN created from a raster surface gridded 
relative to a plane. The calculation can be done relative to the plane, or, if there is a need 
to ignore data close to the plane, the calculation can be done relative to an offset from the 
plane. The calculation results can be used to determine the size of a deformation or other 
feature along a structure. 

Reference Description

Miscellaneous

It is now possible to choose the file used to map HOB features to CARIS file objects. It is 
set to the same default file as used in previous versions of the application, but the Export 
to CARIS Conversion Table option in Tools > Options can be set to customized files as 
needed. There is, for example, a file that could be used with the Limits and Boundaries 
module™ that is installed in \modules\Limits and Boundaries\support\carisconfig\LBM.dat 
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Maintenance

BASE Editor

Reference Description

2D Display

You can now snap to objects in GML backdrops when digitizing new features.

The third party libraries for GDAL and ECW have been updated, resulting in improvements 
in our underlying support for 16-bit channel images. Some other fixes in the libraries have 
also been picked up, including corrections and additions to the list of coordinate systems 
and datums used by GDAL.

01502171 Certain JPG2000 files were displayed in black and white instead of in colour. This was 
caused by metadata not being set for the RGB bands, and the existing third party drivers 
not supporting this case. The new ECW driver fixes this, and the JPG2000 files display in 
colour as expected. 

01301229

01401125

Saving a session when the view had a CHMR coordinate system would not save all of the 
alignment information necessary to correctly georeference the data when the session was 
reopened. Now, the alignment information is saved in new sessions files and the data is 
correctly georeferenced when the session is opened again. 

References to unsaved feature layers are no longer saved when sessions are saved. To 
include the feature layer in a session, the feature layer must be saved to disk before the 
session is saved. 

If there were any unicode characters in the coordinate system description of a source in a 
session file, the session file could not be opened again. This was seen with a specific 
GeoTIFF, but could have been relevant for other sources. This unnecessary detail is no 
longer stored in new session files so this is no longer an issue, and sessions can be used 
to reopen these sources. 

Modified display properties of an open GML file were saved in a session file, but were not 
applied when the session file was reopened. Now, the display properties are applied as 
expected. 

The Overview window has been removed from the application. It remains possible to open 
multiple views in a single application, one of which can be set to an overview of the data, 
as desired. 

Displaying the geographic grid in an area might only display in a portion of the display 
window, depending on the extent of the view and the coordinate reference system (CRS) 
of the view. Now, if the geographic grid is set as visible, it is displayed for all extents.

Note that CRS transformations only work as expected for the area of use of the CRS, 
where the flattening applied for the projection is valid, and that attempting to transform 
lines outside the area of use may result in unexpected artifacts. 

3D Display

 The third party library used for the 3D view has been updated, resulting in significant 
change to the underlying code, such that it will be easier to add in new functionality. This 
has resulted in the minimum system requirements for the display to be updated to OpenGL 
3.0.
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Vector lines drawn in the 3D view were drawn with an offset from the terrain, where this 
offset was calculated based on the extents of data being displayed in the 3D view. As we 
now support drawing 3D lines as 3D lines, applying this offset was no longer appropriate. It 
remains possible to apply an offset through the properties window.

Simplified representation of vector lines could be drawn in the 3D view, even when 
zooming in on the lines. Now, the full detail of the vector lines is now available in the 3D 
view.

As part of the consolidation of the 2D views, 3D view, and subset editor views, the 3D 
scene window has been removed. The draw order window remains for both 2D and 3D 
views, and shows the layers being drawn in the active view.

Batch Tools

CARIS Batch processes now set the ERRORLEVEL environment variable on exit. A value 
of 0 indicates that the process ended successfully, and any other value indicates that an 
error occurred. 

The BathyBatchImport tool has been removed. The existing functionality in CARIS Batch is 
more complete than what was previously available in the legacy BathyBatchImport tool. 

The ability to import many input files each to their own separate CSAR file has been 
removed. This can still be accomplished by writing a script that calls CARIS Batch once for 
each file. 

The Python bindings used to use carisbatch_env.xml to find the environment, which had a 
reference to the registry. Now, the necessary environment is duplicated in 
.\system\environment_python.xml. It may be necessary to manually edit this file to use 
customized environment settings, even if the environment for the application has already 
been customized in Tools > Options.

By default, the environment for the Python bindings is set to use network licensing. If the 
system is setup for local licensing, this is something that will need to be manually adjusted. 

When multiple BDB Server conditions were added in a single query, the Python bindings 
would only actually perform the last specified query. Now, all of the conditions are 
considered together, as expected. 

The --view3d option is no longer available to automatically display data in the 3D view. 
Sources can still be opened in a new instance of the application through the command line 
by listing them after the executable name, for example "caris_base_editor d:\sample.csar 
d:\sample.hob" 

Coverages

When drawing a coverage as digits, the values used to be displayed in the Z-axis "up is 
positive" convention. Now, the digits for coverage values respect the Z-axis convention.

Designated soundings are sounding features, so they always display using the Z-axis 
"down is positive" convention. 

Rasters contain values that represent areas of no data. Certain raster surfaces, in 
particular some GeoTIFFs, had no data values that were not actually within the expected 
range of values for the band. In these cases, the no data value was interpreted as being 0, 
so any real data at a depth of 0 was treated as a hole in the raster. Now, the no data value 
is interpreted correctly even when it is outside the expected range of values for the band, 
and the data at 0 is displayed as data at 0 and not as holes. 

Using Select All on a CSAR raster surface with a lot of no data values completes more 
quickly now than in previous versions. 

Reference Description
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The format of the coordinate reference system (CRS) stored for CSAR files was updated. 
This was done in a backwards compatible way, such that new CSAR files can be opened 
in older software. One benefit of this is that vertical CRS metadata is now stored for all new 
CSAR files, whereas it was only stored before for CRS that had Proj4 or WKT definitions.

Note: as mentioned elsewhere in the changes list, CSAR raster surfaces gridded relative 
to planes now store the plane information differently, as part of the CRS, and these specific 
CSAR files cannot be opened in older applications. 

The unused vertical coordinate system property is no longer shown for raster images.

Connecting to a WMS could fail with a message about invalid dataset dimensions if the 
resolution was very fine compared to the extents of the data. Now, the resolution is 
increased to be coarser if too many cells would result, and the WMS connections now 
succeed. 

01502338

01600545

Certain coverages could not be drawn, depending on the coordinate reference system 
(CRS) of the view. This was known to affect certain WMS and WMTS web services that 
returned data in the Google mercator CRS; there were issues with how coordinates were 
transformed from that CRS to other CRS. With the updates to CRS transformations and 
mercator CRS in particular, this is no longer an issue.

When processing WMS URIs, hyphens were always properly encoded as %2D. However, 
certain WMS servers did not decode the hyphen, so no WMS data could be retrieved from 
those servers. As WMS does not require encoding hyphens, they are no longer encoded, 
and the affected servers can now be used. 

01600127 It was possible to set a flag to show rejected points in point clouds in two locations - in 
Tools > Options and on each individual dataset. It the Tools > Options flag was explicitly 
set, then datasets would automatically pick up that setting when they were opened. If the 
Tools > Options flag had never been set, it would show as "False", do not show rejected 
points, but point clouds that were opened would default to "True", show rejected points. 
Now, the point clouds are opened with the current setting of Tools > Options, regardless 
whether it is the default value or has explicitly been set. 

01501865 BASE Editor 4.1.x could not open point clouds that contained computed bands that were 
created in BE 4.0.x or earlier. This was caused by a change to how the band name was 
stored. Now, band names in either format are supported in newer applications.

Older applications still cannot open newer point clouds that store the band name in the 
new format. 

Grouped raster surfaces could not be ungrouped after any process that added bands was 
run on any of the grouped raster surfaces. Now, the grouped surfaces can be ungrouped 
as expected. 

Changing the coordinate display properties used to only affect the Selection window for 
future selections of CSAR nodes. This included changing the coordinate type, precision, 
unit, and z-axis convention. Now, the coordinates currently being displayed in the 
Selection window for selected CSAR nodes are also changed immediately. This brings the 
behaviour for CSAR nodes in line with existing behaviour for HOB and S-57 selections. 

Coverage Tools

01200481 In subset editor, changing how the points were coloured would cause rejected soundings 
to be displayed in the views, even if a flag had been set to hide all rejected soundings. 
Changing how points are coloured no longer changes which points are shown; rejected 
points stay hidden, when appropriate. 

01103128 Subset Editor now remembers settings from the previous time it was used, such as 
whether rejected soundings are displayed. 

Reference Description
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01500354 Interpolating a raster surface from a TIN could result in single node holes, particularly if the 
TIN was created from dense single beam readings from widely separated survey lines. 
This was caused by the TIN incorrectly believing a location in one of the skinny triangles 
was actually outside the TIN, in certain unusual geometric configurations. The way that 
removed or cut edges are internally stored in TINs has been updated. Now, interpolating 
the raster surface from these TINs produces a complete raster surface with no internal 
holes, as expected. 

Natural neighbour interpolation used to produce incorrect results along the boundary of the 
TIN, in some cases, based on the orientation of the triangles along the boundary. This has 
been fixed. 

01501525 The vertical shift process was not respecting the unit of the single shift value. Now, the unit 
is required to be specified explicitly, and it is respected. 

Copying selected points in a point cloud, or joining existing point clouds, now always 
creates a new point cloud. This helps ensure traceability for the points in a point cloud.

Index bands are no longer shown in the Export Surface to ASCII and Compute Layer 
dialogs. Index bands are internal bands used to efficiently process point clouds, and are 
not expected to be exported or used in processing. 

Support for the range-based deconflictions rules for the combine processes has been 
removed. 

Processes that modify an existing CSAR now clear the selection at the end of the 
operation. Note that this prevents the selection becoming invalid - for example, if Remove 
Layer is run, the removed layer should no longer be a field in the selection window. 

01502650 The process to compute statistics for a coverage used to only consider up to two decimal 
places of precision. If a smaller value was entered, the value could be misinterpreted as 
zero, and the application would run indefinitely. Now, values as low as 0.001 are accepted, 
and a message is displayed if a smaller value is provided. 

Export

The format of raster product templates has changed, so templates produced in previous 
versions (BE 4.1.x, HIPS1 9.0.x, HIPS 9.1.x) cannot be used in newer software.

01502716 BAG files were previously created with some compression even when the compression 
level was set to 0. Now, a compression level of 0 represents no compression. The default 
compression level for BAG export has been set to 1, to be more similar to the default in 
previous versions. Note that using no compression may produce very large BAG files.

Exporting raster surfaces to BAG could produce incorrect BAG files if compression was 
turned on and the width of a dataset was greater than its height. This has been fixed. 

01501312 When exporting a raster surface to point cloud, and changing the coordinate reference 
system, the minimum/maximum values for elevation bands could become unrealistically 
large. The minimum/maximum values are now calculated as expected when the data is 
transformed on export to point cloud. 

01501100 Certain raster surfaces could not be exported to BAG. This happened when the unit of the 
data had spaces in the name, such as US survey feet; spaces are not accepted in this 
BAG metadata field. Now, when exporting the metadata - for BAG or ISO19115 metadata - 
the unit key is used instead of the full name, and the export completes successfully. 

 Exporting selected features to GML did not produce a valid GML file if any of the feature 
acronyms contained a $ character, as that is not a valid character to have directly in an 
XML file. Now, $ characters are replaced by "Cartographic_" in the exported XML. Spaces 
are similarly replaced with underscores.

Reference Description
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When exporting selected features to a CARIS map, messages could be displayed about 
m_prop, cs_oflg, cs_dsrc and objinf objects. There were internal objects with no visible 
impact, and the messages have been removed.

When exporting selected features to a CARIS map, arc edges are now densified and 
exported as a series of linear edges. This is similar to how loxodrome and geodesic edges 
are exported. The densification for all of these cases is now handled consistently, which 
may result in some changes to the exact points created in some cases.

01500925 Exporting the view as a GeoTIFF could fail with a message about an unsupported 
projection if the coordinate reference system (CRS) was a ME type with a non-zero 
reference latitude. The CRS changes, including the switch to using more common 
mercator projections and the switch to encoding the projection in the GeoTIFF header, 
resolve this issue. The view can now be exported to GeoTIFF successfully in those cases. 

Exporting the view to a geospatial PDF would fail if the coordinate reference system of the 
view was an engineering datum. Now, attempting to export the view as a geospatial PDF 
will create an unreferenced PDF in this case. 

Features

Contouring is now done using a floating point resolution, and contour lines are only 
transformed to the output map resolution at the end of the process. Previously, contouring 
had been done at a resolution similar to the output map's resolution and then transformed 
to the output map resolution at the end of the process. The calculation of the resolution 
similar to the output map's resolution was dependent on the exact extents of the coverage, 
such that contouring would produce slightly different results on subsets of the data as it did 
on an entire dataset. Now, the result is that contour point locations are slightly different 
than ones produced by previous versions of the software, but contouring subsets of the 
data in new software will be consistent with contouring the whole dataset. 

The contouring code has been updated to consistently produce the same contour splits. 
Contouring is a threaded process, and it is possible that certain parts of any given contour 
line are created in different threads. Closed contours were always created exactly the 
same, and open contours were always created with the same underlying geometry. 
However, for any given open contour, depending on the threaded processing, the result 
could be a single open contour, or it could be two connected open contours with the split 
happening at various locations in the open contour. Now, the same open contours will be 
created each time the same dataset is used with the same parameters. 

When mapping attributes in the Create Source Areas command, it was only possible to 
map to string-based attributes. Now, it is possible to map to other fields, such as number-
based lists.

It was not possible to map attributes in the Create Source Areas command for combined 
surfaces in older software that did not internally store the contributor string format. Now, a 
sample data point is used to determine the number of fields in the contributor, which can 
then be mapped to output fields.

Attributes specified in the Feature Palette for new features were not set on new features 
that were digitized through the Feature Palette tools. Now, the attributes are set as 
expected. 

When adding a point or sounding to a feature layer, if the view coordinate reference 
system (CRS) is geographic, it is no longer possible to attempt to enter ground coordinates 
for the x and y coordinates. This is because no cartographic ground CRS is available in 
this context. Geographic coordinates can still be entered. 

Editing the geometry of a feature and then moving the feature would result in error 
messages if the attributes were then updated before the file was saved. Now, attributes 
can be updated even after geometries are edited and moved. 

Reference Description
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Moving a sounding spatially could affect nearby lines if the sounding was at the same 
location as one of the nodes of the line, and Edit > All Features was enabled. Now, moving 
the sounding does not affect the line if the line is a clockwise arc, loxodrome, geodesic, or 
a point to point line. 

01103320 Running extract features on a feature layer containing unsaved changes would work on 
the last saved state, not the current state in memory. For example, if extract features was 
used to cut features based on a polygon, and then extract features was used again, it 
would not use the cut features. Now, the current state of the feature layer is used, whether 
or not it has been saved. 

01400731 The Class Type Filter list in the Select Object Acronym dialog box is now available when 
the Create > Copy Feature > Geometry command is selected.

Adding inner rings would fail with an error message if any of the rings was already a hole in 
the superselected polygon. Now, the operation completes with the other rings, and the 
rings that could not be added are reported in the output window. 

Duplicate point references in lines and area objects are now removed when opening HOB 
or 000 files. Certain export operations would previously fail when operating on lines with 
two consecutive references to the same point. 

01500907 Starting the validation process could give an error message about a folder not existing, 
referencing the uslXqcrulefile environment variable. This is no longer an issue because of 
the changes to be module-based, where each module can have its own validation folders, 
in addition to a Tools > Options setting, to add a reference to a folder containing user 
custom validation tests. 

 The Redundant Edges, Points and Soundings validation check no longer produces invalid 
geometries when the Repair or Repair All hyperlinks are clicked in the Validation window.

Validation tests would not consider composite features, such as sounding groups, when 
running a custom test using the GeometryIsCoveredBy filter. Composite features are now 
reported as expected. 

Running Validation Checks on an object or attribute that does not exist in the profile would 
cause a pop-up message box to appear. This message box has been removed. Profile 
warnings are now displayed directly in the Validation window. 

01302704 The S-58 Depth Areas and Depth Contours validation checks now include AML CLB scale 
bands.

Tools > Validation > Invalid Attributes now checks multiplicity of attributes.

When using the validation tool, edges could often be reported twice, once when processed 
clockwise and once counter-clockwise. Now, the edges are only reported once. As a 
result, the redundant edge test with an ID of 20405 has been removed as it tested the 
same edges as 20404. 

When using import selected objects to copy features in a collection to a different layer, if 
any features contained attributes that were unsupported in the catalogue of the new layer, 
the lost attributes were not always reported. The lost attributes were not reported if the 
"Clip to dataset boundary" option was selected, and they were reported otherwise. Now, 
when attributes cannot be carried over to the new layer, they are reported in the output 
window regardless of the "Clip to dataset boundary" option. 

01103364 In some specific cases, using the <UpdateObject> functionality during mapping could 
result in extra attribute information getting applied. This is fixed.

01402145 Attributes with NULL values in Shapefiles no longer cause the Object Import Utility to fail. 

01101533 Attributes with Unicode text can now be correctly imported using the Object Import Utility. 

Reference Description
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 The Object Import Utility could confuse IENC features and attributes that have both upper 
and lower case versions (e.g. boylat & BOYLAT). This is fixed.

Specified separators in the object import utility would be replaced with the default 
separator if the Back button was used to return to step 2, the page where the delimiter is 
specified. Now, the specified separator is kept when browsing back and forward in the 
wizard. 

Exporting features to the SHP file format would only create a matching DBF file if the 
features contained attributes. Now, the DBF file is created regardless of the presence of 
attributes. 

IENC dismar features using a wtwdis attribute value were displaying the wrong value. This 
has been corrected. 

When processing large numbers of features that did not match a specified criteria, the 
application could run out of memory. This could happen when opening a HOB file 
containing many features and selecting a catalogue that did not contain the feature 
acronyms, or when creating unique feature acronyms. This was more likely to be a 
problem with 32-bit software than 64-bit software. Now, less memory is used to process 
each feature, so these memory issues are less likely.

When editing a SORIND attribute, upper-case character formatting was not preserved. 
This is fixed. 

01103251

01402145

Changing the formatted date of an attribute such as SURSTA or SORDAT could cause the 
application to display numerous error messages. This happened when the day of the 
month was valid for the original month but was not valid for the new month, for example, if 
the initial date was January 31, changing the month to February would cause the error 
messages to be displayed. Now, the message is displayed only once and then the invalid 
date is cleared, allowing the correct date to be entered. 

Information in the Attributes window will remain visible after a feature is added when in 
repeat mode. 

After digitizing using the Repeat New Features function on an unsaved feature layer, after 
the feature layer is saved and closed the application could close when the next selection 
was made. Now, the digitize mode is turned off when the feature layer is saved, and the 
application works as expected and the selection can be performed. 

Changing the spatial attributes, such as QUAPOS and POSACC, for an object no longer 
requires activating Edit Feature mode.

Creating a new feature layer when the view was in an unregistered coordinate reference 
system (CRS) would cause the application to close. Feature layers can now be created 
regardless of the CRS of the view. 

Format Support

When the Y-values were in increasing order in a gridded XYZ ascii file, and this file was 
opened directly as a raster surface using the GDAL library, the elevations were not 
displayed correctly. Specifically, the Z values of the cells were flipped; the Z value for the 
lower left corner was displayed in the upper left corner and vice versa. This has been 
corrected, and gridded XYZ ascii files are now displayed correctly, regardless of whether 
the Y-values are in ascending or descending order, in accordance with the GDAL XYZ 
format specification. 

01500435

01501923

Applying an update to an ENC while opening the file could cause the file open to fail if the 
update removed all spatial attributes from a feature. As part of the restructuring of handling 
of attributes, this situation is now handled properly and the ENC can be opened with all of 
its updates applied. 
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01502729 ECW files with an umlaut (ü) in the filename were displayed as completely black. Now, 
these ECWs are displayed correctly. 

S-57 feature records with multiple feature to spatial entries are now supported. 

Unicode text for attributes in Shapefiles opened as backdrops are now properly displayed.

Certain formats, such as DGN, support lines containing only one point, or areas that 
collapsed to a single point or line, and similar degenerate geometries. Attempting to select 
these geometries resulted in error messages being displayed saying that there were too 
few points to create a geometry. Now, the selection can be done successfully even in 
areas with degenerate geometries. Information about degenerate geometries is displayed 
in the output window. 

Certain GML layers were not displayed in previous versions of the application. This 
happened if any of the properties in the layer were of type BOOLEAN, SHORT, or FLOAT. 
Now, layers with properties with these types are now supported. 

Certain GML files could not be opened. This happened when the types in the automatically 
generated catalogue for the GML data did not match the data. This catalogue is no longer 
used as the data is handled more natively now, and the GML files can be opened 
successfully.

Thai text can be displayed in a CARIS file when it is opened. 

Viewing two BSB KAP files with different coordinate reference systems (CRS), with the 
view set to use the CRS of a more localized KAP file, could result in the application not 
allowing zooming in, and error messages being displayed in the output window. Now, the 
transformation between custom BSB CRS is improved, and the data is drawn as expected 
even at finer scales. 

01500967 When opening HCRF charts, a warning could be shown about the format of the NtM date. 
This is fixed. 

Certain GeoTIFFs were displayed upside down in the Display window. This happened 
when the GeoTIFF was saved with its bottom-most data written to the file first. Now, 
GeoTIFFs are displayed correctly whether they are saved bottom-up or top-down. 

The copyright message when opening BSB files has been removed as we no longer use 
the Maptech library to open BSBs. 

Some older CARIS formats are no longer supported in the application, specifically CARIS 
HCS and CARIS Hips Weighted Grid (.def files).

Error messages related to unsupported HOB file versions have been changed to account 
for very old HOB files or HOB file versions newer than the current software. 

Opening a VPF product would fail if no objects were found. This happened when features 
were present in the data, but not referenced in the features index tables. Now, these 
features are loaded.

Empty DXF files can now be opened in the application. 

Import

Support for PFM as an import format has been removed. This is part of preparation to 
upgrade the third party support for PFM, with the intention of supporting it as a format that 
we open natively in an upcoming version. 

01501859

01501710

The ASCII info file editor dialog only accepted two decimal places of precision. That limited 
the accuracy of importing data. Now, up to seven decimal places of precision are 
accepted. 
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Importing a delimited ASCII file to CSAR could fail if there were multiple consecutive 
delimiters, for example "x,y,z,,secondAttribute" where the firstAttribute was empty. Now, 
consecutive delimiters are processed as expected. 

When importing data from ASCII files to CSAR, it is no longer possible to use the old style 
of format information files that were typically created by hand based on a sample. The 
version 2.1 files, typically created through the ASCII Info File Editor in BE 4.1 or later, are 
still supported. This allows schema validation to ensure the files are valid, and also 
ensures that the z-axis direction of the data is explicitly defined.

Miscellaneous

The print button has for the EULA been removed from the installation wizard. The EULA 
remains available at www.caris.com/eula, as well as in the installation directory, e.g. 
C:\Program Files\CARIS\BASE Editor\4.2\caris_eula.rtf 

In previous versions, if the geometry of a single feature contained multiple areas, and this 
geometry was transformed to a different coordinate resolution system such that any one of 
the areas collapsed to a point, the geometry of the feature was considered invalid and an 
error message was displayed. Now, the geometry of the feature remains valid, and is 
made up of all of the remaining areas that did not collapse to points. 

Measurement tool calculations for Z-values and vertical angles were incorrect when the 
view was unprojected. This was caused by some assumptions about the horizontal and 
vertical axes having the same units. Now, an approximate scaling factor is applied to the 
calculations to give more accurate Z-values and vertical angles. 

Layouts involving multiple open windows in the application will no longer result in slowed 
response times for certain processes that write out text to the output window, such as 
some spatial editing and validation.

Selecting the New Publication command could cause the application to close if the 3D 
view was active. Now, the New Publication command is disabled in this case. 

When using a source plugin to open data in an application, the datum information now has 
to be encoded as an identifier (e.g. such as an EPSG code, EPSG:6326) instead of the 
ellipsoid name stored in the support file (e.g. WG84).

Select by Circle now creates a more circular selection area when the circle is small than it 
did with previous releases. 

The HCRF entries have been removed from the datummapping.xml support file. Now, the 
application always uses the shift values that are in the HCRF panel header file. 

Catalogue Editor now saves catalogues with the catalogue version of 1.0, not 1.1. The 1.1 
format was only intended for VPF, and newer software such as BDB Server 4.2 can only 
read 1.0 format catalogues. 

Help content has been added for Catalogue Editor. 

 The makecarhob utility now displays information about what support files were used. This 
helps to identify the cause of any issues experienced when exporting to CARIS file.

The makecarhob utility has been updated to consider the area surrounding point features 
when it creates files that support this information. As BASE Editor only uses this tool to 
create CARIS DES files, no functional difference is expected.

The internal structuring and handling of attributes was changed throughout in order to 
support a new, powerful, consistent presentation style for attributes in the application.

The internal structure for selection was changed to simplify processing selections.

The option to enable windows automatically by layer type has been removed. 
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Support File Updates

If the coordinate reference system (CRS) support file mapdef.dat includes references to a 
datum not contained in datum.dat, and the application parses this entry, an informative 
error message is now displayed.

This happens, for example, when searching for a CRS in the new searchable dialog, and 
the customized mapdef.dat files contains entries that reference the RDNP datum entry. 
That CRS is still supported, but is handled through the EPSG CRS definitions and not the 
CARIS-specific CRS support files. It is recommended to remove unnecessary CRS from 
mapdef.dat, leaving mainly the customized entries, and have the CRS picked up from the 
EPSG definitions in epsg.db. Alternatively, the RDNP datum entry can be manually added 
to a locally customized datum.dat support file. 

A Recommended Track (RECTRC) line is now displayed correctly over a Navigation Line 
(NAVLNE) if it shares the same geometry as the line, when using the INT1 presentation.

A straight territorial sea baseline (STSLNE) that is digitized as a point-to-point line is now 
symbolized with small circles at positions where the line changes direction, when using the 
INT1 presentation.

The DNC Approach Library catalogue has been corrected to remove the extraneous NAM 
attribute from GB005 point features and BB190 line features.

DATSTA and DATEND attributes have been added to PONTON features in the S-57 ENC 
profile.

The VERACC (vertical accuracy) attribute has been removed from the BOYINB (Buoy, 
installation) feature in the S-57 ENC profile.

01502197 The SCAMAX (scale maximum) attribute has been removed from the ARCSLN 
(archipelagic sea lane), ASLXIS (archipelagic sea lane axis), and NEWOBJ (new object) 
features in the S-57 ENC profile.

The CATCBL (category of cable) attribute in the S-57 ENC profile contains values of 
1,3,4,5,6. The value 2 has been removed for CBLOHD (overhead cable) and CBLSUB 
(submerged cable) features.

The CATPRA (category of production area) attribute values 1-10 are removed for the 
PRDARE (production/storage area) feature in the S-57 ENC profile.

The ENC 3.1 catalogue has been updated to support obstructions (OBSTRN) and wrecks 
(WRECKS) as structural objects. Where master/slave relationships are supported, these 
feature types can now be masters for DAYMAR, FOGSIG, LIGHTS, RADSTA, RDOSTA, 
RETRFL, RTPBCN, SISTAT, SISTAW, and TOPMAR objects. 

The VMap VPF profile was updated. The PRO attribute has been added to the AB000 
object.

VPF support files have been updated to version 1.0, resulting in a number of structural 
differences from the previously released versions. No functional difference is expected 
from these changes.

A number of corrections to the DNC VPF catalogues were also made to match the 
specifications.

The geometry type of VPF feature types is now included in feature acronyms. No 
functional difference is expected, but the acronyms associated with some features have 
been changed.

The UNSARE object has been removed from the IENC 2.3 profile.
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Breakwater symbol codes (AWBWLB and AWBWLBSM) have been added to the (ih) 
master and symbol files. This means that breakwater symbols can be accessed again from 
$SCODE attribute for a point feature. 

The Import Selected Objects dialog may not have reported the correct number of objects 
imported if the "Clip to dataset boundary" option was selected. Items outside the boundary 
were not imported, but were counted in the number reported as having been imported. 
Now, the correct number of objects imported is reported. 

 For the purposes of rule files, the type of a GML file is no longer "GML" but "CATALOG". 
The sample rule file GMLToENC3_1.xml has been updated with this change.

 A schema catalogue is now installed to manage the XML schemas used by the application. 
It is not expected to be modified by users.

If no entries were present in the outputtransform.xml support file, the XML schema 
validation used to treat that as an error. A new version 1.1 of the cgt.xsd schema is now 
installed, and empty outputtransform.xml files are now considered valid.

 A schema is now installed for validating masking rules, cmr.xsd.

Schemas used for CSW support are now installed, specifically under the 20120814, cem 
and dsc folders. They include support to supplement ISO code lists as well as a CARIS 
extended metadata schema.

HCRF schemas are now installed.

1.This term is a trademark of CARIS (Universal Systems Ltd.), Reg. USPTO.
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BASE Manager

Reference Description

Miscellaneous

Upgrading to BDB Server 4.2 resolves some maintenance issues, such as that it is now 
possible to add certain georeferenced raster images with no elevation information, such as 
HIPS mosaics, to the BDB Server. See the BDB Server 4.2 changes list for more 
information.

01403007 The performance of loading coverages into a BDB Server database has been significantly 
improved, for coverages that had string tables with many entries. This was observed in 
cases where time information was imported as strings, instead of the preferred format of 
natively storing time information in a time attribute. 

The performance of extracting raster surfaces from a database, using the Database > 
Extraction function, has been dramatically improved. The process was reworked to take 
advantage of the same data copying technology that was applied to the Tools > Surfaces > 
Extract function in BE 4.1.8. Based on in house testing, an extraction that took more than 
an hour to run in BE 4.1.x now takes less than ten seconds to complete. Exact 
performance depends on the system, dataset and parameters used. 

01502059 A specific TIFF that had data that crossed the dateline could not be drawn if the view was 
displaying data using the custom unprojected coordinate reference system (CRS) of a 
BDB Server database, but could be displayed with the standard WGS 84 CRS. Now, BDB 
Server databases have a standard WGS 84 CRS (EPSG:4326) and the TIFF draws as 
expected when the view is displaying data in the CRS of the BDB Server database. 

Using the command to select all features in the display could cause the application to 
close if the view was showing the initial display cover of a database and there were no 
features available to be selected. This could happen when the selected query layer had no 
features, or when the parent database node was selected. Now, the application works as 
expected and no features are selected in these cases. 

Properties of a CSAR were not being displayed properly if it was edited after the coverage 
content was uploaded to a BDB Server 4.2 database using the Replace Bathymetry 
command. This was caused by an old version of the coverage information being displayed 
in the properties. Now, the current coverage information is shown in the properties as 
expected. 
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Engineering Analysis

Reference Description

Conformance

Contour by reference model could fail with a side location conflict. This was more likely to 
happen with DNC output feature layers. This was found to happen when there was a very 
complicated skinny reference model surface adjacent to another reference model surface. 
The change to not clip model-based contours along every boundary, only along 
boundaries where the model depth changes, results in this situation being much less likely, 
as the skinny complicated geometry is almost always at the same depth as the adjacent 
area. The cases that were known to fail no longer have issues. 

Miscellaneous

The command to import reference model points from a file has been removed. There are 
other ways to import points that are more general. For example, if the xyz points are in a 
file, they could be imported as a CSAR point cloud, with the much more sophisticated 
support for format information (.info) files that support a wide variety of input formats, and 
then the reference model points and/or surfaces could be created as needed. 

Model

The view extents are no longer ever requested when creating a new reference model. The 
view extents can be controlled by other existing options, such as saved view extents, or by 
opening other data. 

Vertical and Inclined Surface Analysis

Newly created rasters gridded relative to a specified plane now encode the rotation as part 
of the coordinate reference system. This change means that these rasters cannot be 
opened in older applications. 

When importing points and creating a raster surface relative to defined planes, the 
application would always try to open the source data directly to retrieve the input 
coordinate reference system. This caused the import wizard to display an error message, 
and sources such as ASCII data could not be imported. Now, the source data is only 
opened when the input and coordinate reference system are not specified, so any data 
source can be imported. 

Whenever a raster surface gridded relative to a plane was opened, a computed band used 
to be created for the distance from the projected coordinate reference system datum. That 
band used to be named similar to "Depth (computed from Distance from Plane)". Now, that 
information is displayed as a coordinate value instead. For example, selections for a band 
typically reports the X and Y coordinates and the band value; for rasters gridded relative to 
a plane, the selections for a band will now report the X, Y, and Z coordinates (all relative to 
the top-down CRS) and the band value. Exporting these rasters to ASCII will always export 
the X, Y, Z coordinates, in addition to the specified bands. 

It is also possible to colour the primary elevation band of a raster surface gridded relative 
to a plane based on its depth. This allows applying a consistent Z-based colouring for 
rasters gridded to a variety of planes. 

Volumes

Comparative volumes could fail with a geometry error if one or both TINs had been cut, i.e. 
if outer boundaries had been added to the TIN Editor layer. The algorithm has been 
adjusted to avoid attempting to cut a TIN to the same geometry twice by adding a buffer 
around any TIN that has been cut with an outer boundary. This buffer does not affect the 
ultimate calculation, which will still return the volume between the TINs in areas where 
both TINs are defined. 
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General Notices
• Support for 32-bit operating systems is being phased out. In a future version of BASE Editor, only a 

64-bit version will be created, which will only run on systems with 64-bit operating systems. It is 
recommended to upgrade to a 64-bit operating system.

• The new Feature Editing module requires a new license string. Contact CARIS Customer Services 
for more information.

• BE 4.2.0 fixes some issues in the creation of compressed BAG files, however, compressed BAG 
files created in BE 4.1.x may not display correctly in BE 4.2.0. Contact CARIS Customer Services if 
you experience this issue.

• Not all formats have been updated fully to the new properties structure. For example, certain 
formats such as DXF, DWG and reference models still have distinct properties available for 2D and 
3D views. Also, transparency has not been hooked up for reference models after the implementation 
of the new properties structure.

• The changes to how the application is deployed mean that the command prompt must be setup 
before executables can be run. New options, such as the BASE Editor 4.2 Command Prompt 
available through the Windows Start menu, and the command prompt utility in the Utilities toolbar, 
setup the command prompt appropriately. A benefit of using these tools to setup the command 
prompt is that it is no longer necessary to browse to the command prompt tool; for example, you can 
call CARIS Batch commands directly from any folder if one of the tools is used to setup the 
command prompt. 
• Note that the BASE Editor 4.2 Command Prompt available through the Windows Start menu sets 

up the path for all deployed modules, and the Utilities toolbar command prompt option sets up a 
command prompt with the same path as the running application, which means only the modules 
enabled in the application are in the path. This is relevant, for example, for bathydbserverloader, 
which requires BASE Manager licensing.

• The environment used by the Python bindings in now controlled by the file installed as 
\system\environment_python.xml. This may need to be customized, particularly if your system uses 
local licensing.

• Certain files, like the RXL coordinate system registration (CRS) files, have been updated to store 
CRS content in a new format, and cannot be read by other software, including older versions of 
BASE Editor and HIPS. They also cannot be read by HPD 3.2 or any older versions.

• Support for old style format information files has been removed. The files created in the ASCII Info 
File Editor in BE 4.1.x and BE 4.2.x can be used, but they must specify the Z-axis convention for the 
primary band. 

• If you have previously installed a version of the MrSID/ECW plugin, it is highly recommended to 
install the 1.0.3 version or later. This re-enables these formats in newer applications and ensures 
the application finds the correct version of binary files in all cases. Note that MrSID/ECW plugins are 
always backwards compatible, so installing 1.0.3 will allow you to continue to use these formats in 
older applications as well. The plugin is available through the CARIS OCS website, and you can 
contact CARIS Support for any additional information. 
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• The legacy bathysurfacerepair tool has been removed. It is recommended to use this repair tool in a 
previous release prior to upgrading to BE 4.2.0 if coverages require repairs. Coverages that may 
need to be repaired include:
• point clouds created from BE 2.2 to 3.0.0.11; their extents may be incorrect,
• coverages added to a database prior to BE 3.2; if the database has never been upgraded with 

the bathydbclone tool, some attributes may be missing that would improve the performance of 
the server combine process,

• coverages that contained designated soundings which were subsequently shifted prior to BE 
3.2.2.4; the original depth may be the original value from before the shift,

• raster surfaces created in HIPS prior to HIPS 7.0.1; they may have a standard deviation band 
that is incorrectly identified as an elevation band that is affected by z-axis convention. 

• Lineage information is only stored for commands that have been implemented through the process 
framework. It is expected that more commands will be reworked into commands in the coming 
releases. In the meantime, information is not stored for commands such as Compute Layer and 
Export Surface to Point Cloud. 

• Support for PFM as an import format has been removed. This is part of preparation to upgrade the 
third party support for PFM, with the intention of supporting it as a format that we open natively in an 
upcoming version. 
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