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CARIS1 HIPS2 and SIPS3 10.2.0

Highlights

Support for Multiple Detections

 Multiple-detection data can now be imported to HIPS projects from Teledyne Reson Multi-Detect 
and Kongsberg Extra Detections. The import of multiple-detection data is an optional step in the 
processing workflow, quite similar to the existing workflow for Water Column Imagery. Once the 
main bathymetry processing is complete, multiple-detection data can be imported as Additional 
Bathymetry, and all correctors applied to the standard bathymetry (including tide selection, sound 
velocity correction etc) are applied to the imported data. This Additional Bathymetry can then be 
reviewed, cleaned if necessary and optionally included in any downstream products.

Data Credit: CHS/NAVO, Kongsberg EM2040D

Support for Time Series Backscatter in SIPS

 Full Time Series backscatter data can now be processed with SIPS Backscatter for Teledyne 
Reson and Konsgberg systems. Leveraging the proven backscatter algorithm of the first SIPS 
Backscatter release in HIPS and SIPS 9.1, the same processing methods are applied to the full 

1. This term is a trademark of Teledyne CARIS, Reg. USPTO and CIPO
2. This term is a trademark of Teledyne CARIS, Reg. USPTO and CIPO
3. This term is a trademark of Teledyne CARIS, Reg. USPTO and CIPO
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Time Series data. The workflow to process Time Series data is as seamless as it was before, with a 
single additional step after standard multibeam bathymetry processing to produce high-quality, fully 
corrected backscatter mosaics.

Left: Beam Average, Right: Time Series

 Normalized backscatter from Teledyne Reson systems is now also supported in SIPS Backscatter, 
for processing from both Beam Average and Time Series data.

Plymouth Fort, UK, T50P Compensated Backscatter
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Engineering Analysis Module now available in HIPS

The Engineering Analysis Module (EAM), previously available as an optional add-on to 
CARIS BASE Editor, is now also available as an optional add-on to HIPS. The Engineering 
Analysis module provides seafloor analysis tools for dredging and other engineering 
operations, including the creation of channel reference models and volume computations.
 

Visualizing channel conformance in HIPS

Note: An updated license is required to run v10.2 software. Each license is unique and will work with 
HIPS and SIPS 10.2 as well as earlier versions. Subscribed keys have been automatically updated and 
are available for download from the OCS.
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Enhancements

Reference Description

3D View

Colouring a coverage based on the values in a status band now displays different 
values in more distinct colours, to facilitate finding nodes based on status value. 

The colour legend in the 3D View now displays more meaningful content for string 
bands and Status bands.

A new feature layer can now be created while in the 3D view. 

When creating a New Feature Layer, if any view is open with data in it, the centre of the 
view is used automatically for the initial extents of the new feature layer. The extents 
picker is not displayed in the New Feature Layer dialog box in this case. 

Note: the extents of a feature layer are automatically updated to the extents of the 
features in the file when it is saved. 

 It is now possible to make selections in the 3D view, as part of a continued effort to 
make interacting with the 3D view more central to the application experience. This 
allows, for example, easily creating features in a HOB file for points in a point cloud that 
are notable for any number of reasons. 

CARIS Batch, Processes

APP-2613 Some changes were made for how application settings are processed by CARIS Batch. 
No functional changes are expected in the application. 

BDB-15955 Processes that create rasters have been updated to report specific error messages 
when available, instead of internal errors. 

FRM-13791 The AddFeatures process in the CARIS Batch command line tool could create shifted 
results. This happened because the features were treated as unregistered, due to an 
internal detail of how the coordinate reference system (CRS) was stored, and could 
have affected opening GML files in the application, or GML files and Shapefiles through 
the CARIS Batch command line tool. Now, the CRS information is correctly processed 
and AddFeatures creates the expected results. 

The restriction of only being able to use AddFeatures in the CARIS Batch command 
line tool if the input had the same coordinate reference system (CRS) and resolution as 
the output has been relaxed. Now, CRS transformations happen as needed in 
AddFeatures.

It is now possible to use an Onboard service URI as an input for a process in the CARIS 
Batch command line tool. As an example, CARISBatch --run CopyToCSAR 
http://127.0.0.1:8080/rest/v1/csar/CUBE1m 
d:\CopiedFromOnboard.csar.

When the output format is HOB, the ContourRaster process in the CARIS Batch 
command line tool now has an option for creating polygons between successive contour 
lines (e.g. depth areas). These polygons can optionally have attributes populated with 
the minimum and maximum values of the raster band within the polygon area.

The CreateSoundingsFromCoverage process has been added to CARIS Batch. 
This includes many of the options available in the Sounding Selection command in the 
application.

It is now possible to specify horizontal and vertical buffers when tiling a raster to allow 
overlap in tiles.
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The command to export a coverage as a point cloud is now available as the 
ExportPoints process in the CARIS Batch command line tool. As as result, this 
process will produce a CSAR point cloud with lineage information, even when it is run 
through the application. 

The dialog box in HIPS has also been updated to be similar to the other process-based 
dialog boxes and the Export Surface to Point Cloud command and dialog box has been 
renamed Export Points.

It is now possible to define the contour generation method for ContourRaster in the 
CARIS Batch command line tool. This can be used to create contour boundaries that 
fully cover all populated cells, instead of ending at the location of true position nodes.

A new option was added to the ContourRaster process in the CARIS Batch 
command line tool to remove collinear points during contour creation. This can be 
helpful when using the contours in later processing for feature-based products that 
prohibit collinear points. Note that in a future version, this option will be removed and 
collinear points will never be created in these features.

When exporting a BAG to BAG format using the ExportRaster process in the CARIS 
Batch command line tool, the BAG metadata from the input is now used for the output. 
Any metadata values specified in the command line override the default values carried 
over from the input.

Some processes, including Finalize Raster, Finalize Variable Resolution Surface, and 
Create Variable Resolution Surface have a new option for setting the Z-axis convention. 
If a process model created using a previous version is opened in Process Designer, the 
new option will be defaulted to the application's current Z-axis convention (positive 
down) and the setting would need to be updated to match the values (default positive up 
in Process Designer prior to 10.2).

Convert To HIPS 

The LAS converter now includes LAZ files in the extension filter when selecting raw 
files. 

The Teledyne PDS converter has been updated to use the latest API, version 2.0.1.1. 

The conversion of LAS data has been updated to reject WITHHELD flags, to be more 
consistent with other Teledyne CARIS applications. 

A cable out/layback positioning option for side scan data has been added to Hypack 
RAW, HSX conversion. The CAB data field will be read from HSX format. 

A new process, File> Import> Auxiliary Data> Multiple Detections, has been added to 
HIPS for importing Kongsberg Extra Detections and Teledyne Reson Multi-Detect data 
records as Additional Bathymetry. 

Export 

 When BAG files are created, validation is now performed and detailed error messages 
are provided for any issues with the metadata. 

Exporting to BAG files now always writes out 12 decimal places of precision to prevent 
scientific notation being used for the values.

The Party Role setting in the BAG metadata identification information had always been 
hard-coded to “Originator”, regardless of what was entered by the user. The values 
specified by the user for the Responsible Party settings are now honoured in the output.

Reference Description
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Error messages from certain processes, such as creating a GeoTIFF, are now properly 
returned in the error stream instead of the regular output stream. This facilitates writing 
complicated Python scripts that call a number of CARIS Batch scripts and identify error 
cases. 

Export > HIPS Data > HIPS to HOB track line settings have been updated to 
automatically populate the information attribute with the full path of the HIPS line on 
disk, e.g., Path\<Project name>\<Vessel name>\<Day>\<Line name>. 

Features 

It is now possible to save feature layers with S-100-based catalogues, such as the 
SSDM catalogue, without exporting the data to a GML file or similar format. A new 
CARIS feature-based format with the H2O extension is used for this data. This allows 
using catalogues with feature acronyms of arbitrary length, multiplicity, and the other 
rich modelling capability available in S-100.                             

Feature layers based on S-57 catalogues continue to be saved in HOB format.

The Vectorize from Raster feature editing command has been renamed Line from 
Image.

The names for the types of catalogues in the New Feature Layer dialog box have been 
updated. Specifically, a VPF prefix has been added for the DNC types. This changes the 
default type to S-57, with its finer resolution.

Filters 

It is now possible to create length-based rules in the Rule Wizard to filter lines (open 
and closed) based on their length. This can be used, for example, to isolate short 
contour lines. 

Filters in processes would not work if any of the band names contained special 
characters such as <, >, =, which were interpreted as part of the expression and not the 
band name. Quotation marks can now be used to ensure the band name is properly 
parsed when it contains special characters.  

This applies to the FilterCoverage, ExportCoverageToASCII and 
ExtractCoverage processes, and the Filter, Surface To ASCII and Extract filter dialog 
boxes.

The Surface Filter has been updated to better handle slopes when CUBE surfaces are 
used as the source for the filter. 

The Filter Observed Depths button on the HIPS Data Filters toolbar is now disabled 
when Swath Editor is open. Observed Depths filtering is done in Swath Editor using the 
Filter Observed Depths button on the Swath Editor toolbar.

Generic Data Parser 

The option to load Delayed Heave has been added to Generic Data Parser. 

GUI

If there are any transient coverages open when closing all data or saving a session, 
there is now a prompt giving an opportunity to save this data.

The HIPS Module has been renamed HIPS Professional in the Tools > Modules dialog 
box, and its description has been updated. 

Reference Description
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Installation 

The HIPS and SIPS template folder has been moved to the HIPS and SIPS folder under 
%ProgramFiles%\CARIS\HIPS and SIPS\10.2\modules. 

The sample depth ranges file for Variable Resolution creation by Ranges has been 
renamed to “Depth_Ranges.txt”. 

The Engineering Analysis module is now available to licensed users within HIPS and 
SIPS.

Licensing

The licensing HASP drivers have been updated to a new version. This addresses some 
installation issues seen on Windows 10 systems that prevented concurrent installation 
of different application versions. 

Process Designer 

The existing features processes have been updated to be able to be used in Process 
Designer. No substantial functional changes are expected, but some error handling has 
been improved. 

The file list control was updated to be more consistent. Clicking an item selects it, 
double-clicking an item edits it and clicking the '+' button is the only way to browse for a 
file.

The following raster processes from the main application are all now available in both 
Carisbatch and Process Designer for use with the existing processes: 
• AddFeatures 
• CalculateCoverageVolume
• ChangeFeatureAttributes
• ClassifyRasterHolidays
• ClipFeatures
• ContourRaster
• ContourRasterByModel
• CopyToCSAR
• CreateSoundingsFromCoverage
• DifferenceCoverages
• EraseFeatures
• ExportFeaturesToShapefile
• ExportToWKT
• ExtractCoverage
• ExportCoverageMetadata
• ExportCoverageToASCII
• ExportPoints
• ExtractCoverage
• FillRasterHolidays
• FilterCoverage
• FilterFeatures
• AddFeatures 
• CalculateCoverageVolumes
• ShiftElevationBands
• VectorizeRaster 

QC Reports 

The Surface QC Report dialog box has been updated to include User Defined settings.

Reference Description
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Selection

The Select by Lasso behaviour has been improved to support continuous drawing of the 
boundary of the selection area in the 2D, 3D and display windows. 

For improved usability when showing or hiding multiple HIPS track lines, “Show”, “Hide” 
and “Show only selected” commands have been added to the right-click menus in the 
Project window and main Display window. 

SIPS Mosaics

SIPS mosaics are now identified as such through the use of new metadata. As a result, 
new files created from SIPS mosaics, for example through the Surface > Extract 
process, retain the metadata and the new files are also now identified as SIPS mosaics 
in the application.

A number of processes, such as Profile, have been updated to support this new format. 

New SIPS mosaics will not be identified as SIPS mosaics in older software as the older 
software does not read the relevant metadata.

Support has been added for time series imagery processing in the SIPS Backscatter 
processing engine for Teledyne Reson and Kongsberg sonars. 

SIPS Backscatter mosaic creation on data with duplicate records no longer causes a 
failure in the processing engine. Any line with duplicate records will be skipped and this 
is reported in an error message. The processing then continues to the next line.

SIPS Backscatter interpolation has been updated to better locate adjacent samples.

An issue preventing the creation of SIPS Backscatter mosaics on some Kongsberg 
EM710 data has been resolved.

Beam average and time series mosaics from Reson s7k 7058 records (Calibrated 
Snippets) can be created with the SIPS Backscatter processing engine. If beam 
average is selected, one value per beam is extracted from the snippets.

Support has been added for time series imagery processing in the SIPS Backscatter 
processing engine for Teledyne Reson and Kongsberg sonars. 

The Compute Layer command can now be used to add layers to SIPS Mosaics.

Subset Editor 

When a reference model is viewed as a reference surface in the 2D view of Subset 
Editor and it is a horizontal plane, the view will now represent that plane as a line. 

Surfaces

 Compute Layer for surfaces now accepts expressions with conditional operators that 
allow filtering of the data for populating a computed layer. See user documentation for 
details of syntax and examples

The logic used to evaluate expressions is now shared for point clouds and raster 
surfaces. No functional changes are expected. 

It is now possible to use IF, >=, <=, and NO_DATA when writing expressions, for 
example when using Filter Coverage or Compute Layer. The keywords like IF are now 
case insensitive. NO_DATA, however, must always be upper case.

Computed bands in CSARs are now created dynamically using the filtering logic, which 
in-house testing shows provides a performance improvement. 

Reference Description
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When copying from a raster surface with non-standard x-axis convention, the resulting 
CSAR file was not as expected. This was seen with certain CIT files; if using an 
unregistered coordinate reference system (CRS), the resulting CSAR was horizontally 
flipped, and if using a projected CRS, planar offset and normal properties were set. 
Now, the x-axis values are handled as expected. 

It is no longer possible to set the coordinate reference system (CRS) of an open 
coverage as Undefined. Coverages must have a CRS defined; engineering datum can 
be used for CRS that are not georeferenced. 

Each layer / band in a surface or coverage is now identified by its type of data. This fixes 
displaying elevation bands in 3D when the coverage also contains a colour band. 

The Compute Layer command is now available in the context menu for the parent of a 
surface in the Layers window. As well, the Remove Layer command can now be used 
for any computed layer or band in a SIPS mosaic.      

Variable Resolution surfaces can now be displayed as reference surfaces in Subset 
Editor. 

If any surface sources are outdated, it is no longer possible to create, recompute or add 
to the surface containing those sources. A message will be output in the output window 
and the process will end. 

The dialog boxes used to create New Regular Gridded surfaces and New SIPS Mosaics 
have been updated to be easier to use. All options that have default settings have been 
hidden using progressive disclosure controls which enable users to easily run the 
process with fewer options to set. 

CSAR point cloud status bands are now identified as “Flag Set” type instead of “Scalar” 
in the Band Type property field. No functional effects are expected as a result. This was 
done to more clearly support mapping multiple flags into the single band value.

Activating the CHGF function in the Variable Resolution Cube Properties improves 
hypothesis generation over slopes and steep features, providing better depth estimates 
under these conditions.

The vectorize raster process could fail with specific data, particularly when very small 
polygons were created based on a single row or column of nodes. The algorithm has 
been updated to complete successfully in these cases. The process could populate the 
wrong attribute value. This has been fixed.

 The performance of the CARIS Density and Ranges resolution estimation methods has 
been considerably improved. 

When mapping by value, the Vectorize Raster process has been expanded to allow 
mapping individual components of a parametrized string table band, such as 
Contributor, to attributes in a newly created feature. It is possible to map the same 
component, or the entire value, to multiple attributes.

Miscellaneous 

Attempting to copy empty geometries to formats such as Shapefile used to fail with an 
error about an unsupported interpolation type. The geometries are now copied as empty 
geometries, when appropriate. 

The plugin for connecting to data from a CARIS Onboard service has been adjusted. No 
functional changes are expected. 

The NARD datum has been added to the datummapping.xml file to improve support for 
BSB datasets that have coordinate reference systems based on that datum. 

Reference Description
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Memory is now cleared more consistently when retrieving the proxy to open a provided 
URL. 

When a Geodetic Datum Code is not found in the KNQ record of a BSB image file, 
version 3.0 or later, the application now attempts to read the Geodetic Datum Name 
from the KNP record. If the Geodetic Datum Name is used, a warning message is now 
displayed. If no Geodetic Datum Code or Geodetic Datum Name is found, an error 
message is now displayed. 

A new entry was added to the Bathy DataBASE catalogue for isolines at a constant 
value. The new entry is named Isoline (isolne) and has a corresponding attribute 
named Isoline Value (isoval). 

This can be used, for example, to perform contouring on a SIPS mosaic and produce 
lines in a HOB file. A DEPCNT cannot be used in that context as those are defined to 
have values in metres, and SIPS mosaic intensity values are in decibels.

Coordinate reference systems (CRS) that did not contain a WKT prefix were not being 
interpreted correctly, resulting in an error message being displayed in the CRS registry 
about an identifier not being found for a bound CRS. Now CRS that come from other 
sources that reference PROJCS, GEOGCS, or COMPD_CS are handled properly.

Several dialog boxes including the Export Raster dialog box have been updated to 
include helpful text when there are no appropriate bands available to be selected. 

Reference Description
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Maintenance

Reference Description

.hips File

Feature mapping during Import Selected Objects from a *.hips file has been fixed.

3D View

Properties for certain vector formats, such as DWG, and reference models, would still 
display the 2D properties when the 3D view was activated. The properties are now 
cleared when the 3D view is activated, and the appropriate properties are displayed 
when a source is selected.

Clicking the middle mouse button in the 3D view could cause the camera to zoom out. 
The minimum scale has been adjusted to prevent this automatic zoom out from 
occurring.

Additional Bathymetry

Regenerate Additional Bathymetry no longer fails if Tide was not loaded.

Additional Bathymetry point cloud properties are now fully displaying platform name, 
minimum and maximum times.

The surface creation progress bar has been updated to work correctly when adding 
additional bathymetry to a surface.

Status bands for Designated, Rejected, Accepted, Outstanding, Examined soundings 
have been updated to display each state as a different colour in the 2D view.

 Additional bathymetry data can now be displayed in Subset Editor without other data 
being enabled.

Additional Bathymetry now remains visible in the Subset Editor if the HIPS project is 
moved to a different location.

Regenerating the critical soundings layer now includes designated soundings in the 
additional bathymetry layer as well.

Additional bathymetry will now display in Subset Editor even if the view projection is 
different than the one used by the Additional bathymetry layer.

Subset editor 3D view no longer jumps back to overview after creating additional 
bathymetry.

Using the Add selection to Additional Bathymetry command no longer outdates a 
surface when the “Include additional bathymetry” option was not used during the 
surface's creation.

Adding Additional Bathymetry to a surface now correctly applies outdated or updated 
status to the surface, depending on the Automatic Surface Update setting.

When Automatic Surface Update is off, saving edits in Subset Editor no longer reports 
warning messages that the surfaces are out-of-date and require recompute. 

Beam Pattern

 Creating a SIPS Backscatter Beam Pattern has been fixed to run when using a surface 
as a DTM source.
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CARIS Batch, Processes

Running the CreateSIPSBeamPattern command in carisbatch no longer fails.

The AddFeatures process in the CARIS Batch command line tool has been updated 
to ensure redundant edges are not added.

The way that the CARIS Batch command line tool initializes support files has been 
changed. No functional differences are expected.

The error message when attempting to create a coordinate reference system from an 
unsupported projection has been improved. This is seen, for example, when using the 
ExtractCoverage process with a KAP raster.

A specific error message is now displayed when attempting to filter a raster based on 
values in a colour band.

The finalize raster process still produced a raster surface even if an error was reported. 
Now, the incomplete CSAR file is automatically removed when an error occurs.

The Classify Raster Holidays process now runs correctly with mosaics in CARIS Batch.

When DXF files were created in the application, the measurement units were always 
created as “English - Inches”. RXL files were created with the correct units so the 
resulting DXF files were opened correctly in CARIS applications. The measurement 
units in the DXF file are now set correctly, provided DXF has support for the appropriate 
unit; otherwise, the units are defaulted to metres.

Creating contours in a HOB file through the CARIS Batch command line tool was 
incorrectly setting the isolation type value as the contour depth. The correct depth is now 
populated for the contour line objects.

The FillRasterHolidays process in the CARIS Batch command line tool now gives 
an informative error message if the input is not a raster.

Raster surfaces that have been interpolated cannot be finalized. The error message for 
the FinalizeRaster process in the CARIS Batch command line tool has been 
improved for this situation.

Catalogue Editor

Adding values to an enumerated list in the HIPS Catalogue Editor, or making other 
changes to the list values, is now saved appropriately and allows for these HIPS 
Projects to be opened.

Compute GPS Tide

The Realtime option for Water Line in Compute GPS Tide is now being applied correctly.

Computing HIPS GPS Tide using certain separation model file types no longer fails.

Contacts

Contact image names are now updated to match the contact ID, which will allow the 
contact images to show in the Image Preview window.

Reference Description
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Convert to HIPS

Sound Velocity Profiles stored in Kongsberg ALL files are now being treated differently 
during conversion to HIPS:
• A Sound Velocity Correction entry is made in the stored line log file for each unique 

SV change from acquisition. The time stamp of each entry corresponds to the time it 
was applied.

• The SVP file created in each line folder will store all unique SV entries. The time 
stamp of the stored profiles is the original cast time

Referencing Kongsberg *.all data directly is now working when the Position datagram is 
EM90 type. Also, the EM100SVP datagram is now supported.

Conversion of specific GSF data no longer causes the application to fail.

The Hypack RAW, HSX converter no longer shows HS2 in files of type selection.

JSF Bathymetry that is missing data from the port channel will now convert with the 
correct time stamps.

 Selecting Project, Vessel and Day from the File selection type field at step 3 of the 
Conversion Wizard is now correctly creating the PVDL structure on conversion.

When converting Kongsberg ALL, using “Reference *.all data directly”, into an existing 
HIPS project that has a different datum/ellipsoid than does the HIPS Vessel File, (for 
example, has WGS 84 vs. NAD 27), the navigation data used for display in HIPS and 
SIPS is now properly transformed.

Side scan from EIVA SBD is now supported during conversion.

Documentation

CARIS Batch documentation for HIPS and SIPS Processes and Variable Resolution 
processes is now showing properly online.

Export 

When exporting the view to a GeoTIFF, if the Tools > Options coordinate units were set 
to something other than metres, the resulting GeoTIFF had incorrect coordinate values. 
The export GeoTIFF functionality has been replaced and now works correctly with 
various coordinate units.

When exporting a selection from a feature layer or HOB to 000, the coordinates could be 
slightly different. This was noticed most often when using a feature layer with VPF DNC 
coastal resolution. More accuracy is now maintained when calculating the coordinate 
multiplication factor, and the shift no longer occurs.

 When exporting a raster to GeoTIFF, the result is now tiled, with pyramid levels that 
display more detail at finer resolutions.

Using the Export Raster process to convert an image with transparency to JPEG 
produced a file that displayed incorrectly as the colour information was incorrectly 
identified as CMYK . The image is now created with the correct RGB colour information.          
Note that transparency is dropped and all pixels are displayed based on the remaining 
colour information. If no colour is set for a given pixel, the result is black pixels.

HIPS to HOB export was failing to export Navigation retrieved via direct read from a raw 
file. This has been fixed.
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Feature Editing

Certain area features could disappear when using a feature to cut other features, with 
the Edit > Features > Cut or Edit >Features > Cut and Remove commands. This 
happened when the resulting geometry included a near collapse. The entire source 
geometry was skipped as a result. The precision of geometry calculations has been 
improved for these commands, and the area features are now cut as expected.

 When clipping features with the Copy to Clip Layer command, features that cannot be 
clipped to a specified geometry are now reported in the Output window.

The vectorize raster process could fail with specific data, particularly when very small 
polygons were created based on a single row or column of nodes. The algorithm has 
been updated to complete successfully in these cases. The process could populate the 
wrong attribute value. This has been fixed.

 Error messages have been improved for cases when the application cannot open a file 
containing feature object data.

Filters 

HIPS Data Filters > Surface/Polygon (Filter Type:Polygon only) functionality has been 
updated to use the Keep Up to Date flag on each surface affected by the filter when 
Automatic Surface Update from Tools > Options is on. The affected surfaces will be 
updated after filtering is complete.

Finalize

The finalize raster process was failing with an error message about the dimensions if a 
subset of the source did not contain any information to copy to the output raster surface. 
The finalize process now skips over those subsets and writes out the remaining 
information to the output raster surface.

 The uncertainty band was not being displayed for raster surfaces created by the 
Finalize Raster process when the view was zoomed out. New raster surfaces created by 
Finalize now have uncertainty values when zoomed out.

 Finalize speed has been increased significantly when applying Designated soundings.

First Run

The module state dialog box (Tools > Options > Modules) was being shown on first run 
of the application for each user. Now this behaviour can be overridden by having a valid 
moduleState.xml file in the ProgramData folder. This allows easier setup for 
systems used by multiple users. User-specific choices for the active modules for each 
user can be adjusted by updating Tools > Options > Modules after starting the 
application.

Generic Data Parser

Generic Data Parser is now converting Hydro SB (Single beam) data with the correct 
internal setting, which allows merge to work properly for that data type.

 Generic data parser processing can now be successfully run using the Run Process 
Designer Model command from the Tools menu in HIPS.

GUI

If the console window is turned on for the application, and it is active, pressing CTRL+C 
would cause the application to close. CTRL+C now has no effect when the console 
window is active.
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Changing display properties for features while the view was being refreshed could cause 
the application to fail. Changing the display properties now cancels any ongoing view 
draw operation.

Grouping of variable resolution surfaces in the Layers window is not supported and now 
prompts with an informative message instead of an error.

Projects are now listed in alphabetical order, regardless of capitalization, in dialog boxes 
where the project tree is displayed.

SIPS menu items are no longer visible when the SIPS module is turned off.

HIPS Utilities

 The Refract command line utility is now working correctly.

The CreateSurface utility has been removed from HIPS since the CreateHIPSGrid 
functionality is available in carisbatch.

Import Auxiliary Data

TerraPos navigation data containing large time gaps is no longer shifted in time on 
import.

 Importing Delayed Heave using Import > Auxiliary Data > Applanix POS MV now loads 
properly on a line with large time jumps (1/2 day or more) and skips the records (outputs 
messages) so that the subsequent good data can be imported.

Line Report

 In a Detailed Line Query report, the Delayed Heave File field now correctly shows the 
file name and path for the selected line.

 Line Report is now properly displaying the loaded SBET file.

Merge

 Remote heave is now applied in Merge for Kongsberg data, when offsets are in the 
Heave section of the vessel file.

Navigation Editor

Running Set Navigation Source will now show a processing dialog box when in 
Navigation Editor. 

Options

 The Time Buffer can now be set to 0 (zero) in the Tools > Options dialog box.

Process Model

An issue with running multiple lines through a process model file has been resolved.

HIPS-15966 Running a process designer model file in HIPS, that contains a Create HIPS Grid 
referencing an invalid CRS or extents, no longer causes the application to fail.

Processes

The Process > Apply Smoothing command has been removed from HIPS and SIPS 
since the input file is not available for 10.0 versions and higher. 
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Profiles

Transient Profile layers are no longer saved to session files as they are not re-created 
when the session is reopened.

Profile creation on an Intensity layer of a SIPS Mosaic has been fixed.

Sessions

When a session file is opened, the coordinate reference system of the view now 
respects the position units specified in Tools > Options.

SIPS Mosaic

Memory issues when creating a GeoCoder mosaic have been resolved.

Artifacts are no longer introduced to Kraken data during SIPS Side Scan Mosaic 
processing.

Mosaic creation using SIPS Backscatter no longer fails for data with missing pings.

When saving a mosaic after editing the Brightness/Contrast, there are no longer error 
messages in the Output window.

Sound Velocity Correction

Applying Sound Velocity Correction to Elac data no longer causes a vertical shift at 
nadir.

Sounding Selection

 Performing mapping during sounding selection did not correctly map over SORDAT or 
other date fields in CSAR bands. This was caused when the SORDAT was stored as a 
string in the CSAR band because mapping was only happening for bands stored in a 
date format. Now, data stored in string bands can also be mapped to date fields, but this 
simply copies the value over without performing validation of the content.

Subset Editor

Improvements have been made to the speed for loading/unloading huge projects in 
Subset Editor.

 Reference surfaces now load correctly in Subset Editor when the project has a different 
coordinate reference system than the reference surface.

When using the Surface Filter with settings that would reject all soundings (for example, 
by using a Static Value of 0.0m), some soundings were not being rejected. This has 
been fixed.

Selecting Cancel instead of Save when exiting Subset Editor was causing the 
application to fail. This has been fixed.

Surfaces

Creating a new gridded surface using CUBE no longer fails when multiple HIPS and 
SIPS projects are the source.

Automatic Surface Update no longer gives warnings for difference surfaces open in 
HIPS. A difference surface can never be kept up to date.

Grouping multiple surfaces together could cause the application to fail if the properties 
did not have minimum/maximum values for a layer. The application now avoids updating 
undefined properties and the grouping completes as expected.
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Transparency properties, such as for surfaces, could be set when either a 2D or 3D view 
was active, but the values displayed would be reversed when switching from 2D to 3D. 
For example, a 20% transparency set in the properties when a 2D view was active would 
be displayed as a 80% transparency in the properties when the layer was active in 3D, 
although it was actually applied as 20% transparency. Transparency values are now 
correctly copied from 2D to 3D, and the transparency percentage displayed in 3D is the 
value that is applied.

Variable Resolution Surfaces no longer show a 'Status' band in the list of layers for 
display.

The Vertical Shift dialog box has been updated to use a generic dialog box that exposes 
all of the process options. The user interface will be more consistent with other updated 
dialog boxes, but no functional differences are expected.

When contouring a true position raster, selecting the “Grid” contour generation method 
still produced true position-based contours and boundaries. This has been fixed so that 
the contour generation method is respected when contouring a true position gridded 
surface.

When performing a vertical shift of a point cloud, the shift source and data were 
assumed to be in the same coordinate reference system (CRS) for an extents 
calculation. This could result in an error message about not finding the band. The 
extents are now correctly transformed to the CRS of the point cloud, and the shift 
completes successfully. 

Create HIPS Grid with Shoalest Depth True Position no longer generates infinite values 
for the Position_TPU and Depth_TPU when TPU does not exist in the HIPS data.

 Linear artifacts are no longer introduced during the creation of uncertainty surfaces.

Variable Resolution 

It is now possible to create variable resolution surfaces when the source file name 
contains the special characters '[' and ']'.

Variable Resolution surfaces are now honouring the Suppressed flag.

A rejected status flag set on Additional Bathymetry data is now honoured when used in 
Variable Resolution surfaces.

The display name for the source coverage in the New Variable Resolution Surface 
dialog box now shows spaces instead of the encoded value of %20.

Vessel Editor

Manually entering a value for the Julian day in Step 1 of the Vessel Editor wizard now 
correctly sets the date in the calendar control. 

Water Column Imaging

The data search for raw WCI is now functioning correctly in Swath and Subset Editors 
for Kongsberg *.all files with accompanying *.wcd files,
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