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CARIS BASE Editor 4.4.0

Highlights
 New tools for generalizing bathymetry

A collection of new techniques are presented for generalizing bathymetry in the chart compilation 
workflows in BASE Editor. 
Two new methods for generalizing elevation surface models and a new safe-side contour 
smoothing method are available. These can be used to produce hydrographically-safe results, 
pushing contours to the deeper water. 

(Figure 1 - Contours produced from increasingly smoothed surface)

A new Thin Points process is also included that can be used for general purpose point thinning or to 
produce a shoal-biased point cloud suitable for chart compilation. The new point thinning and 
smoothing techniques can be used in isolation or together with other tools in the cartographic 
bathymetric feature compilation workflow to produce the best results.
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 Visualizing and editing of Classification bands to better support data from LAS
A new workflow for editing classification values on Lidar point clouds is now available in BASE 
Editor. The new tools are available in the Subset Editor, allowing area based QC and cleaning 
processes to be followed.

(Figure 2 - New classification editing tools)

The new Lidar workflow tools allows for quick, toggle on/off visibility and colouring based on 
classification, as well as editing of flags and classification attributes for points. New classifications 
can easily be added or removed. Cleaned and classified clouds can easily be filtered based on 
classification and modeled as elevation surface models, exported back out to LAS format or 
uploaded into BDB Server as appropriate.
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 3D view improvements
Improved visualization and performance when working with point clouds in the 3D view. In 
particular, points can now be visualized with new geometry styles, such as 'Oriented splats', that 
allow the points to be experienced as a seamless and shaded surface model.

(Figure 3 - Geometry styles for drawing points in 3D)

As well, the user has new options to go into a Pan Control mode to reposition data in the 3D view. 
This and other modes are available in the 3D section of the Options settings.

 New sample S-102 and bENC overlay process models
To facilitate the creation of process models for completing complex or repetitive tasks, a number of 
sample process models are now included in the installation. Of particular interest will be process 
models for bENC and S-102 Bathymetric Surface creation. These files can be found under 
C:\ProgramData\CARIS\BASE Editor\4.4\SampleData\.
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Enhancements

BASE Editor

Reference Description

3D View

01103072 The performance of drawing data in the 3D view has been improved by optimizing the 
frequency of updating the display. Datasets with very large extents are also handled more 
efficiently.

Clicking the middle mouse button in the 3D view now activates the active Controller state 
specified by the Controller Type option in the 3D category of Tools > Options. The right 
mouse button now displays the axes and can be used to rotate the 3D view. 

A new Pan Control option has been added to Controller Type option in the 3D category of 
Tools > Options. When active, Pan Control allows using the middle mouse button to drag 
the data to reposition it within the 3D view. This is similar to how panning works in the 2D 
view. Using a middle mouse scroll wheel still zooms in or out in 2D and 3D views. 

There are new 3D display options for nodes in a point cloud to improve the visualization 
and display shading. The new options are provided through a new Geometry Style 
property under Points in the Properties window when a layer is selected in the Layers 
window. Note that the non-default options require better video card drivers to display the 
points as expected. 

A colour range file with 18 distinct colours for the first 18 integers (0 to 17) was added to 
the colour support folder. This can be used to colour string table bands such as 
Classification bands in 2D and 3D.

Batch Tools

When listing processes available in the CARIS Batch command line tool, now only the 
process names are shown. Note that the descriptions are still shown as part of the help for 
each individual process, for example, CARISBatch --run ProcessName --help.

The SimplifyFeatures and SmoothFeatures processes in the CARIS Batch command line 
tool are now available with the Feature Editing module.

Coverage Tools

01600294, 
01401510

A new Thin Points process has been added to create new point clouds from existing 
coverages, using only a subset of the original points. Three implementations are currently 
available. One algorithm thins the points randomly to remove a specific percentage of the 
source points. A second algorithm ensures there are no points within a specified distance 
of each other point. A third algorithm allows applying a bias to preserve important points, 
which can be the shoalest, deepest, largest, or smallest values, and can prefer designated 
soundings. 

The new biased Thin Points algorithm can be used to accomplish the same kind of shoal 
biased results as Sounding Selection (CreateSoundingsFromCoverage), but has been 
implemented to be more scalable and performant. Thin Points will likely ultimately replace 
Sounding Selection. However, Sounding Selection will continue to be part of the BASE 
Editor toolkit for the foreseeable future, in order to maintain support for existing workflows 
and procedures.



CARIS BASE Editor 4.4.0: Enhancements

CARIS BASE Editor 4.4 Changes List 9

 It is now possible to create a new smoothed version of an existing elevation band in a 
raster surface or variable resolution surface. There are two smoothing methods available, 
both of which preserve hydrographic safety. There is a Laplacian method that iteratively 
applies smoothing, and a shoal expansion method that expands shoals to ensure the drop-
off slope around them is no steeper than a defined limit. Smoother, hydrographically-safe 
contours can then be created from the smoothed bands. This functionality is available 
through the Tools > Layers > Smooth Elevations command, and also through 
AddSmoothedBand in the CARIS Batch command line tool and Process Designer.

BAG file support has increased to version 1.6.1. This includes support for BAG rasters with 
variable resolution (VR) refinement grids. Specifically, it is now possible to: 

• import these BAG files as CSAR VR files using the File > Import > Variable 
Resolution BAG command, a process model or ImportVRSurface process in the 
CARIS Batch command line tool, and

• export CSAR VR as BAG VR using the File > Export > Variable Resolution BAG 
command, a process model or ExportVRSurfaceToBAG command line tool.

The combine processes now support variable resolution surface (VR) input. The result is 
the same as exporting the VR to a point cloud and using the resulting point cloud as the 
input for the combine.

Tile Raster and Clip Raster processes have been added to the Tools > Surfaces 
application menu.

Export/Import

01700820 When a file cannot be imported to the CSAR format, the name of the file is now displayed 
in the details of the error message available from the Output window, or when using 
verbose in the CARIS Batch command line tool. This is particularly helpful if any error 
occurs when importing hundreds of files at once.

When exporting times to LAS, 6 digits of precision are now maintained.

Features

01700544, 
01700484

The Smooth Contours functionality has been renamed to Smooth and Filter Lines and is 
now available in the Feature Editing module from the Edit > Lines menu. The dialog box 
has been rearranged to show the working order of the function. Note that new functionality 
has been added with the previous name and location, i.e. Edit > Contours > Smooth 
Contours.

01100028  It is now possible to perform hydrographically-safe direction-biased smoothing on a 
selection of lines, for example contours and their associated depth areas. If the contours 
were created using a Bathy DataBASE catalogue, there is enough information encoded 
with the line to ensure safety, otherwise there are explicit controls to specify how to adjust 
the lines. This functionality is available through the Edit > Contours > Smooth Contours 
command, and also SmoothFeaturesByDirectionBias in CARIS Batch and Process 
Designer. 

The smoothing is currently performed one line at a time, so it is possible that the 
smoothing can result in crossing contours. Additional work is planned to improve 
smoothing many lines at once.

Format Support

Multi-spectral SIPS mosaics, produced by HIPS & SIPS 10.3, can now be opened in BASE 
Editor. The colour band should be used to visualize the data; the other bands display 
differently than they do in HIPS.

Reference Description
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Installation

The minimum system requirements for the display have been updated to OpenGL 3.3 in 
order to support improved capability in the 3D view.

Process Designer

The "For Each" process has been added to Process Designer to allow running a process 
model against each of a set of inputs. 

This is useful, for example, after running the "List Files" process to collect a number of 
files, or the "Tile Raster" process to produce a number of rasters.

A sample Process Designer model using this process is available at 
C:\ProgramData\CARIS\BASE Editor\4.4\SampleData\ExportTilesToBAG.processmodel

The "List Files" process has been added to Process Designer to allow using wildcards to 
find all files that have relevant names in a given directory structure. 

This is useful, for example, if passing all files of a specific format to the "For Each" process 
to run a set of processes on each of the files - perhaps an import from GSF to CSAR. 

A sample Process Designer model using this process is available at 
C:\ProgramData\CARIS\BASE 
Editor\4.4\SampleData\ImportEachTextFileAsCSAR.processmodel

The "Parse Path" and "Compose Path" processes have been added to Process Designer. 
These allow taking an input file path, breaking it into its component pieces (directory, 
filename, extension) and then re-combining the pieces as appropriate. 

This is useful, for example, in the context of running the same process repeatedly on a 
number of inputs, and using the input filename as a basis for creating a distinct filename 
for the output.”

It is now possible to use a Process Designer model to tile a raster surface and export each 
tile to BAG, with associated metadata also exported. This is available through the new “For 
Each”, “Parse Path”, and “Compose Path” processes. Sample process models are 
deployed with the application to demonstrate how this can be setup; they can be found in 
C:\ProgramData\CARIS\BASE Editor\4.4\SampleData. 

Running the ExportTilesToBAG.processmodel from the sample data runs the 
ExportRasterToBAG.processmodel for each tile that is created.

Sample Process Designer models are now shipped with the application in the 
C:\ProgramData\CARIS\BASE Editor\4.4\SampleData folder.

This includes process models to:
• tile a raster and export the tiles to BAG (ExportTilesToBAG),
• import each source file in a directory as a CSAR (ImportEachTextFileAsCSAR), and
• create a bMIO from a collection of source coverages (bMIO).

Python API

A query method was added for point clouds and variable resolution surfaces that allows 
specifying the bands of interest and/or limiting extents for the query. If no bands are 
specified, all bands are queried. If no extents are specified, all data in the cloud is queried.

Reference Description
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Engineering Analysis

Subset Editor

Classification band values can now be easily visualized and adjusted for point clouds in 
Subset Editor. This is a significant improvement for interacting with data imported from 
LAS files, which can then be exported back to LAS if desired. 

Specifically, in Subset Editor there is now a predefined list of classifications from which to 
select the active classification, and a Classify button that can be used to set the 
Classification band value of all selected nodes to the active classification value. The auto-
cursor mode can also be used to set Classification band values for all selections as they 
are performed. 

A Classification Visibility dialog box has been added to easily turn on or off the visibility of 
points with specific Classification band values. Classification band values are displayed in 
the Selection window and in the 3D view legend based on the name of the classification. 
The Filter Coverage process can be run using the name or number associated with the 
classification. 

The list of available classifications can be adjusted either in the Subset Editor 
Classification Visibility dialog box, or the String Table Definition dialog box available 
through the Properties of the Classification band. Values can be added, renamed, or, if not 
in use, deleted.

Support Files

01502231 The geoid NZGD2000 has been added to the datum lookup support file. Files created with 
this geoid are represented as NZ2K in the coordinate reference system.

Reference Description

2D Display

The Overview command can now be used in the Cross-section window when it is active 
and docked. If the window is undocked, the <F9> key must be used to apply the overview.

Reference Description



CARIS BASE Editor 4.4.0: Maintenance

12 CARIS BASE Editor 4.4 Changes List

Maintenance

BASE Editor

Reference Description

2D Display

Selecting View > Overview or pressing the Overview button now overviews the active 
docked view. To perform an overview on an undocked view that has focus, such as a 
Subset Editor view window, you can now press the <F9> key. 

3D Display

Viewing large point clouds in 3D often used to show tiles of varying data density. 
Improvements have been made to display a higher, more consistent level of detail 
throughout the point cloud, both in the initial display and as zooming and panning through 
the data.

Colour range files are now handled differently from colour map files in 3D. Specifically, 
changes to the minimum/maximum display properties and the sliders are ignored; the 
colour range file values are always respected. The 3D view legend was also improved to 
better show Classification band values, and other string table band values, when using 
colour range files in 3D. 

The Subset Editor views still do not support colour range files at this time.

Changes to most band display properties are now applied immediately without the 3D view 
needing to be redrawn.

When no layer is selected in the Layers window, the left mouse button no longer has any 
effect in the 3D view.

Batch Tools

01700191,  
01701281,  
01701489,  
01701538,  
01701548

The way that coordinate reference systems (CRS) are read from the source for Shapefiles 
has been changed. CRS in RXL files now override the CRS in PRJ files.

The ContourRaster process in the CARIS Batch command line tool has been adjusted to 
use a consistent orientation when creating open contours, and to set the isolation type 
attribute on closed contours that touch the outer boundary. 

The CreateSoundingsFromCoverage process in the CARIS Batch command line tool now 
has a short key (d) for the minimum distance option.

When using the CUBE population method, the PopulateVRSurface process no longer fails 
with an error message about accessing the CUBE configuration file.

The short-key for comments has been removed from all processes. It is still possible to add 
comments by using the full option name, --comments. This allows the short-key C to be 
used for the contributor attribute in the JoinPoints and ServerJoinPoints processes.

Coverages

BAG files with invalid creation time metadata could not be opened. These files can now be 
opened, however, no creation time metadata is shown for them, and error messages about 
the invalid metadata is displayed in the Output window.
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The temporal extent stored in BAG metadata is now shown as the temporal extent of the 
BAG when it is opened in the application. 

If the temporal extent was set for a BAG, this temporal extent was displayed in the lineage 
as the minimum and maximum times for the source(s) used in the process. Now, the 
minimum and maximum times shown in the lineage of the BAG sources is determined by 
the citation date fields in the BAG metadata. If no dates are stored, the times in the lineage 
for the sources are shown with default values, i.e. 1970-01-01 at midnight.

NO_DATA values no longer display for Computed Layers on a variable resolution surface.

Setting the bounding polygon type to convex is now respected for variable resolution 
surfaces.

LAS support has been adjusted in preparation for handling more data in a future version. 
No functional changes are expected.

Coverage Tools

01700696 When creating a new mosaic with a geographic coordinate reference system, the 
resolution is now shown with the precision specified in Tools > Options for geographic 
distances.

When the resolution of a newly created mosaic raster was finer than the resolution of an 
input raster, the mosaic was created shifted relative to the input. The mosaic now lines up 
with the input in this case.

01701610,  
01701638,  
01701221

Creating a variable resolution surface with a geodetic coordinate reference system used to 
fail if resolutions were entered as a number of degrees. These values are now converted 
to approximations of distances on the ground and the process completes. Note that 
coarsest and finest resolutions must be entered in consistent units (e.g. both in degrees, or 
both in ground distances).

01700580,  
01503512

The Extract Coverage process used to include all points exactly on the polygon boundary 
when doing inclusive extraction or exclusive extraction. Now, the points exactly on the 
polygon boundary are only included when doing inclusive extraction.

01700954 Compute statistics used to only consider nodes that had a populated Status band value 
when a raster surface included a Status band. The Status band is now ignored during 
statistics calculations and all populated nodes in the raster are considered for calculations.

01700297 Designated soundings can now be added to raster surfaces that internally store data with 
the z-axis convention of down is positive.

Applying designated soundings when running the Finalize Raster process on a raster 
imported from XYZ files was failing with an error message about not being able to open the 
source. Finalize now completes successfully and displays a warning message about not 
being able to apply designated soundings.

Using Tools > Designated Soundings to designate soundings on a point cloud used to 
leave the Status band unchanged. Now, the status band value is set as Designated.

This does not change any existing designated soundings. Some operations, such as apply 
designated on the Thin Points process, only process points that have the status set as 
Desginated.

Filtering a point cloud could cause the application to fail if the point cloud had a band 
containing time values. Filtering now completes as expected.

While creating a CSAR point cloud, a temporary point cloud is now created in the scratch 
folder. This is not expected to have any functional effect.

Reference Description
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01701182,  
01701451

When combining coverages, the output extents are increased by half of a resolution to 
determine whether a given input coverage is possibly relevant. If the output coordinate 
reference system was geodetic and if the Tools > Options distance unit did not match the 
resolution unit specified for the process, the half resolution buffer may have been 
calculated incorrectly and a coverage that barely overlapped the output extents by less 
than half a resolution may not have been considered for deconfliction. This has been fixed.

When a process created a new CSAR raster surface with a geodetic coordinate reference 
system, if the Tools > Options distance unit did not match the resolution unit specified for 
the process, the resolution could be calculated incorrectly. This has been fixed.

Variable resolution (VR) estimators other than CARIS Density used to fail with an error 
about no data in the extents if the input coordinate reference systems (CRS) did not match 
the output CRS. Now, CRS transformations are properly applied and VR surfaces are 
created.

When repeatedly adding sources to a variable resolution surface, the file size could grow 
significantly. Using Save As CSAR would clean up unnecessary copies of information and 
decrease the file size. Now, adding sources to variable resolution surfaces automatically 
cleans up unnecessary copies, keeping the file sizes lower.

Specifying filtering options for variable resolution surfaces now affects which nodes are 
displayed in 2D display windows.

The wording describing variable resolution surfaces in error messages has been improved 
and made more consistent.

An error message is now displayed if the extents provided for the CombineToRaster/
ServerCombineToRaster process is inconsistent with the area of use of the output 
coordinate reference system. 

The standard process dialog box used for processes with different sets of format or 
method-specific options, like Export Points, no longer shows partially complete saved 
options. 

Reference Description
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Export/Import

01700788 Rejected points are skipped when using the Import Wizard to create a raster surface. A 
message used to state that these skipped points were outside the extents of the data. 
Now, the message in the Output window says how many points were skipped because 
they were rejected and how many were skipped because they were outside the extents.

01700820 When a file cannot be imported to the CSAR format, the name of the file is now displayed 
in the Output window or command prompt. This is particularly helpful if any error occurs 
when importing hundreds of files at once.

01700820 Sources with no valid data are now skipped during import and a meaningful message 
displayed. This can happen, for example, with a GSF file containing only rejected points.

01700909 The performance of importing data to CSAR has been improved for cases when the 
vertical coordinate reference system is specified.

When importing colour data in the ImportPoints process or Import Wizard, any red, green 
or blue values set as 255 were treated as a 0. This means, for example, that all white 
pixels were imported as black, and certain other pixels were darker than expected. Now, 
the 255 value is properly treated as the maximum value for the colour.

01701182,  
01701451

When importing data to a CSAR raster, any specified extents are extended by half a 
resolution. If the output coordinate reference system was geodetic and if the Tools > 
Options distance unit did not match the resolution unit specified for the process, this 
extension amount could be calculated incorrectly; this has been fixed.

01700969 When exporting selected features to DXF, the $INSUNITS units field is now populated 
based on the output coordinate reference system.

Exporting BAG files or coverage metadata now completes successfully when the active 
regional settings on the system has commas instead of periods for decimal separators. 
The metadata files are consistently written with periods as decimal separators.

Export Points to CSAR now reports a meaningful error message if the input does not have 
a primary elevation band.

When exporting points to LAS version 1.4 with a point record format of 6 or higher, 
classification values are now always updated as expected. Specifically, classification 
values of 8 or 12 are now properly mapped to new user-defined values. 

When exporting points to LAS from BASE Editor and selecting input bands to map to LAS 
fields, the available input bands are now provided in a drop-down list. 

When exporting points to LAS from BASE Editor or Process Designer, there is a new 
option to "Include All Bands". This can be used as a more user friendly way to map all 
supported input bands to corresponding output bands. Warning messages are displayed 
when specific bands cannot be exported to the specified LAS format. 

When exporting points to LAS version 1.3, bands that are not supported by the 1.3 
specification are no longer written to the LAS file. This may include bands from later 
versions of LAS or bands created with CARIS tools. Warning messages are displayed 
when specific bands cannot be exported to the specified LAS format. 

When exporting points to LAS, the legacy return count in the LAS file is now correct. 

Override point record format values are now respected when exporting points to LAS.

A number of error messages have been improved for importing from LAS and exporting to 
LAS. In addition, more error cases are now handled when the mapping from input bands to 
LAS fields do not match. 

Reference Description
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Using Export Points to create a new CSAR point cloud from an existing point cloud or 
variable resolution surface would fail if the output did not include all bands from the source. 
Now, a subset of bands can be exported successfully.

Features

01600537,  
01402157

Since BE 4.3.0, all sounding selection is done in the output coordinate reference system 
(CRS), instead of in the input CRS. This resolves a number of cases where shoal values 
were unexpectedly missed, based on analysis done in the output CRS.

01701159 The Quick Creator dialog box now displays an error if an attempt is made to create 
designated soundings from anything other than the primary elevation band of the 
coverage.

01700969 The default $INSUNITS units written when creating contours in a DXF file is now 6 
(metres) instead of 9 (mils).

01701133 S-100 based feature layers, such as SSDM feature layers, only support ‘Edge’ type lines - 
not arcs, loxodromes, or geodesics. A better error message is now displayed when 
attempting to save a file with unsupported edge types.

The name of the "Create Sounding Inside Contour" command has been changed to 
"Create Features Inside Contours" to reflect the more general functionality.

Transforming contours to the output coordinate reference system of a feature layer, such 
as a HOB file, could fail. This happened more often with feature layers with coarser 
resolutions, such as VPF DNC feature layers. Issues could include crossing contours, the 
application closing unexpectedly, and error messages including ones about point-like 
curves. Contours are now created successfully. 

In rare cases, contour lines were created in a reverse direction, resulting in depth areas 
with incorrect attribution. Contours are now created with consistent direction and depth 
areas are properly attributed.

There is improved handling for cases when geometry transformations result in polygons 
collapsing to lines or points, or lines collapse to points. This includes proper handling, such 
as areas correctly reported as 0, and/or error messages in various operations.

The performance of Edit > Features > Cut, and Cut and Remove, have been improved. 
They are now similar to what they had been in BE 4.2.x.

The internal algorithm for contouring variable resolution surfaces was adjusted to improve 
performance. No functional changes are expected.

Format Support

01700191,  
01701281,  
01701489,  
01701538,  
01701548

Certain GeoTIFF files displayed as shifted in the application. This happened for files 
created in older software which encoded the parameters incorrectly when using the 
coordinate reference system of Mercator (variant A). These files are now displayed as 
expected, and files with correctly defined CRS are unaffected by the changes.

The way that coordinate reference systems are read from the source for GML files has 
been changed. No functional changes are expected.

Installation

Installations are now only provided as full installations. Patch installations with roll-back 
capability are no longer supported.

Process Designer is now deployed as a separate module. No functional difference is 
expected.

Reference Description
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Process Designer

Running multiple processes concurrently through a Process Designer model could result 
in the application closing. Now, processes like exporting BAG that open or write data 
through the GDAL third party-library are run consecutively and not concurrently, and they 
complete successfully.

Many processes now add an appropriate file extension to the user-defined name for an 
output file. If an alternate extension is specified for the output file, the user-supplied 
extension is used.

The Data process in Process Designer has been updated to not warn about overwriting 
existing files. This was done to better support using the process as inputs for other 
processes. The Data process can also still be used for the output of processes.

Forward compatibility has been improved in Process Designer. It now has better support 
for opening process models created in newer software that have different option 
definitions. 

Because this fix was not in older versions, certain process models created in the current 
version may not work in older versions.

Python API

The coverage API no longer supports retrieving the “Position” internal band for raster 
surfaces.

Subset Editor

When auto-exaggeration was turned off, points were not displayed in the Subset Editor 2D 
View if the subset slice area was rotated. The exaggeration is now automatically adjusted 
in this case to ensure the points are drawn.

Support Files

01700985 Colour files (maps/ranges) could not be found if the Colour Maps option in the Files and 
Folders category of Tools > Options was set to a network location such as 
\\location\directory. This also caused the application to close when starting Subset Editor. 
Now, network locations can be used for the Colour Maps path.

The TrackLine colour map file shipped with BASE Editor is now the same as the version 
shipped with recent versions of CARIS HIPS & SIPS.

References to the OS GB 1936 ellipsoid have been added to the datum mapping support 
file used when importing points from GSF files.

Miscellaneous

01700882 The performance of selecting data has been improved, particularly for the case when the 
data is stored in a different coordinate reference system than is currently being used in the 
Display window.

Error messages for handling LAS files have been updated; some messages now display 
the name of the file being accessed.

Reference Description
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BASE Manager 

Engineering Analysis

Reference Description

Batch Tools

Comments specified in the ServerCombineToRaster process are now populated. They can 
be found in the Information attribute of the resulting raster surface.

Coverage Tools

Processes cannot change an existing BDB Server database coverage; processes can 
generate a new coverage from an existing BDB Server database coverage or edit the 
surfac vector object. Attempting to change an existing BDB Server database coverage will 
now give a more informative error. This happens, for example, when specifying a BOID for 
the input of the ClassifyRasterHolidays process.

The ServerCombineToRaster process now respects the type of bounding polygon 
specified in the options.

Database Connection

01700995 The performance of interacting with a BDB Server database has been improved by 
caching database properties after retrieving them the first time.

The default database queries file has been updated in the installation.

Miscellaneous

Improved error handling has been added for cases where geometries collapse during a 
transformation to a different coordinate reference system, such as an area collapsing to a 
line.

Reference Description

Conformance

The Contour by Reference Model command was always producing boundary objects in the 
output feature layer, regardless of the settings selected by the user. The Create 
Boundaries setting is now honoured when the process is run.

Volumes

Geometries used in comparative volume calculations have been made more exact to 
enhance the precision of the calculation. The resulting differences in areas and volumes 
are small (generally <0.1%) with the datasets tested in house.
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