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1. はじめに 
 

本書では、Windows 2000/XP(x86)/XP(x64)/Vista(x86)/Vista(x64)、Solaris 10(SPARC)、HP-UX 
11i(PA-RISC)、Redhat Enterprise Linux 3(x86) 用の Imagix 4D バージョン 6.4.0 について記述
してあります。本書には、ソフトウェアをシステムにインストールする前にお読みいただきたい重

要な情報が含まれています。 

 

2. サポートするプラットフォームおよびオペレーティングシステム 
Imagix 4D バージョン 6.4.0 がサポートするプラットフォームおよびオペレーティングシステムは、
以下の通りです。 

・x86 プロセッサ上で動作するWindows 2000/XP/Vista 

・x64 プロセッサ上で動作するWindows XP x64 Edition/Vista x64 Edition 

・SPARC プロセッサ上で動作する Solaris 10 

・PA-RISC プロセッサ上で動作する HP-UX 11i 

・x86 プロセッサ上で動作する Redhat Enterprise Linux  3 (RHEL 3) 

 

3. 使用上の注意点 
Imagix 4D バージョン 6.4.0を日本語環境でご利用頂く場合の注意事項についてご説明します。 

 

・ 日本語のディレクトリ名に保存されているソースファイル、あるいは、フルパス名のいずれか

に日本語のディレクトリが含まれるソースファイルを解析することができません。 

（回避策）英数字のディレクトリにコピーをとって、コピーされたファイルを使って、解析を

行ってください。 

・ プロジェクト名に日本語を利用することができません。 

（回避策）プロジェクト名には、英数字を使用してください。 

・ プロジェクトを日本語のディレクトリに作成すると、解析時にエラーになります。 

（回避策）プロジェクトは、日本語を含まないディレクトリに作成してください。 

・ 解析および表示をサポートしている日本語のエンコーディングは、Windows ではシフト JIS、
Solaris、HP-UX、RHEL 3では EUCのみです。これら以外のエンコーディングのソースファ
イルを解析する際は、事前に、サポートされているエンコーディングに変換してから解析を実

施してください。 

・  
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4. Imagix 4Dリリースノート 6.4.0 - 5.4.5からの変更点 

表記法 
当リリースノートは一連のセクションに分けられており、各セクションではツールの各分野におけ
る変更点を説明しています。変更点は、重大度に応じて 2つのカテゴリに分けられます。カテゴリ/
重大度はインデントのレベルにより次のように示されます。 

重要な新機能/変更 

その他の変更および修正 

バージョン番号が記述されていない場合、変更は最初の 6.0リリースで導入されたものです。 

C/C++ソースコードアナライザ 
-encmacオプションを追加しました。このオプションは外側のマクロ展開のどこかで展開されてい
るマクロについて、複数行からなるマクロ定義での行番号を追跡します。これらは、マクロ同士の

相互参照の構成に使用されます。これによってマクロ定義本体の中が色付けにより強調され、

Function Calls with Macrosビューからその場所にナビゲートすることができます。(C627 - 6.0.0) 

123ullのような整数リテラルを符号なしの long long型リテラルとするサポートを追加しました。
(C654 - 6.0.0) 

パラメータ宣言において多数の同じ名前が使用されているソースコードでのアナライザの速度が大

幅に向上しました。この現象が起きる代表的な例はMicrosoftのインクルードファイルです。
(C656 - 6.0.1) 

GNU C拡張機能の__gnuc_va_listを可変パラメータのリストに追加しました。(C667 - 6.0.0) 

extern "C" 変数宣言における型名の省略が可能になりました（Microsoft拡張機能）。(C670 - 
6.0.1) 

forループに対して生成される制御フロー情報が改善され、静的なバウンドがあるためにループに 1
回以上進入していることを Imagix 4Dデータフローアナライザに伝えるようになりました。(C671 
- 6.0.2) 

sizeofで括弧を付けずに単純な型名を使用可能とするMicrosoft拡張機能を追加しました。例：s = 
sizeof mytype;(C680a - 6.1.0) 

アドレスによる共用体の定義を可能とする IARコンパイラ拡張機能を追加しました。例：union 
{int a; float b;} @ 0x1234;(C684 - 6.1.0) 

-uaggrオプションを追加しました。このオプションは同じ名前を持つ最上位レベルのクラスの出現
ごとに一意の相互参照情報を生成し、実質的にそれらを異なるクラスにします。-uaggrオプション
により、同じ名前を持つクラスを別個のものとして扱うべき箇所での名前の衝突を避けることがで

きます。これは、複数のプログラム、DLL、または共有ライブラリにまたがっている Imagix 4D
プロジェクトに対応しています。一般に、これらを別々のプロジェクトに入れること、そして

Imagix 4Dのスーパープロジェクト機能を使用してグローバル・ビューを取得することが推奨され
ます。(C689 - 6.1.0) 

-trkarrayオプションを追加しました。このオプションは静的な配列要素の相互参照情報を追跡し
ます。これらの要素は Imagix 4Dのディスプレイにおいて array[1] などの別々の変数として表示
され、配列変数に含まれます。(H07-5 - 6.2.0) 

システムインクルードファイルに定義されている型について、追加の相互参照情報を作成しました

（システムインクルードファイルに関して他のデータが収集されていない場合）。これにより、

Imagix 4Dはより完全に型の関係をグラフに表示できるようになりました。以前はこれらの型はデ
ータベースから省略されていました。(C692 - 6.2.1) 

関数内部の#includeからのコードを Imagix 4Dのファイルエディタにおいてタグ付けできるよう
に、追加の相互参照情報を作成しました。(C713 - 6.2.0) 
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-msrcfxオプションを追加しました。このオプションは、インクルードファイルが複数回インクル
ードされ、その都度異なるソースコードを生成する場合に、追加の相互参照情報を生成します。こ

のオプションは通常、考慮されるすべての条件パスに対してデータを生成するオプションと共に使

用されるでしょう。これは相互参照情報を増大させることがあり、異なる定義設定に基づいて新し

いコードを生成するためにインクルードファイルを故意に複数回インクルードする場合にのみ意義

があるため、注意して使用すべきです。(C719 - 6.2.1) 

ISO C言語 1999標準規格に従って、__VA_ARGS_の取り扱いを追加しました。(C730 - 6.2.1) 

Microsoft 拡張機能の dllexportおよび dllimportを追加しました。クラスの名前が複数の DLL間
で同一であることを強制するので、-uaggr(C689)と共に使用される場合に、特に有用です。(C734x 
- 6.3.0) 

123ui8や 123i16など、型に固有の整数リテラルのためのMicrosoft DDK拡張機能を追加しました。
(C746 - 6.3.0) 

ラベルおよびラベル式のアドレス（計算された'goto'）に対応した、GNU C/C++拡張機能を追加し
ました。(C758 - 6.3.1) 

extern "C"の前でMicrosoft declspecを使用可能とするMicrosoft拡張機能を追加しました。(C761 
- 6.3.1) 

テンプレートパラメータに依存する typenameを解析する際の、未定義の typenameに関
する誤った警告を除去しました。(C631 - 6.0.0) 

未定義のマクロ使用についての相互参照情報を除去しました。そのようなマクロ名が後に

異なって定義される可能性があるため、そのような相互参照情報は誤解を招きかねません。

(C655b - 6.0.0) 

2つの C++の関数が同一であるかを解決するために使用されるパラメータのチェックを変
更しました。現在では、パラメータ型はすべて潜在型に削減されています。以前は、中間

の typedefが使用可能でした。また、これは C++関数に対して生成された相互参照データ
ベース内の改変された名前を変更し、完全なパラメータ型が Imagix 4Dのディスプレイ
に表示される場合にユーザから可視となります。(C655 - 6.0.0) 

インクルードファイルと同じ名前を持つディレクトリがあった場合に発生していた、「再

オープンできない」というエラーメッセージを除去しました。(C666 - 6.0.0) 

クラス名または型名の解決を修正し、後に中間の名前空間のエイリアス(例： namespace 
n2 = n1; using namespace n2;) を付けられるようにしました。(C673 - 6.0.1) 

クラス内の無名の共用体メンバを、それを囲むスコープ内で可視にしました。(C673 - 
6.0.1) 

マクロ展開における一致しないパラメータに関する誤った警告を除去しました。(C680c - 
6.1.0) 

型名の解決を修正しました。コンテキストで型名が必要とされている場合、ルックアップ

を型名に限定することにより、それ以外の方法では隠される型名が認識されるようにしま

した。(C680d - 6.1.0) 

クラスの解決を修正しました。基底クラス名が関数または変数によって隠されている場合、

コンテキストによりそれがクラスでなければならないと判定されるため、依然として解決

の必要があります。(C681 - 6.1.0) 

#ifdefディレクティブでのマクロ使用箇所を示す行番号の情報を修正しました。(C682 - 
6.1.0) 

インクルードファイルからの 1行からなる関数が制御フロー情報に複数回記録されないよ
うにし、フローチャートの表示が Imagix 4Dで正しく動作するようにしました。(C683 - 
6.1.0) 

複数個のファイルに広がった構文エラーに関する行情報を改善しました。(C694 - 6.1.0) 

シンボル型の解決を修正しました。C++の場合、クラス名が同じ有効範囲内の同名の変数、
関数、または列挙子によって隠蔽されるようにしました。また、enumタグ名が相互参照
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情報において同じ有効範囲内にある変数名とは異なるようにし、Imagix 4Dがそれらを
別々に表示できるようにしました。(C697 - 6.1.0) 

クラスメンバのテンプレート関数の識別方法を修正しました。例：

object.templatefunction<int, int>(x, y);(C701a - 6.2.0) 

展開を行う前に一連のマクロ再定義が発生する、特定の状況下でのマクロ展開を修正しま

した。(C701b - 6.2.0) 

再定義されたクラスメンバがトークン並び -> Classname <... にかかわる場合、テンプレ
ートのインスタンス化がソースコードの解釈の 1つであるとみなされるように解析を修正
しました。(C701c - 6.2.0) 

C++においてネストされた extern "C"コードに現れる関数に対して正しいリンケージ名が
生成されるように、解析を修正しました。この動作は、これらの関数が Cの関数本体と
正しく相互参照されるために必要です。(C708 - 6.2.0) 

構文エラーが見つかった後での不要なエラーメッセージのカスケード表示を減らしました。

(C711 - 6.2.0) 

sizeof classnameの直後に for文が続く箇所での誤った構文エラーを修正しました。
(C715 - 6.2.1) 

function<T1>(exp, constructor<T2>(var)()); のような、特殊化されたテンプレート関数
のネストされた呼び出しに関する解釈を修正しました。(C726 - 6.2.1) 

どのファイルが関数ポインタを割り当てているかを追跡するための相互参照情報を作成し

ました。(C729 - 6.2.1) 

システムインクルードファイル内のマクロの再定義であるマクロについて、マクロ情報を

作成しました(システムインクルードファイルに関して他のデータが収集されていない場
合)(C733 - 6.3.0) 

初期化子の関数名の最初にある余分な"*"に対する制御フロー情報を修正しました。これ
により、データフローレポートでこのようなケースが正しく処理されます。(C739- 6.3.0) 

ある 16進リテラルがマクロと混在している箇所でのマクロ展開を修正しました。(C749 - 
6.3.0) 

ネストされた再帰的な型に対する sizeofの計算のパフォーマンスを最適化しました。
(C763 - 6.3.1) 

変換であるか型仕様であるかがあいまいな int (* const... の解決を改善しました。(C767 - 
6.3.2) 

struct型の前方宣言をインクルードするパラメータ型に関する相互参照情報を修正しまし
た。(C770 - 6.3.2) 

wchar_tを明示的な事前定義の型として Imagix 4Dの相互参照情報に追加しました。こ
れにより、wchar_t型であるプログラム要素のユーザ検索が可能となりました。(C775 - 
6.4.0) 

プリプロセッサディレクティブにより生成されたソースコードの省略部分の始点と終点を

調整しました。現在、囲んでいる#ディレクティブ行は解析対象とみなされます。これに
より、ファイルエディタにおいてグレーで影を付けられる行が変化します。(C777 - 
6.4.0) 

テンプレート実引数の終端についての識別方法が修正されました。以前は、ある種の複雑

かつネストされたテンプレートのインスタンス化では、解析においてテンプレート実引数

の終端が不明となることがありました。これによって"abandoning template arguments"
という偽のエラーメッセージと、後続するいくつかの副次的なエラーが発生していました。

(C779 - 6.4.0) 
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その他のデータ収集 
../imagix/user/cc_cfgディレクトリには、gnu gccコンパイラの様々なバージョンに適用可能な.inc
コンパイラ構成ファイルがいくつか含まれています。gcc コンパイラは構成可能な範囲が広いため、
これらの.incファイルでさえもユーザの環境に合わせて構成する必要があります。コンピュータの
環境固有のビルド向けに最適化された.incファイルを自動的に作成する、新しいユーティリティの
imagix-gnuが追加されました。(6.3.0)このユーティリティが特定のWindows環境に対応するため
に修正されました。(6.3.1) 

ソースアナライザのエラーや警告メッセージに関する技術サポートとのやり取りを容易にするため

に、メッセージとそれらが関連するソースコードと基盤となる Imagix 4Dの環境に関するさまざま
な情報を 1つにまとめる関数が追加されました。このまとめられた情報は Imagix社または販売代
理店の技術サポートに送ることができます。この関数には、Analyzer Resultsウィンドウの File -
>Export...メニューからアクセス可能です。情報は../your_project.4D/analyzer_logファイルに書き
込まれます。2つのバージョンのログファイルを作成できます。デフォルトのバージョンでは実際
のソースコードを示し、マスクされたバージョンではシンボル名がすべて一般的な名前に置き換え

られます。(6.1.0) 

gnu_xxxx.inc 群を改善しました。(6.0.2) 

MSVC Workspaceのデータ収集アプローチを使用する際に特定のワークスペース/ソリュ
ーションの構成(Debugや Releaseなど)を選択する機能を追加しました。(6.1.0) 

MSVC ProjectまたはMSVC Workspaceのデータ収集アプローチを使用する際の/F1オ
プションのサポートを追加しました。(6.1.0) 

msvc_win.inc 内のMSVCバージョン番号を修正しました。(6.1.0) 

arm_cross.incを改善しました。(6.1.0) 

新しい iar_arm.incを追加しました。(6.2.0) 

iar_8051.inc、iar_avr.inc、iar_cr16c.inc、および iar_hc12.incを改善しました。(6.2.0) 

IBM Visual Ageコンパイラ用に新しい ibm_aix.incを追加しました。(6.2.1) 

MSVC Projectのデータ収集アプローチを使用する際の.dspパス名におけるスペースのサ
ポートを修正しました。(6.2.1) 

metrowerks_hiware.incを改善しました。(6.2.1) 

Windows環境の特定の条件下で、解析結果を analyzer_log ファイルにエクスポートでき
ないという問題を解決しました。(6.3.0)マクロ展開が失敗するという問題を解決しました。
(6.3.1) 

新しい freescale_hcxx.incを追加しました。(6.3.0) 

gnu_xxxx.inc群を改善しました。(6.3.1) 

Windows DDKのサポートをmsvc_win.incに追加しました。(6.3.2) 

MSP430を ti_cross.incに追加しました。(6.3.3) 

MSVC ProjectまたはMSVC Workspaceのデータ収集アプローチを使用する際、Visual 
Studioのプロジェクト定義において Exclude From Buildの設定が可能になりました。
(6.3.3) 

プロファイルデータのインポートの際に、すでに無効となったデータの表示および進捗バ

ーをクローズする処理を修正しました。(6.3.3) 

統合されたディスプレイウィンドウ 
Imagix 4Dの 6.xバージョンにおいて最も際立った変更点は、以前のユーザインターフェース表示
の大部分が 1つのディスプレイウィンドウに統合されたことです。 
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File Editor、Flow Chart、Calculation Tree、Metrics Tool、および様々な Reportなど、以前は固
定されていなかったディスプレイの多くが従来の Graphウィンドウと結合され、統合ディスプレイ
ウィンドウのMainパネルが形成されました。 

また、従来の Projectパネルおよび Symbolパネルも拡張されました。それらのパネルには、File 
Browser、Class Browser、Use Browser、Grep Toolなど以前は固定されていなかった他のディス
プレイのいくつかが含まれています。さらに、新しい機能も導入されています。 

ディスプレイを一箇所にまとめるほか、新しいMainパネルでは同種のウィンドウの複数インスタ
ンス（10個まで）をサポートしています。例えば、最大 10個の Graph、最大 10個の Flow Chart、
および最大 10個の Calculation Treesを同時に開くことが可能になりました。以前は、複数インス
タンスは File Editorにおいてのみサポートされていました。 

デフォルトでは、様々なディスプレイの複数のインスタンスがノートウィジェット内にタブとして

現れます。ノートは、横並びまたは縦並びの 2つのノートに分割可能です。ノートが 2つに分割さ
れているとき、個々のタブ付きディスプレイを一方からもう一方へとドラッグすることができます

(タブ名を使用)。 

MDIディスプレイメカニズムは、タブ付きのノートに代わる手段として利用可能です。 

ノートまたはMDIによる方法のどちらかを使用して、実際のディスプレイを切り離し、統合ディ
スプレイウィンドウとは別に表示させることができます。 

この変更の一部として、あるディスプレイに固有のメニュー項目はそのディスプレイに移動したた

め、メインメニューの一部ではなくなりました。従来のメニュー項目のほとんどは、最終的に

Graphウィンドウに組み込まれました。 

ツール全体にわたってマウスとキーボードの割り当てが変更され、より直感的で一貫性のあるもの

となりました。マウスの右クリックスによるコンテキストセンシティブメニューの項目は、追加の

ディスプレイウィンドウに対応して拡張されました。 

Graphウィンドウ 
統合ディスプレイウィンドウの変更の一部として、それぞれ独自のメニューを持つ 10個の Graph
ウィンドウを同時に表示させることが可能になりました。その時々で、これらのうち 1つがアクテ
ィブな Graphウィンドウとみなされます。アクティブウィンドウでは、強調されるシンボルが黄色
で表示され、他のウィンドウではそれらが白で表示されます。Graphウィンドウを使用する際は常
に、それがアクティブウィンドウになります。 

「モード」の概念を Graphウィンドウから削除しました。以前は UML Diagramモードおよび
Control Flowモードで提供されていたグラフディスプレイは、単にビューとして Viewメニューに
より提供されるようになりました。(6.4.0) 

多くのグラフィックディスプレイおよび従来の Browseモードの動作は、現在は Symbolsパネルの
Cross Referenceタブから使用できます。 

ビュー可能なシンボル型および関係型を選択する主要なメカニズムは、従来の Set Viewダイアロ
グから、Viewメニューの下にある一連の事前定義のビューに替わりました。Set Viewダイアログ
は現在、メニュー項目 Other...から利用可能です。カスタムビューでの名前空間の包含をクラスと
は別に制御できるように、新しいシンボル型が追加されました。Set Viewメニューから定義された
ビューを保存して、事前定義ビューのリストに追加することができます。 

6つの標準の事前定義ビューが追加されました。 

File Callsはソースコード内のファイルおよびそれらの間の呼び出し関係を示します。これらの呼
び出しはファイルメンバ間の呼び出しが抽象化されたものです。例えば、FileA.cにある FuncAが
FileB.cにある FuncBを呼び出す場合、FileA.cは FileB.cを呼び出すとみなされます。この機能は、
制御フローの観点からどのファイルが他のどのファイルに関係しているかを診断する際に役立ちま

す。(6.4.0) 

Namespaces and Classes は名前空間とクラスとの間にあるコンテナと継承関係を示します。以前
は、名前空間はクラスおよびテンプレートと組み合わせて様々なビューに表示されていました。現
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在は名前空間は別に扱われ、このビューにのみ表示されます。このビューは名前空間の内容が理解

できるように最適化されます。 

Class Callsはソースコード内のクラスおよびそれらの間での呼び出し関係を示します。これらの呼
び出しはクラスメンバ間の呼び出しが抽象化されたものです。例えば、 ClassA::FuncA が
ClassB::FuncBを呼び出す場合、ClassAは ClassBを呼び出すとみなされます。この機能は、制御
フローの観点からどのクラスが他のクラスのどれに関係しているかを診断する際に役立ちます。

(6.4.0) 

Class HasType はデータタイプとして他のクラスで使用されているクラスを示します。これはクラ
スのデータ相互依存性のいくつかを診断する際に役立ちます。(6.4.0) 

Function Calls with Set Variablesは関数呼び出しおよび関数での変数のセットを示します。これ
は変数のセットと読み取りの両方が表示される Function Calls with Variablesビューを補完するビ
ューです。(6.4.0) 

Function Calls with Macrosは関数呼び出しおよび関数でのマクロの使用を示します。これはソフ
トウェアのマクロ定義に何が隠蔽されているかを理解する際に役立ちます。 

File Build、Classes and Calls、Class Use、Type Useの 4つの事前定義ビューが削除されました。 

Traverse機能に、1組の新しい機能として Unique Upおよび Unique Downが追加されました。
これらは Full Upおよび Full Downと同様の機能ですが、グラフ内の他のシンボルからも到達可能
であるシンボルを除外します。(6.1.0) 

Filter機能に、Hide Libraryが追加されました。これはグラフからライブラリ関数を削除する簡単
な方法を提供します。 

新しい関数として Analyzeが追加されました。Analyzeダイアログはコンテキストセンシティブメ
ニュー（シンボルの右クリックで表示）の Analyze...メニュー項目から利用可能です。Analyzeダ
イアログには実行可能な解析のリストが含まれており、そのうち大部分については新しいグラフウ

ィンドウが表示されます。この機能により、関心のある情報を表示するグラフの作成が大幅に迅速

化および簡素化されます。Analyze機能のごく一部の機能をサポートしていた AutoQuery機能は
削除されました。(6.0.0 - 6.4.0) 

手動によるグラフレイアウトの持続性が大幅に拡大されました。グラフレイアウトに対するユーザ

の最適化は、グラフの周囲にシンボルをドラッグすることによって常に可能です。この最適化は新

しいシンボルがグラフに追加されるときにも持続するようになりました。新しい機能の Automatic 
Layoutが Editメニュー項目およびアイコンに追加されました。この機能は自動レイアウトに復元
します。(6.3.0) 

いくつかのビューについて、以前は Viewメニューから利用可能であった表示フォーマットのオプ
ションが、新しい Displayメニューから利用可能になりました。UML Diagramビューでは、これ
らのコントロールは以前は View->Set Viewメニュー項目で提供されていました。構成関連のビュ
ーでは、これらはメトリックス情報をグラフで色分けするためのコントロールになっています。

(6.4.0) 

新しいコントロールにより、あるレポート（特に Functions Not Used In Tasksレポート）からグ
ラフへと情報を色分けして示すことが可能になりました。(6.3.0) 

マウスの右クリックによるコンテキストセンシティブな操作が拡張されました。拡張された操作の

中には、グラフの空白部分またはグラフ内の関係をクリックしたときの新しい操作が含まれます。 

グループメンバと構造体メンバの衝突を解決しました。(6.2.0) 

ブックマークおよび元に戻す/やり直しの機能を拡張し、ビューをまたがった変更に対応
するようになりました。(6.2.1) 

structureビューグラフでのシンボルの位置をブックマークに追加し、復元されたブック
マークにグラフレイアウトに対するユーザの最適化が含まれるようにしました。(6.3.0) 

Set Viewが同一セッションの複数のプロジェクトから開かれたときに発生していた障害
を解決しました。(6.3.3) 

Manage Groupsダイアログの外観と動作を改善しました。(6.3.3) 
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グラフでの元に戻す/やり直す操作において、グループの処理を修正しました。(6.3.3) 

Control Flowビューのレイアウト順序を改善しました。順序には最上位のシンボルだけ
ではなく、前のカラムのすべてのシンボルが考慮されるようになりました。(6.4.0) 

UML Diagram Set Viewダイアログのメンバ有効範囲の定義を変更し、パラメータを含
めるようにしました。これにより、メンバのフィルタリング設定はパラメータとローカル

変数の両方に作用します。(6.4.0) 

Control Flowビューおよび UML Diagramビューでのズーム/パンの機能を拡張しました。
白またはグレーの背景をもつグラフでパンしたときの見やすさが改善されました。(6.4.0) 

UML Class Diagramビューで Aggregates関係の Informationオーバレイにフォーカス
したときのクラッシュを解決しました。(6.4.0) 

Edit -> Automatic Layout のアイコンとメニューを同期させました。(6.4.0) 

Control Flowビューでのブックマークの復元を修正しました。(6.4.0) 

Select -> Find and Filter -> Addダイアログでのディレクトリ名のマッチングを改善しま
した。(6.1.0)ダイアログの Options部分の分かりやすさが改善されました。(6.4.0) 

Flow Chartウィンドウ 
統合ディスプレイウィンドウの変更の一部として、それぞれ独自のメニューを持つ 10個の Flow 
Chartウィンドウを同時に表示させることが可能になりました。デフォルトでは、各 Flow Chart
はMainパネルの一部として表示されます。 

複雑なプログラムロジックを持つ関数で操作する際の Flow Chartを簡素化するために、Flow 
Chartをユーザ指定のデシジョンポイントで折りたたむことにより、図の一部を隠すことができま
す。この機能はマウスの右ボタンクリックによるコンテキストセンシティブメニューによって制御

されます。出力される図では、該当するデシジョンポイントおよびそれに対応するデシジョンの終

結点より内側にあるどのロジックも表示されません。(6.2.0) 

Highlightメニューに、強調の新しい選択肢として Editor Selectionを追加しました。
(6.0.0)強調表示を修正しました。(6.1.0) 

ElseIf構文の偽の行を取り除きました。(6.3.0) 

Calculation Tree 
統合ディスプレイウィンドウの変更の一部として、それぞれ独自のメニューを持つ 10個の
Calculation Treeを同時に表示させることが可能になりました。デフォルトでは、各 Calculation 
TreeはMainパネルの一部として表示されます。 

データフロー解析により生成される Calculation Treeディスプレイに、新しい Display設定として、
関数間での割り当てフローに関する情報を表示するか抑止するかの設定が追加されました。表示す

る場合は、フローパスから現在の場所へと呼び出される関数のどのステートメントも、現在の値に

影響を与えていればリストされます。また、現在の計算に関係していれば、グローバル変数のファ

イルレベルの初期化もリストされます。(6.3.3) 

より大規模なプロジェクトでの Calculation Treeの使用を可能にするために、拡張仮想メモリスキ
ームが追加されました。詳しくは、当リリースノートの Flow Check のセクションをご覧ください。
(6.3.0) 

C++のクラスメンバに対応するために、Calculation Treeが拡張されました。(6.4.0) 

Variable Tableタブのデータ関連の障害を解消しました。(6.2.1) 

Mainパネル内の 2つのノート間での、Calculation Treeタブのドラッグ操作を修正しま
した。(6.3.0) 

Calculation Treeのユーザインターフェースを改善し、Calculation Treeディスプレイ全
体の中で内側のノート/タブを使用するようにしました。(6.2.1)改善および修正を行いま
した。(6.3.2) 
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複数の Calculation Treeディスプレイ間でのデータの衝突を解消しました。(6.3.2) 

Printダイアログを同期させ、Calculation Treeディスプレイを修正しました。(6.3.2) 

Calculation Treeディスプレイを生成する際のパフォーマンスを改善しました。複雑なプ
ロジェクトでの計算時間に関する警告を追加しました。(6.3.3) 

Variable Dependenciesタブのレイアウトおよび情報表示を改善しました。(6.3.3) 

Calculation Treeの変更に合わせ、ツールチップを更新しました。(6.4.0) 

File Editorウィンドウ 
デフォルトでは、各 File EditorはMainパネルの一部として表示されるようになりました。 

ファイル内でのシンボルへのスクロールを容易にするため、ファイルメンバのリストが追加されま

した。このリストはスライドアウトのウィジェットであり、File Editorアイコンバーの右に表示さ
れる新しいアイコンから利用可能です。Tools -> Options (General タブ)ダイアログにチェックボ
ックスがあり、これによってスライドアウトをクリックする必要があるか、または単にカーソルを

アイコンの上に置けばよいかを制御します。 

File Editorディスプレイの左側に行番号を表示できるようになりました。行番号表示の有無は、メ
ニュー項目の Options -> Layout -> Show Line Numbersにより制御されます。(6.3.0).行折り返し
が有効である場合には、行の付番に誤りが生じるため、機能が無効にされました。(6.3.1) 

一部のレポートでは、レポート結果に関連するソースコードの行を、File Editorの左側に示すこと
ができます。Functions Not Used in Tasks レポートおよび Recursive Functions レポートでは、
この表示はメニュー項目の Options -> Report Dataにより制御されます。Skipped Linesレポート
では、この表示はメニュー項目の Options -> Data Display -> Code Skipped by Source Analyzer
により制御されます。(6.3.0) 

Control-Sのサポートを追加しました。Control-Sを押すと File Editorの内容が保存され
るようになりました。 

Homeキーと Endキーの動作を、標準的な用法に一致するように変更しました。(6.1.0) 

Save As操作におけるファイル名の問題を解決しました。(6.1.0) 

カット/コピー/ペーストのクリップボード操作を改善しました。(6.1.0) 

プロジェクトデータの更新または再生成におけるファイル保存の操作を修正しました。

(6.2.1) 

読みやすさを向上させるため、様々なシンボル型の表現に使用される色を少し変更しまし

た。さらに、ライブラリ関数を示す色が標準の関数を示す色と少し異なるようにしました。

また、ローカル変数を示す色が標準の変数を示す色と少し異なるようにしました。(6.2.2) 

Control-Fのサポートを追加しました。Control-Fを押すと、File Editorの一番上にある
検索入力フィールドにフォーカスが移動するようになりました。Control-Fを押した時点
でテキストが強調表示されていれば、そのテキスト文字列が検索に使用されます。(6.3.1) 

ファイルメンバリストのスライドアウトウィジェットに、ファイル順にするかアルファベ

ット順にするかのユーザ選択が追加されました。(6.4.0) 

Automountパス名またはデータベースに存在しないファイルに対する File -> Openのサ
ポートが追加されました。(6.4.0) 

プリプロセッサディレクティブにより生成されたソースコードの省略部分の始点と終点を

調整しました。現在、囲んでいる#ディレクティブ行は解析対象とみなされます。これに
より、ファイルエディタにおいてグレーで影を付けられる行が変化します。(6.4.0) 

File Editorの変更に合わせ、ツールチップを更新しました。(6.4.0) 
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プロジェクトパネル 
統合ディスプレイウィンドウの左側のカラム全体をカバーするように Projectパネルの領域が拡張
されました。Projectパネルタブを表示するために 2つのノートが提供されており、2つのタブを同
時に表示することができます。Displayタブは（タブ名の）ドラッグ＆ドロップにより、一方のノ
ートから他方のノートへと移動させることができます。 

従来の File Browserは Projectパネル内の File Indexに統合されました。従来の File Browserに
あったMembersタブ、RelationshipsタブおよびMetricsタブは、File Indexの右上隅にある新し
い>>>アイコンから、スライドアウトタブとして利用できます。Tools->Options(Generalタブ)ダイ
アログにチェックボックスがあり、これによってスライドアウトをクリックする必要があるか、ま

たは単にカーソルをアイコンの上に置けばよいかを制御します。フォーカスしているファイルのソ

ースチェック違反を表示する新しいタブとして、Source Checksが追加されました。 

新しいタブとして Namespace Indexが追加されました。以前は、名前空間はクラスおよびテンプ
レートと組み合わせて様々なビューに表示されていました。 現在は、名前空間は別に処理されます。 

従来の Class Browserは Projectパネル内の Class Indexに統合されました。従来の Class 
BrowserにあったMembersタブ、RelationshipsタブおよびMetricsタブは、Class Indexの右上
隅にある新しい>>>アイコンから、スライドアウトタブとして利用できます。Tools-
>Options(Generalタブ)ダイアログにチェックボックスがあり、これによってスライドアウトをク
リックする必要があるか、または単にカーソルをアイコンの上に置けばよいかを制御します。 

以前は固定されていなかった Grep Toolが Projectパネルに統合されました。 

新しいタブとして Database Lookupが追加されました。これは Grepツールを補完するもので、テ
キスト文字列ではなくシンボル名のプロジェクト全体での検索をサポートします。名前検索ではワ

イルドカード文字(*)を使用できます。 

Graph Symbolsタブが改善され、可視のシンボルの表示に加えて、選択されたシンボルだけを表示
するか、あるいはシンボルの数を要約して表示する機能が加わりました。ユーザインターフェース

では Graphウィンドウを最大 10個までサポートするようになったため、Graph Symbolsタブには
アクティブな Graphウィンドウに関する情報が表示されます。 

Homeキーと Endキーの動作を、標準的な用法に一致するように変更しました。(6.1.0) 

タイミングの問題によって時として発生していた、Graph Symbolsディスプレイが
Graphウィンドウと同期しなくなる現象を解決しました。(6.2.0) 

プロジェクトレベルの複雑度メトリックスを Project Summaryタブに追加しました。
(6.2.0)平均複雑度の計算を修正しました。(6.2.1) 

動作しなくなっていた、grepシンボルの強調表示を修正しました。(6.3.0) 

構造体と共用体を、Namespace Index の Members スライドアウトタブに追加しました。
(6.3.3) 

Grep Toolタブ内の grep文字列入力フィールドのスクロールを改善しました。(6.3.3) 

Graph Summaryタブの印刷出力の内容を修正しました。(6.3.3) 

スライドアウトタブがメインウィンドウの後ろに隠れてしまわないようにしました。

(6.4.0) 

シンボルパネル 
Symbolパネルの領域を拡張し、統合ディスプレイ・ウィンドウの下部のほとんどがカバーされる
ようにしました。Symbolパネルタブを表示するために 2つのノートが提供されており、2つのタ
ブを同時に表示することができます。Displayタブは(タブ名の)ドラッグ&ドロップにより、一方の
ノートから他方のノートへと移動させることができます。 

Symbolパネルにフォーカスするための新しい方法が追加されました。ツールの任意の場所で、シ
ンボルの上でマウスの右ボタンを(クリックするのではなく)長く(0.5秒以上)押すと、Symbolパネ
ルがそのシンボルにフォーカスします。従来のコンテキストセンシティブメニューによる Symbol
パネルにフォーカスする動作は依然として存在します。 



    12 

Copyright (C) 1994-2009 Imagix Corporation / 株式会社東陽テクニカ 

従来の Declarationタブが改善され、フォーカスされたシンボルの完全なソースコードを示すよう
になりました。例えば、関数が Symbolパネルでフォーカスされると、タブには関数の完全な定義
が表示されます。タブの名前が Source Codeに変更されました。 

Cross Referenceタブが追加されました。このタブではフォーカスされたシンボルのファンインと
ファンアウトがグラフィック表示されます。このタブは Browseモードにおいては従来の Graphウ
ィンドウと同様に動作し、フォーカスと緊密にリンクしており、Symbolsタブの残りの要素のフォ
ーカスを決定付けるかそれに従います。グラフの表示オプションは、グラフの背景の空白部分を右

クリックすることによって表示されます。 

従来の Use Browserは、Usageタブとして Symbolパネルに統合されました。以前は、固定されて
いない別のディスプレイウィンドウでした。従来のユーザ設定のいくつかを削除し、タブがより自

動的に機能するようになりました。(6.0.0)関数ポインタの位置の解析が改善されました。(6.2.1)シ
ステム関数ポインタのサポートを追加しました。(6.3.0) 

Historyタブが追加されました。これにより、Symbolパネルで前にフォーカスしていた場所に戻る
ことができます。(6.3.0) 

File Location タブが改善され、フォーカスされたシンボルの定義と共に宣言の場所も示
すようになりました。 

Cross Referenceグラフ内にメトリック値によって偽りの色付けが表示されるのを解消し
ました。(6.2.1) 

Usageタブを、他のシンボルの宣言に使用されるシンボルに対して適切なファイルからソ
ースコードの行を表示するように修正しました。(6.3.3) 

Usageタブおよび Historyタブの印刷処理を修正しました。(6.3.3) 

Metricsウィンドウ 
統合ディスプレイウィンドウの変更の一部として、従来のMetrics Toolの様々なディスプレイが、
Mainパネルの一部であるディスプレイとしてビュー可能になりました。 

ファイルレベルでは、6つのメトリックスが追加されました。それらは Functions in File、Total 
Cyclomatic Complexity、Average Cyclomatic Complexity、Maximum Cyclomatic Complexity、
Halstead Program Volume、Maintainability Indexです。(6.2.0) 

新しいメトリックスディスプレイとして Namespace Metricsが追加されました。以前は,名前空間
はクラスおよびテンプレートと組み合わせてメトリックスディスプレイに表示されていました。現

在は名前空間は別に処理され、メンバ数を示すソフトウェアメトリックスの小さい集合だけを実際

に名前空間に使用できます。(6.2.0) 

クラスレベルでは、7つのメトリックスが追加されました。それらは Internal Methods Called、
External Methods Called、Chidamber/Kemerer Class Coupling、External Methods and 
Coupling、Average Cyclomatic Complexity、Maximum Cyclomatic Complexity、Halstead 
Program Volumeです。(6.2.0) 

いくつかのクラスメソッドに対し、代替の計算方法が追加されました。Lack of Cohesion of 
Methodsメトリックスには、Chidamber/Kemererメソッドペア共有計算および
Li/Henry/Hitz/Montazeriの別の依存グラフ計算が、Henderson/Sellers の標準計算のオプション
として利用可能です。Internal Methodsメトリックスおよび External Methodsメトリックスには、
さらに別の計算オプションが利用可能です。これらの計算方法は Tools -> Options(Metricsタブ)ダ
イアログを通して選択されます。(6.2.0, 6.2.1) 

関数レベルでは、5つのメトリックスが追加されました。これらは、McCabe Decision Density、
McCabe Essential Complexity、McCabe Essential Density、Knots、Halstead Program Volume
です。(6.2.0) 

クラスメソッドを Response for Classメトリックスの計算に追加しました。(6.2.0) 

Chidamber/Kemerer Class Coupling、Chidamber/Kemerer Lack of Cohesion of 
Methods、および External Methods Calledの各メトリックスの計算を変更しました。
(6.2.1) 
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スクロール中のメトリックスの表示更新を修正しました。(6.2.1) 

ステートメントによりソートする際の問題を解決しました。(6.2.1) 

Javaコードに対する Depth of Inheritance Treeメトリックスの計算における問題を解決
しました。(6.3.1) 

Java .classファイルに対して Knotsメトリックスを計算しようとする問題を解決しまし
た。(6.3.1) 

フローチェックレポート 
拡張された仮想メモリスキームを使用するすべてのフローチェックレポートでメモリ容量を増やし、

関数間のデータフロー解析に必要とされる相当量のメモリ要件に対処しています。Imagix 4D では、
データフロー解析での中間的な計算に最大 64GBのディスク格納領域を使用できるようになりまし
た。以前のフロー解析は、50Kから 100Kのステートメントと関数を持ちサイクロマチック複雑度
が 200未満であるプロジェクトにしか現実的には適用できませんでした。この改善により、関数の
サイクロマチック複雑度が 200を超えない限り、100Kから 500Kのステートメントを持つさらに
大規模なプロジェクトを処理することができます。関数がより複雑である場合でも解析は実行可能

ですが、より大きいプログラムでは実行時間が数時間かかる可能性があります。500K以上のステ
ートメントおよび多数の複雑な関数を持つプロジェクトでは、解析が完了しない可能性が高いです。

可能であれば、それらをより小規模なプロジェクトに分割することをお勧めします。(6.3.0) 

Task Flow Checksメニューにある新しいレポートの Functions Not Used in Tasksは、直接呼び
出されない関数、または定義したタスクから関数ポインタにより呼び出されない関数をすべてリス

トします。タスクを全く定義していない場合、すべてのルート関数がタスクであるとみなされ、こ

のレポートにはどの関数もリストされません。このレポートには Display設定があり、それによっ
てライブラリ関数のリスト表示の有効/無効を切り替え、名前、ファイル、またはディレクトリ名な
どによってリストの順序を変えることができます。(6.3.0) 

Mismatched Critical Regionsレポートでは、従来提供されていた関数呼び出しの始点または終点
がない領域に加え、あいまいなステートメントおよび関数を表示するようになりました。あいまい

なステートメントとは、1つの制御フロー内のクリティカルな領域により保護され、別の制御フロ
ーで保護を解除されている可能性があるステートメントです。同様に、あいまいな関数とは 1つの
制御フローケースで保護され、別の制御フローで保護を解除されている可能性がある関数全体です。

これらのリストは一致しない領域に関するもう 1つのビューをユーザに提供します。この情報を使
用して、クリティカルな領域の保護呼び出しを追加することによりこれらの制御フローを改善すべ

きかどうかを決定することができます。 

Variables Set in Multiple Tasksレポートおよび Reentrant Functionsレポートは特定の用途に関
係するクリティカルな領域の名前を、保護インジケータの隣にリストします（下のスクリーンショ

ット参照）。識別しやすくするため、クリティカルな領域の名前はレポートの始めにリストされま

す。またこれらのレポートではステートメントが保護されるかどうかを判定する際、すべてのクリ

ティカルな領域を考慮します。以前は、最後に定義されたクリティカルな領域だけが使用されてい

ました。(6.2.0) 
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すべてのフローレポート、特に Uninitialized Variables Read、Mismatched Critical Regions、お
よび Out of Step (Z) Variablesでは、C/C++ソースアナライザによって提供される、forループに関
する追加情報を使用します。静的な境界が存在していて、forループに 1回以上入っていることを
アナライザが判定すると、フロー解析では無条件にループに進入します。これは whileループと do
ループのフローの違いに似ており、1つめは最初に条件があり、2つめはただちにループに進入し
ます。(6.0.2) 

Variable Flow Between Tasksレポートでは、複数の潜在的な関数呼び出しを通してセッ
トされる変数について、複数回セットされるとみなします。これは"SS"により示されます。
以前は、これらが単一のセットを示す"S"でフラグされることがありました。同様にこの
レポートでは、呼び出された関数内の別の割り当てがフロー解析に含まれるため、いくつ

かの変数フローの分類を"R,S"または"RR,SS"から"R,*"に変更しました。(6.0.2) 

Reentrant Functionsレポートでは、同じ関数の複数回の出現を解消し、レポート内の冗
長部分を減らしました。(6.1.0) 

いくつかのレポートにおけるメモリ使用量を削減しました。(6.2.0) 

Out of Step (Z) Variablesレポートは、呼び出し階層のほか行番号に基づいて関数の並び
をソートします。以前は、同じレベルにある関数呼び出し（if文または switch文での分
岐など）が、ランダムに順序付けされることがありました。(6.3.1) 

ソースの複数箇所に宣言を持つ変数について、レポートが正しく宣言の 1つをリストする
ようになりました。以前は、レポートでは間違ったファイルからの行番号で変数をリスト

することがありました。 

Uninitialized Variables Readレポートは、変数が実際には現在の使用へのパス上で呼び
出された関数によってセットされる箇所について、以前は偽の肯定をリストしていました。 

Reentrant Functionsレポートに、複数のクリティカルな領域に関する報告を追加しまし
た。(6.4.0) 

その他のレポート 
すべてのレポートに適用される新しいオプションを使用すると、レポートの最初の起動時に実際に

レポートが実行されないように設定できます。このオプションを指定してレポートを起動すると、

結果となるレポートは空白で表示されます。これによってユーザは、レポートが実際に実行される

前にレポートのメニュー項目を通してレポートの設定を変更することができます。集中的に計算が

行われるレポートでは、これによって大幅に時間を節約できます。(6.3.0) 

Include Analysisレポートの出力結果は、シンボルの従属性の基本計算を改善したことにより大幅
に改訂されました。(6.3.3) 

新しいレポートとして Similar Functionsが追加されました。このレポートはある評価基準に基づ
いて、類似する構成体を持つ関数を特定します。類似性はユーザ設定により定義され、名前、相互

参照ファンアウト、および一連のメトリックス（McCabe Cyclomatic Complexity、Halstead 
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Program Difficulty、および Number of Statements）のさまざまな組み合わせを含みます。例え
ば、このレポートはデフォルトでは、90%の類似した名前と 90%の類似したファンアウトを持つか、
90%の類似した名前と 90%の類似したメトリックス値を持つか、90%の類似したファンアウトと
90%の類似したメトリックス値を持つ関数をリストします。このレポートは、類似したコードの統
合をめざしたリファクタリングの努力をサポートします。またこれは、類似した関数でバグが発生

したためにバグ修正の適用の必要があると思われる関数を特定するのに役立ちます。(6.2.0) 

新しいレポート関数として Import Reportが追加されました。レポートを特殊な.4drフォーマット
で保存し、のちのセッションで Import Report機能を使用してそれを再オープンすることにより、
計算が集中的に行われるレポートの再生成に要する時間を節約することができます。また、Import 
Reportレポートにより他のツールからのデータを Imagix 4Dにインポートした後、Imagix 4Dを
使用して、他のツールにより発生したソフトウェアの問題を調べることができます。 

Import Reportを通してインポートされるレポートに期待されるフォーマットを変更しま
した。(6.1.0) 

一部のスクロール操作を改善しました。(6.3.3) 

Similar Functionsレポートにおける相互参照の類似に関する計算を修正しました。
(6.3.3) 

Class Summary合計から名前空間を除去しました。(6.3.3) 

ソースチェックの Potential Static Functionから非関数を除去しました。(6.3.3) 

-msrcオプションを使用したときのソースチェックの重複エントリを除去しました。
(6.3.3) 

ソースチェックレポートにおいて Omittedとして示される行の整合性を改善しました。
(6.4.0) 

Include Analysisレポートにおける varスタイル変数の解析を修正しました。(6.4.0) 

その他のユーザインターフェースおよび情報の表示 
Helpメニューから利用可能な入門ツアーが 6.xの機能を示すように更新され、ツールにロードされ
た任意のプロジェクトと共に機能するように改善されました。その結果、ユーザは Imagix 4Dの機
能が自分のコードに対してどのように動作するかを調べることができます。 

Informationオーバーレイに表示されるプレースメントおよびグループの情報が改善され
ました。(6.1.0) 

Windowsの内部メニューに対するツールチップの掲示を修正しました。(6.1.0) 

メインウィンドウ起動時の大きさと位置の設定に、より一貫性をもたせました。(6.3.2) 

Toolsメニューから複数ウィンドウが起動される現象を修正しました。(6.3.3) 

メニューおよびアイコンの有効/無効の切り替えを改善しました。(6.3.3) 

ローカルおよびパラメータについて、Informationオーバーレイに表示される情報を改善
しました。(6.4.0) 

Informationオーバーレイにタスク情報を追加しました。(6.4.0) 

Optionsダイアログ、コンテキストセンシティブヘルプ、ツールチップ、およびツアーか
らモードに関する記述を削除しました。(6.4.0) 

ドキュメントの生成 
名前空間のドキュメント出力に新しいセクションが追加されました。以前は、名前空間はクラスお

よびテンプレートと組み合わせてクラスセクションに表示されていました。現在は、名前空間は別

に処理されます。 

Internet Explorer 7での大きい.pngファイルの表示を修正しました。(6.0.0) 

ドキュメントのクラスセクションが不適切に省略されないようにしました。(6.1.0) 
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HTMLドキュメント上のソースコードセクション間のナビゲーションを改善しました。
(6.1.0) 

変数および関数ポインタに対してどのサブセクションが生成されるかを修正しました。

(6.2.0) 

HTML ドキュメントの一番上に Struct セクションが二重に表示されないようにしました。
(6.2.0) 

ライブラリ型のサポートを追加しました。(6.2.1) 

DocGenシートに、相互参照グラフのレイアウトおよびコンテンツ用のコントロールを追
加しました。(6.2.1) 

手動でフローチャートの失敗を通知する必要性をなくしました。(6.2.1) 

相互参照レイアウト、コンテンツ制御および新しいメトリックスに対応してサンプル.dgn
シートを更新しました。(6.3.0) 

プロジェクトの全体より小さい範囲をカバーするドキュメントについて、ソースコードの

断片を修正して正しいファイルから抽出されるようにしました。(6.3.3) 

ソースアナライザの-vuidオプションを使用して部分的または分散型の HTMLドキュメ
ントを生成する際の、参照の衝突を修正しました。(6.3.3) 

'enum'リテラルについて、読み取られる箇所を示すように用途の情報を変更しました。
(6.4.0) 

出力の印刷 
Mainパネルのディスプレイには、ローカルの Fileメニューを通して利用可能な独自の Printダイ
アログが用意されています。(6.0.0)一番上のメニューバーの Printダイアログが、追加のディスプ
レイを扱うために改善されました。(6.2.0)Printダイアログが改善されました。.pngファイルにつ
いて、グレースケール出力が選択できるようになりました。グラフの背景を逆にするオプションが

追加されました。フォーマットを変更するとファイルの接尾語が自動的に更新されるようになりま

した。(6.4.0) 

Visio .vdxフォーマットのサポートを追加したことにより、Visio2003以降のバージョンの
Microsoft Visioへのエクスポートが可能になりました。(6.3.1)Calculation Treeに.vdxフォーマッ
トを追加しました。(6.3.2). 

.png出力に、16ビットの日本語の文字に対するサポートを追加しました。(6.1.0) 

Windowsの.png出力で、Arialの文字を使用できるようになりました。(6.2.1) 

プリンタへの出力について、用紙サイズの最適化機能を改善しました。(6.3.0) 

.png出力およびプリンタへの出力について、白い背景を持つグラフでの色の変換を修正
しました。(6.3.2) 

.vdx出力に、SJISに対するサポートを追加しました。(6.3.2) 

.csv出力について、正方形とテキストがあるグラフの印刷を修正しました。(6.3.3) 

.ps出力について、ボックスのサイズ変更用の線がある Control Flowビューの印刷を可能
にしました。(6.4.0) 

.txt出力について、Analyzer Resultsウィンドウの印刷を修正しました。(6.4.0) 

.vdx出力について、HTML特殊文字を含む名前の印刷を修正しました。(6.4.0) 

.vdx出力について、Graphウィンドウのコメントの印刷を修正しました。(6.4.0) 

.png出力およびプリンタへの出力について、Graphウィンドウのコメントにおける日本
語の文字の印刷を修正しました。(6.4.0) 

.png出力について、コメントと幅の広い文字列を持つ Flow Chartの出力における関数名
およびコメントの位置を修正しました。(6.4.0) 
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プリンタへの出力について、フォントサイズの計算を改善することにより文字が重ならな

いようにしました。(6.4.0) 

バッチモード/コマンドラインでの起動 
ブックマークデータのオープンに関連する問題を解決しました。(6.2.0) 

ファイルの編集内容の保存が cmmdRegenerateProjectDataに干渉しないようにしました。
(6.2.2) 

cmmdOpenProjectを同一コマンドファイル内で複数回起動できるようにし、複数のプロ
ジェクトを連続的にオープンできるようにしました。(6.3.2) 

相互参照の印刷処理が cmmdDocument出力に干渉しないようにしました。(6.3.2) 

名前空間メトリックスを、デフォルトの cmmdMetricsの起動により生成される出力に追
加しました。(6.3.3) 

cmmdMetrics出力のカラム名から偽りのカンマを除去しました。(6.3.3) 

位置を示す引数が与えられていない場合の cmmdMetricsコマンドおよび
cmmdReportMultipleコマンドの出力位置を修正しました。(6.4.0) 

インストール 
Vista環境下でのインストールを簡素化しました。(6.0.0) 

imagix-licsppt.batユーティリティにおけるディレクトリ名の中のスペースの取り扱いを
修正しました。(6.1.0) 

ライセンス認可メカニズムにおいてユーザ名の大文字/小文字を区別しないようにしまし
た。(6.1.0) 

MACアドレスの読み取りのサポートを Vistaの外国語バージョンに追加しました。
(6.3.2) 

ソフトウェア使用許諾契約も含め、日本語サポートのインストールを改善しました。

(6.4.0) 
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5. 株式会社東陽テクニカへのお問合せ 
株式会社東陽テクニカは、Imagix Corporation の日本国内における総代理店です。 

日本国内でのお問合せについては、株式会社東陽テクニカへお願いします。 

 

株式会社 東陽テクニカ 

ソフトウェア・ソリューション 

 

郵便番号 〒103-8284 

住所 東京都中央区八重洲 1-1-6 

電話 03-3245-1248(直通) 

FAX 03-3246-0645 

E-Mail(営業窓口) ss_sales@toyo.co.jp 

E-Mail(サポート窓口) ss_support@toyo.co.jp 

E-Mail(ライセンス窓口) ss_lic@toyo.co.jp 

 

6. Imagix Corporation へのお問合せ 
以下に示す Imagix Corporationに直接お問合せいただくこともできます。 

 

電話 +1 805 781 6002 

FAX +1 805 781 6003 

E-Mail(営業窓口): sales@imagix.com 

E-Mail(サポート窓口): support@imagix.com  

 

7. 保証の免責 
株式会社東陽テクニカおよび Imagix Corporationは、作成時に細心の注意を払って本書を正確に
記述することに努めておりますが、本書内の誤りや欠落に関する責任は負いかねます。また、本書

内の記述通りに製品が動作することを表現かつ意味する保証書として作成された文書ではないこと

をお断りしておきます。 

 

8. 著作権について 
本書には著作権があり、全体または一部を問わず、どのような方法(電子的またはその他)によって
も、Imagix Corporationの文書による事前の承諾なしには、複製、再生、公開、転記、翻訳、縮小
を行うことはできません。 

 

9. 商標 
本書内に示した他の全ての製品やサービスには、それらを販売する企業で選定された商標、サービ

スマーク、製品名が含まれます。 


